Not all windows can be minimised directly

Reported by James Haigh on 2011-08-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Sam Spilsbury

Bug Description

All windows should be minimisible. There should be an /option/ to ignore the 'disable minimise' request defined in the extended window manager hints. (I'm not counting gksu-style authentication overlay dialogs as windows.)

If a window is waiting for a minimised dialog to close, it should /only/ focus and restore the dialog if it receives mouse or keyboard input. See bug #832301.

James Haigh (james.r.haigh) wrote :

I should have selected Ayatana Design, shouldn't I.

James Haigh (james.r.haigh) wrote :

To be able to minimise dialogs, bug #832301 will need to be fixed. Otherwise, when the dialog is minimised the parent window will get focus and immediately unminimise the dialog again.

John Lea (johnlea) wrote :

@James

Hi, I have just tried to reproduce your bug by;

1. Opening a bunch of windows, and then opening a gedit 'Open Files' dialogue
2. Pressing CTRL-ALT-D

This successfully minimises all windows, could you provide some step by step instructions to reproduce?

thanks!

James Haigh (james.r.haigh) wrote :

John, replace step 2 with 'Press Alt-F9'.

The point I was making about Super-D (or Ctrl-Alt-D), is that the ability to minimise some windows seems to have been deliberately disabled, but it's actually /possible/ to minimise any window.

See this screenshot, notice that there is no minimise button. Pressing Alt-F9 does nothing.

Some windows request not to be minimized as per the extended window
manager hints. This is not a bug. You have to minimize it's ancestor
(eg parent window)

see: http://standards.freedesktop.org/wm-spec/wm-spec-1.3.html#id2507474

On Thu, Aug 25, 2011 at 4:37 AM, James Haigh <email address hidden> wrote:
> John, replace step 2 with 'Press Alt-F9'.
>
> The point I was making about Super-D (or Ctrl-Alt-D), is that the
> ability to minimise some windows seems to have been deliberately
> disabled, but it's actually /possible/ to minimise any window.
>
> See this screenshot, notice that there is no minimise button. Pressing
> Alt-F9 does nothing.
>
> ** Attachment added: "no-minimise.png"
>   https://bugs.launchpad.net/ayatana-design/+bug/830637/+attachment/2309939/+files/no-minimise.png
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/830637
>
> Title:
>  Not all windows can be minimised
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/830637/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Changed in compiz (Ubuntu):
status: New → Invalid
status: Invalid → In Progress

Oh, actually, reopening.

This is somewhat different, the default show desktop method is to minimize all windows. You can enable a plugin like showdesktop or fadedesktop to get a different behaviour I guess. Needs design feedback as to what they actually want, but we won't have time to do this for O

Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → later
description: updated
summary: - Not all windows can be minimised
+ Not all windows can be minimised directly
James Haigh (james.r.haigh) wrote :

"Some windows request not to be minimized as per the extended window manager hints. This is not a bug."

This is was the kind of thing I was expecting; I knew it was an intended feature.

So in this case, what I'm asking is that there should an /option/ to ignore 'disable minimise' requests from windows such as dialogs.

Bug #832301 will also need to be solved in order to prevent the dialog that has just been minimised from immediately popping up again.

"You have to minimize it's ancestor (eg parent window)"

I'm aware that this can be done using the mouse, but seriously, try doing that with the keyboard! Alt-Tab, Alt-F9 doesn't work because the Alt-Tab fails to select the parent due to bug #832301.

"This is somewhat different, the default show desktop method is to..."

I have not experienced /any/ issue with show desktop. I was merely making a point that a restriction has been imposed. I now understand that this restriction is the 'disable minimise' request defined in the extended window
manager hints you tell me about.

Oh BTW, what is the real name for the 'disable minimise' request?

Thanks.

Matthew Paul Thomas (mpt) wrote :

James, the original version of this bug report might not have been valid, but your revised version almost certainly isn't. What use would it be to have an option for whether some windows should be minimizable? What reason would any two people ever have for choosing different values for that setting?

> "You have to minimize it's ancestor (eg parent window)"
>
> I'm aware that this can be done using the mouse, but seriously, try
> doing that with the keyboard! Alt-Tab, Alt-F9 doesn't work because the
> Alt-Tab fails to select the parent due to bug #832301.

Yes, this should be fixed.

>
>
> "This is somewhat different, the default show desktop method is to..."
>
> I have not experienced /any/ issue with show desktop. I was merely making a point that a restriction has been imposed. I now understand that this restriction is the 'disable minimise' request defined in the extended window
> manager hints you tell me about.
>
> Oh BTW, what is the real name for the 'disable minimise' request?
>

There is no such request. Windows must actually specify that they wish
to be minimized by setting the _NET_WM_ALLOWED_ACTIONS hint. If the
actions in _NET_WM_ALLOWED_ACTIONS do not contain
_NET_WM_ACTION_MINIMIZE then the window is not allowed to be minimized
(windows that do not set this hint are allowed to be minimized by
default).

see: http://standards.freedesktop.org/wm-spec/1.3/ar01s05.html#id2523223

That being said, for dialog windows with their WM_TRANSIENT_FOR hint
being set to another toplevel window we explicitly disable
minimization, since the dialog window is meant to be minimized at the
same time as its parent.

> Thanks.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/830637
>
> Title:
>  Not all windows can be minimised directly
>
> Status in Ayatana Design:
>  New
> Status in “compiz” package in Ubuntu:
>  In Progress
>
> Bug description:
>  All windows should be minimisible. There should be an /option/ to
>  ignore the 'disable minimise' request defined in the extended window
>  manager hints. (I'm not counting gksu-style authentication overlay
>  dialogs as windows.)
>
>  If a window is waiting for a minimised dialog to close, it should
>  /only/ focus and restore the dialog if it receives mouse or keyboard
>  input. See bug #832301.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/830637/+subscriptions
>

--
Sam Spilsbury

I'm afraid that presently this bug is a request to override application functions made by developers. As stated at freedesktop, this bug would be contrary to the spec.

Furthermore, with the advent of modal dialogues the whole point is moot, anyway (provided Ubuntu ever implements them).

Changed in ayatana-design:
status: New → Opinion
Changed in compiz (Ubuntu):
status: In Progress → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments