[Oneiric] Dash doesn't always auto-pick the best colour, add disable/pick colour option to CCSM?

Reported by David Raid on 2011-08-13
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Dash's new Chameleon-like feature of autodetecting the most frequent colour in the desktop background is a very cool touch, but it doesn't always look best with a wallpaper.

Could an option to either turn this off (defaulting back to black) or change the colour from auto to a custom colour be added to CCSM?

David Gomes (davidgomes) wrote :

I have to agree with this, we need to try and make this customizable.

Omer Akram (om26er) on 2011-08-17
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in unity:
importance: Undecided → Wishlist
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

What do you mean by "doesn't always look best"? Can you attach an example screenshot or two? Thanks.

Changed in ayatana-design:
status: New → Incomplete
dahias (wengahias) wrote :

The readability of the Dash-text is horrible bad in general and really worst if you use bright wallpapers. Just try around and you will see.
i very much liked the dash-style in 11.04. it's doesn't distract one's eyes from using the dash like chameleon does.
nevertheless chameleon is nice, but it should be dyked more black to increase readability.

But the point is:
It's completly illogical to include gtk-themes like "High-Contrast" to improve accessibility for visually handicapped people, but don't give an option to disable or modify the "chameleon"-feature.

dahias (wengahias) wrote :

Added an Screenshot to show that a very common Usecase (opend browser while using dash) results in white text on white Dash.
Wallpaper was Ubuntus default one.

Maybe a Fix like in related Bug #837993 could help to improve this a little. But for sure this won't be enough for visually handicapped people. > Thats why Options are very important to modify the dash-effect to one's specific needs.

David Raid (davidraid) wrote :

This bug is not a duplicate of #837993. #837993 is the duplicate, due to it being opened later. Why was it necessary to create a new bug rather than post the offered solution here? I find that in bad taste.

Additionally, my suggestion was to add the ability to manually choose the colour, giving the option to turn this new chameleonic feature off.

thom (tsk) wrote :

Regression of this bug:

Again, launcher behaves like a chameleon.....manual override is broken.
Come on guys, this is bad engineering: Designrule #1: Manual ALWAYS overrides automation

thom (tsk) wrote :

additional info:
Ubuntu 12.04
unity:
  Geïnstalleerd: 5.10.0-0ubuntu3
  Kandidaat: 5.10.0-0ubuntu3
  Versietabel:
 *** 5.10.0-0ubuntu3 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

unity-2d:
  Geïnstalleerd: 5.10.0-0ubuntu1
  Kandidaat: 5.10.0-0ubuntu1
  Versietabel:
 *** 5.10.0-0ubuntu1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

David Raid (davidraid) wrote :

I have already commented that this is not a duplicate of 837993, please say why you disagree before you just mark it as such.

837993 is "Where the average background colour is either very light or dark, adjust this value to darken/lighten in order to preserve readability"

That bug refers to the brightness of the colour making text difficult to read. A fix for this bug would NOT be to touch the colour, as in THIS bug, but to change the brightness settings.

THIS bug is "Dash doesn't always auto-pick the best colour, add disable/pick colour option to CCSM"

This refers to that the colour being picked from the wallpaper is not always appropriate and the best visually appealing complimenting colour for the Dash to use. It has NOTHING to do with the problem of readability of text and the bug fix would be different.

If you disagree, please state your reasoning.

I totally agree with this. Ambiance theme was looking really nice in 11.04 and 11.10 but now its consistency is broken by this effect. If you have a blue background (and therefore a blue dash and launcher) and open nautilus, you get a window dominated by brown and black, surrounded by blue => ugly combination.

Haneef Mubarak (haneefmubarak) wrote :

I would say that it ought to be looked at seriously: Marked as Confirmed.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Daniel van Vugt (vanvugt) wrote :

In Ubuntu 12.04 at least, there is such an option to configure the colour:
CCSM > Ubuntu Unity Plugin > Experimental > Background Color

Just remember to set a high opacity (> 200) or the additive blending of the launcher will look ugly.

If you wish to return to the default behaviour of automatic colour section, just set Opacity=0.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:unity at revision 1723 (Fri 2011-10-21)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers