Activity log for bug #824965

Date Who What changed Old value New value Message
2011-08-12 04:41:42 Jeremy Bicha bug added bug
2011-08-12 04:41:55 Jeremy Bicha bug task added unity
2011-08-12 20:28:26 Jeremy Bicha summary Alt-Tab switcher should switch to an app tile that is clicked [alt-tab] switcher should switch to an app tile that is clicked
2011-08-17 21:04:19 Omer Akram bug task added ayatana-design
2011-08-17 21:04:46 Omer Akram unity: status New Incomplete
2011-08-17 21:04:48 Omer Akram unity (Ubuntu): status New Incomplete
2011-08-18 09:31:33 John Lea ayatana-design: assignee John Lea (johnlea)
2011-08-18 09:31:38 John Lea ayatana-design: importance Undecided Low
2011-08-18 09:31:43 John Lea ayatana-design: status New Fix Committed
2011-08-18 09:31:51 John Lea tags amd64 apport-bug oneiric running-unity amd64 apport-bug oneiric running-unity udo
2011-08-18 10:51:23 Omer Akram unity: status Incomplete Confirmed
2011-08-18 10:51:25 Omer Akram unity (Ubuntu): status Incomplete Confirmed
2011-09-21 16:28:55 Omer Akram unity: importance Undecided Low
2011-09-21 16:28:58 Omer Akram unity (Ubuntu): importance Undecided Low
2011-09-21 16:29:56 Omer Akram description 1. Open up several apps (for instance, a web browser, a game, a file manager and a terminal). Don't have the apps maximized. 2. Press Alt+Tab. Hold down the Alt key and click the tab selector so that the game is active. 3. While continuing to hold down Alt, use your mouse to click the terminal tile Expected behavior: Unity should switch to the terminal since the mouse click overrides where the tab happened to end up. Alternate example: 3. While continuing to hold down Alt, change your mind and click to the actual file manager in the background. Expected behavior: Unity should switch to the file manager since the mouse click overrides the Alt+Tab behavior. Other notes: Gnome Shell works the way I expect; it would be nice for Unity to do the Right Thing also. ProblemType: Bug DistroRelease: Ubuntu 11.10 Package: unity 4.8.0-0ubuntu1 ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1 Uname: Linux 3.0.0-8-generic x86_64 Architecture: amd64 CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell] Date: Fri Aug 12 00:24:55 2011 InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007) SourcePackage: unity UpgradeStatus: Upgraded to oneiric on 2011-06-17 (55 days ago) 1. Open up several apps (for instance, a web browser, a game, a file manager and a terminal). Don't have the apps maximized. 2. Press Alt+Tab. Hold down the Alt key and click the tab selector so that the game is active. 3. While continuing to hold down Alt, use your mouse to click the terminal tile Expected behavior: Unity should switch to the terminal since the mouse click overrides where the tab happened to end up. Alternate example: 3. While continuing to hold down Alt, change your mind and click to the actual file manager in the background. Expected behavior: Unity should switch to the file manager since the mouse click overrides the Alt+Tab behavior. Other notes: Gnome Shell works the way I expect; it would be nice for Unity to do the Right Thing also. =====User testing result===== In user testing we found that several users tried to use the pointer to select applications/windows when alt-tab was open. The requested change is to enable the use of the pointer and left click to select a specific app/window. Left clicking on a app/window should close the alt-tab and bring the selected item into focus. ProblemType: Bug DistroRelease: Ubuntu 11.10 Package: unity 4.8.0-0ubuntu1 ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1 Uname: Linux 3.0.0-8-generic x86_64 Architecture: amd64 CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell] Date: Fri Aug 12 00:24:55 2011 InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007) SourcePackage: unity UpgradeStatus: Upgraded to oneiric on 2011-06-17 (55 days ago)
2011-09-21 16:30:18 Omer Akram unity: assignee Jason Smith (jassmith)
2011-09-21 16:30:24 Omer Akram unity (Ubuntu): assignee Jason Smith (jassmith)
2011-09-28 16:28:05 John Lea ayatana-design: status Fix Committed Fix Released
2011-10-18 16:49:14 John Lea tags amd64 apport-bug oneiric running-unity udo amd64 apport-bug oneiric running-unity udo udp
2011-10-18 16:49:19 John Lea ayatana-design: status Fix Released Fix Committed
2011-10-18 16:49:24 John Lea unity: milestone backlog
2011-12-14 02:26:36 Marco Trevisan (Treviño) bug added subscriber Marco Trevisan (Treviño)
2011-12-14 14:09:58 John Lea summary [alt-tab] switcher should switch to an app tile that is clicked Alt-tab - When alt-tab is open, the user should be able to left click with the pointer on a specific app/window in order to select it
2011-12-14 14:11:38 John Lea description 1. Open up several apps (for instance, a web browser, a game, a file manager and a terminal). Don't have the apps maximized. 2. Press Alt+Tab. Hold down the Alt key and click the tab selector so that the game is active. 3. While continuing to hold down Alt, use your mouse to click the terminal tile Expected behavior: Unity should switch to the terminal since the mouse click overrides where the tab happened to end up. Alternate example: 3. While continuing to hold down Alt, change your mind and click to the actual file manager in the background. Expected behavior: Unity should switch to the file manager since the mouse click overrides the Alt+Tab behavior. Other notes: Gnome Shell works the way I expect; it would be nice for Unity to do the Right Thing also. =====User testing result===== In user testing we found that several users tried to use the pointer to select applications/windows when alt-tab was open. The requested change is to enable the use of the pointer and left click to select a specific app/window. Left clicking on a app/window should close the alt-tab and bring the selected item into focus. ProblemType: Bug DistroRelease: Ubuntu 11.10 Package: unity 4.8.0-0ubuntu1 ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1 Uname: Linux 3.0.0-8-generic x86_64 Architecture: amd64 CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell] Date: Fri Aug 12 00:24:55 2011 InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007) SourcePackage: unity UpgradeStatus: Upgraded to oneiric on 2011-06-17 (55 days ago) 1. Open up several apps (for instance, a web browser, a game, a file manager and a terminal). Don't have the apps maximized. 2. Press Alt+Tab. Hold down the Alt key and click the tab selector so that the game is active. 3. While continuing to hold down Alt, use your mouse to click the terminal tile Expected behavior: Unity should switch to the terminal since the mouse click overrides where the tab happened to end up. Alternate example: 3. While continuing to hold down Alt, change your mind and click to the actual file manager in the background. Expected behavior: Unity should switch to the file manager since the mouse click overrides the Alt+Tab behavior. Other notes: Gnome Shell works the way I expect; it would be nice for Unity to do the Right Thing also. User testing notes: In user testing we found that several users tried to use the pointer to select applications/windows when alt-tab was open. ---------------------------------- Desired solution: - The requested change is to enable the use of the pointer and left click to select a specific app/window. Left clicking on a app/window should close the alt-tab and bring the selected item into focus. - Additionally the mouse scroll wheel should be active and allow the user to change focus in either direction
2011-12-14 14:11:59 John Lea ayatana-design: importance Low Medium
2011-12-15 08:57:05 Igor Khoroshev bug added subscriber Igor Khoroshev
2011-12-29 13:04:29 dahias bug added subscriber dahias
2012-02-17 17:29:12 Andrea Cimitan tags amd64 apport-bug oneiric running-unity udo udp amd64 apport-bug oneiric running-unity top5p udo udp
2012-02-20 10:15:49 Adam Niedling bug added subscriber Adam Niedling
2012-02-20 15:54:03 John Lea ayatana-design: importance Medium Critical
2012-02-20 21:41:53 Adam Niedling bug task added unity-2d
2012-02-24 22:46:23 Launchpad Janitor unity-2d (Ubuntu): status New Confirmed
2012-02-25 11:40:44 Burkart Lingner bug added subscriber Burkart Lingner
2012-02-26 01:37:22 Marco Trevisan (Treviño) branch linked lp:~3v1n0/unity/alt+tab-scroll-wheel
2012-04-18 16:40:42 entonjackson bug added subscriber entonjackson
2012-06-25 12:43:40 Omer Akram unity (Ubuntu): assignee Jason Smith (jassmith)
2012-06-25 12:43:44 Omer Akram unity: assignee Jason Smith (jassmith)
2012-06-25 16:09:16 John Lea unity: status Confirmed Triaged
2012-06-25 16:09:21 John Lea unity (Ubuntu): status Confirmed Triaged
2012-07-11 13:13:06 ArTaX bug added subscriber ArTaX
2012-10-10 16:02:09 John Lea unity: importance Low High
2012-10-10 16:02:12 John Lea unity (Ubuntu): importance Low High
2012-10-10 16:02:15 John Lea bug task deleted unity-2d (Ubuntu)
2012-10-12 13:26:38 John Lea bug task deleted unity-2d (Ubuntu)
2012-10-15 16:24:58 John Lea bug task deleted unity-2d (Ubuntu)
2012-10-15 16:25:01 John Lea bug task deleted unity-2d
2012-11-14 01:17:23 Marco Trevisan (Treviño) unity: assignee Marco Trevisan (Treviño) (3v1n0)
2012-11-14 01:17:25 Marco Trevisan (Treviño) unity (Ubuntu): assignee Marco Trevisan (Treviño) (3v1n0)
2012-12-05 15:42:44 Stephen M. Webb unity: assignee Marco Trevisan (Treviño) (3v1n0) Unity Maintainers (unity-maintainers-team)
2012-12-05 15:42:53 Stephen M. Webb unity (Ubuntu): assignee Marco Trevisan (Treviño) (3v1n0) Unity Maintainers (unity-maintainers-team)
2012-12-20 00:37:28 Thibaut Brandscheid bug added subscriber Thibaut Brandscheid
2013-01-02 14:22:29 Stephen M. Webb unity: assignee Unity Maintainers (unity-maintainers-team) Stephen M. Webb (bregma)
2013-01-02 14:22:33 Stephen M. Webb unity (Ubuntu): assignee Unity Maintainers (unity-maintainers-team) Stephen M. Webb (bregma)
2013-01-02 17:12:04 Stephen M. Webb unity: status Triaged In Progress
2013-01-02 17:12:08 Stephen M. Webb unity (Ubuntu): status Triaged In Progress
2013-01-09 17:50:25 John Swing bug added subscriber John Swing
2013-01-31 23:43:20 Michael Basse bug added subscriber Michael Basse
2013-04-25 13:59:42 Stephen M. Webb unity: milestone backlog 7.1.0
2013-05-19 09:31:31 dino99 tags amd64 apport-bug oneiric running-unity top5p udo udp amd64 apport-bug precise running-unity top5p udo udp
2013-06-20 13:07:32 Stephen M. Webb unity: milestone 7.1.0 7.1.1
2013-07-16 17:52:23 Brandon Schaefer unity: assignee Stephen M. Webb (bregma) Brandon Schaefer (brandontschaefer)
2013-07-16 17:52:26 Brandon Schaefer unity (Ubuntu): assignee Stephen M. Webb (bregma) Brandon Schaefer (brandontschaefer)
2013-07-16 17:53:08 Brandon Schaefer branch linked lp:~brandontschaefer/unity/alt+tab-mouse
2013-08-12 02:54:58 PS Jenkins bot unity: status In Progress Fix Committed
2013-08-12 03:58:42 Brandon Schaefer unity (Ubuntu): status In Progress Fix Committed
2013-08-12 13:52:11 Launchpad Janitor unity (Ubuntu): status Fix Committed Fix Released
2013-10-10 17:29:09 Stephen M. Webb unity: status Fix Committed Fix Released
2014-05-17 10:32:44 Irfan Fauzan ayatana-design: assignee John Lea (johnlea) Irfan Fauzan (theblackhat-mj29)
2014-05-17 10:32:49 Irfan Fauzan unity: assignee Brandon Schaefer (brandontschaefer) Irfan Fauzan (theblackhat-mj29)
2014-05-17 10:32:55 Irfan Fauzan unity (Ubuntu): assignee Brandon Schaefer (brandontschaefer) Irfan Fauzan (theblackhat-mj29)
2014-05-19 09:54:26 John Lea ayatana-design: assignee Irfan Fauzan (theblackhat-mj29) John Lea (johnlea)
2014-05-19 12:50:22 Marco Trevisan (Treviño) unity: assignee Irfan Fauzan (theblackhat-mj29) Brandon Schaefer (brandontschaefer)
2014-05-19 12:50:30 Marco Trevisan (Treviño) unity (Ubuntu): assignee Irfan Fauzan (theblackhat-mj29)
2015-10-14 16:19:15 Marco Trevisan (Treviño) tags amd64 apport-bug precise running-unity top5p udo udp amd64 apport-bug precise rls-w-incoming running-unity top5p udo udp