Merge the lenses into the Dash to gain launcher space and consistency

Reported by Niklas Rosenqvist on 2011-05-31
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Before the release of Unity the lenses seemed like nifty little applications but that completely changed due to it's implementation. The lenses today take up a launcher item space each and gets automatically added to the launcher on installation. That makes me discouraged to install and explore lenses since they would take up valuable launcher space. In my launcher I only want what I put there myself.

It also contradicts the statement in the wiki page for UbuntuArchitecture under “Design Principles” since the lenses can be reached from both the launcher and their search results are included when searching from the default dash:

“There should be exactly one recommended way to accomplish a task in the default installation, to promote consistent documentation and support”

Therefore I propose that the lenses should be integrated into the default Dash. When opening the Dash you should be presented with the most used lenses instead of how it is now with “Browse the internet”, “View pictures” (seriously, users already have Firefox in the launcher upon a fresh installation, does anyone really use those shortcuts?). When searching without selecting a specific lens the files & folders and applications results would be shown by default since I guess this is what most people want to find, like with Gnome-Do.

By implementing this change the launcher would be used purely for the users own launcher's and keep the lenses neatly organized and still easily accessible. (especially if the following change also was implemented: https://bugs.launchpad.net/unity/+bug/790591)

I first proposed this in the ayatana thread:
https://lists.launchpad.net/ayatana/msg05620.html

and then later refined it in:
https://lists.launchpad.net/ayatana/msg05999.html

View the attached image for a mockup of this feature.

description: updated

The same problem is discussed here but I think that the solution in this bug report is better:
https://bugs.launchpad.net/unity/+bug/759724

With this I mean the one I've submitted*

affects: unity → ayatana-design

Supposed to be only affecting Ayatana design so the unity entry is being marked invalid.

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid

I changed the bug to ayatana-design when I learned that it was a more appropriate category but then also changed the unity affections to invalid but later learned that those should stay the way they were. That's why I'm changing back the status to new.

Changed in unity:
status: Invalid → New
Changed in unity (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

is your request somewhat a duplicate of bug #761155?

Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Omer Akram (om26er) wrote :

Setting to incomplete and adding needs-design tag as we wait for Design.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
tags: added: needs-design
Matthew Paul Thomas (mpt) wrote :

Fixed in unity 4.x.

Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments