Searching for some proprietary software yields no results in software centre / application lens

Reported by haydoni on 2011-05-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned
software-center (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

In Ubuntu 11.04: If an new user wants to write a text document, they may not know which application to use (assuming they know very little). One option they may try is to type "Word" (the only term they know) into the dash, however this returns nothing. If they try the applications lens many non-supported applications are displayed (but not LibreOffice Writer -- which, unbeknown to him, is pre-installed).

Similarly for terms like Excel, Powerpoint (especially a problem as LO Draw is not installed by default), Paint,...
Currently, in the application lens "Photoshop" DOES return GIMP.

If an appropriate term is searched for open source alternatives should be displayed in dash/contact lens/software centre software.
So that, if a user types in "Word" he is immediately and clearly displayed alternative applications (notably LibreOffice Writer -- which he has installed).

Note: This was originally posted as a brainstorm idea, but I was told to file it as a bug, http://brainstorm.ubuntu.com/idea/27840/. Thankyou.

LibreOffice Writer is displayed in software center if you search for 'Word', but not in the apps lens. It seems to me like this bug is about the results of an App Lens search corresponding with the results in the same software center search. Am I right?

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to make Ubuntu better. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

Changed in ubuntu:
status: New → Invalid

I'm a little annoyed at this response since I was told to submit it as a bug
IN brainstorm! I mentioned this is the bug report...

" Note: This was originally posted as a brainstorm idea, but I was told
 to file it as a bug, http://brainstorm.ubuntu.com/idea/27840/.
 Thankyou."

As Brendan mentions, LO Writer comes up in a software centre search for
"word", the behaviour should be the same in the dash/application lens, so
this is a bug (!).

On 18 May 2011 20:26, Fabio Marconi <email address hidden> wrote:

> Thank you for taking the time to make Ubuntu better. Since what you
> submitted is not really a bug, or a problem, but rather an idea to
> improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm
> at http://brainstorm.ubuntu.com/ where it can be discussed, voted by the
> community and reviewed by developers. Thanks for taking the time to
> share your opinion!
>
> ** Changed in: ubuntu
> Status: New => Invalid
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/784557
>
> Title:
> Searching for some proprietary software yields no results in software
> centre / application lens
>
> Status in Ubuntu:
> Invalid
>
> Bug description:
> In Ubuntu 11.04: If an new user wants to write a text document, they
> may not know which application to use (assuming they know very
> little). One option they may try is to type "Word" (the only term they
> know) into the dash, however this returns nothing. If they try the
> applications lens many non-supported applications are displayed (but
> not LibreOffice Writer -- which, unbeknown to him, is pre-installed).
>
> Similarly for terms like Excel, Powerpoint (especially a problem as LO
> Draw is not installed by default), Paint,...
> Currently, in the application lens "Photoshop" DOES return GIMP.
>
> If an appropriate term is searched for open source alternatives should be
> displayed in dash/contact lens/software centre software.
> So that, if a user types in "Word" he is immediately and clearly displayed
> alternative applications (notably LibreOffice Writer -- which he has
> installed).
>
> Note: This was originally posted as a brainstorm idea, but I was told
> to file it as a bug, http://brainstorm.ubuntu.com/idea/27840/.
> Thankyou.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+bug/784557/+subscribe
>

C de-Avillez (hggdh2) wrote :

Agreed. Consistency requires adding an alias for LO/OO/other text formatting packages. Reopening, since this *is* a bug.

Changed in ubuntu:
status: Invalid → New
importance: Undecided → Low
Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → unity (Ubuntu)
tags: added: needs-design
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Abhishek Singh (abhishek1729) wrote :

Since this is a behavioral (not technical) defect in Unity the changes have been made in accordance to Design Bugs in https://wiki.ubuntu.com/Unity/FilingBugs.

Didier Roche (didrocks) on 2011-07-05
Changed in unity:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers