Launcher - Unity launcher single missing/invisible/blank icon

Reported by Daniel van Vugt on 2011-04-29
512
This bug affects 99 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Marco Trevisan (Treviño)
5.0
High
Marco Trevisan (Treviño)
6.0
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Timo Jyrinki
Quantal
High
Marco Trevisan (Treviño)

Bug Description

[Impact]

Launcher icon missing/hidden.

[Test Case]

1) Open and close multiple times Openoffice from an .odt file

What should happen:
4) The icon in the launcher should not be an "?" or empty icon.

[Regression Potential]
Broken application tracking.

Original Description:

Binary package hint: unity

NOTE: This bug is about having a single invisible icon. If all your icons are missing then that's a different bug.

Dragged the Take Screenshot icon into the launcher. It's now totally invisible, but the blank space is still taking up space in the launcher.

I can left-click on the blank space and it correctly launches Take Screenshot. However right-click'ing on the blank space shows "Label Empty".

See attached screencast invisible_launcher_icon.ogv

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,vpswitch,place,imgpng,regex,unitymtgrabhandles,grid,session,gnomecompat,mousepoll,resize,move,animation,expo,ezoom,workarounds,wall,staticswitcher,fade,scale,unityshell]
Date: Fri Apr 29 15:00:43 2011
DistroCodename: natty
DistroVariant: ubuntu
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_AU.UTF-8
 LC_MESSAGES=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel van Vugt (vanvugt) wrote :
Daniel van Vugt (vanvugt) wrote :

Another screenshot for completeness, but look at the "missing_icons_rightclick.jpg" attachment above for a better idea of the problem.

UGN (eugene-korneev) wrote :

i have all icons invisible, but can move, rightclick and launch like normal.

summary: - Unity launcher missing/invisible/blank icon
+ Unity launcher single missing/invisible/blank icon
description: updated

Confirming, I see the exact same. I had Deja Dup on my panel, I got rid of it and added a few times, added it again and it shows as blank. Other new applications add fine.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-06-06
Changed in unity:
status: New → Confirmed
Ron (ron-11235) wrote :

I have the same issue with the gThumb icon. The following might be useful to anyone attempting to fix this bug.

3 systems (Ubuntu 11.04), one: 64bit (nVidia video), two: 32bit (netbook=intel video, desktop=ati video):

I have resized the Launch pad icons on all three. On the 64bit, and one 32bit (netbook) the gThumb icon can be dragged successfully to the launcher.

On the 32bit desktop (installed from scratch, identical to the netbook, same install disk) the gThumb icon does not show. If I copy the /usr/share/applications/gthumb.desktop file to my home directory (~/.local/share/applications) [and change permissions to "me," though that was for editing, it probably doesn't have anything to do with the problem], then drag that file to the launcher, the icon appears.

Hope that helps someone.

Furinkazan (mathieu-vidalies) wrote :

Try this :

sudo apt-get install gnome-icon-theme-extras gnome-icon-theme gnome-icon-themes gnome-icon-theme-full syslinux-themes-ubuntu syslinux-common syslinux-themes-debian

Daniel van Vugt (vanvugt) wrote :

I haven't seen this bug in a long time. I suspect it might be fixed now. Wait and see if anyone else can reproduce the bug in the coming weeks/months...

Omer Akram (om26er) wrote :

Closed on vanvugt's comment. thx.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

Just because I can't reproduce the bug now doesn't really prove anything. Other people might still have the bug.

If you do have this bug still, please comment here. Otherwise we can let the bug expire, slowly...

Changed in unity:
status: Invalid → Incomplete
Changed in unity (Ubuntu):
status: Invalid → Incomplete
Louis-Dominique Dubeau (ldd) wrote :

I experience this bug in Ubuntu 11.10.

I dragged Evolution from the dash to the launcher. There is an empty space where I dropped Evolution. If I click there, I do get Evolution to start but there is no feedback whatsoever from the launcher.

Right-clicking does not produce the "Label Empty" item but instead produces a blank menu item.

I'm going to attach a screenshot.

While I was writing this comment parts of the GUI crashed, including compiz and unity-panel-service. They were automatically restarted. After restarting, the icon appears properly.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed

This is definitely still happening. I just did a fresh install (today) of 11.10, updated all available updates including proposed and I still see the blank/missing icon problem. When I drag it from Dash to launcher it will just create an empty space. Also When I fire the app up from Dash it won't show up in launcher.
I'm not sure which apps are affected but it seems to me that it is fresh installs that are affected. After a reboot they work as expected.

To reproduce:
1. Install anything with a GUI from Software Center, do not restart
2. Open Dash and drag the icon of the app to the Launcher
3. Icon is missing, only an empty space is visible
4. Remove the empty icon and launch app from Dash, Launcher won't show the running program, neither will it show an empty space.
5. Try again to drag the icon from Dash to launcher, now it won't stick at all, not even an empty icon.
6. Try Alt+Tab to the running app, it wont show up.

Expected:
Icon should be visible after adding the app to launcher.

To fix:
A login/logout will usually fix this problem and icon is again visible, sometimes a reboot is needed.

Seems to me like something is not triggered after install.

Sebastien Bacher (seb128) wrote :

I can confirm it's still happening in precise

Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Mike G (bluplr) wrote :

Bug affected me in fresh install of precise. It was produced in a very similar fashion to oscar-tiderman. Fixed by rebooting.

Bug affected me in Natty, Oneiric and in a fresh install of Precise Pangolin. Only fix when i logout or restart the system.

Sebastien Bacher (seb128) wrote :

Daniel, is that the same issue than bug #978401?

Sebastien Bacher (seb128) wrote :

sorry I meant bug #978392

Daniel van Vugt (vanvugt) wrote :

seb128, yes that was a duplicate. Now marked as such.

Changed in unity:
milestone: none → 5.14.0
digobs (lester-davidm) wrote :

I confirm that this bug is also present on precise..

digobs (lester-davidm) wrote :

Bugs reproduction are here;

1/Test Bug1
(i) Open an application from the terminal and exit by the command ctrl-c or click on close bouton in your application (repeat the procedure three times at least)
(ii) Then drag the same application icon from the dash to launcher
(iii) Conclusion, just a blank space represent the application icon in the launcher and when you right-click on the emty space the name of the application is not appear

2/Test Bug 2
(i) Open an application from dash
(ii) In the launcher select keep in lauch the application
(iii)Close the aplication
(iv)Remove the application launcher
(v)Open the same application from dash
(vi)Conclusion there are no icon in the launcher

Note: Don't use the same applications for test 1 and test 2.
        All of the applications that are found in the dash are concerned with these bugs

I am also having the issue on 12.04. Attached is a screen recording I took where Hedgewars was used as the example. (My first attempt to drop it onto the launcher was unsuccessful for whatever reason, but that's probably a separate issue. The second try is where the bug shows itself.).

tags: added: precise

This one seems to only be able to happen if and only if it is draged from the dash to the launcher. Therefore the bug is in the code where an icon is droped onto the launcher....Ill start looking for a fix.

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Confirmed → In Progress

For me this does not only happen when applications are draged to the launcher. Tuxguitar and Shotwell never show in the launcher, whereas the behavior is different. When I go backt to the Dash and klick on the icon, in the case of Shotwell the already open window shows. Tuxguitar however opens a new window. This means, whenever I have a Tuxguitar window in the back, it stays there. Forever and ever ...

It seems that bamf fails on a dbus call sometimes which causes the icon to failed to load which causes a blank icon:

WARN 2012-06-08 13:39:23 unity <unknown>:0 Failed to fetch icon: No such interface `org.ayatana.bamf.view' on object at path /org/ayatana/bamf/application62801462
WARN 2012-06-08 13:39:23 unity <unknown>:0 Failed to fetch name: No such interface `org.ayatana.bamf.view' on object at path /org/ayatana/bamf/application62801462
WARN 2012-06-08 13:39:23 unity <unknown>:0 Unable to fetch children: No such interface `org.ayatana.bamf.view' on object at path /org/ayatana/bamf/application62801462

Łukasz Zemczak (sil2100) wrote :

How's the progress on this bug going? Any possible fixes?

The problem: bamf_factory has a list of local_views that holds a list of the current views in the launcher. When an application quits it gets to the bamf_factory::on_view_weak_unref to remove the view from local_views buuuut for some reason it doesn't get to that function sometimes so it doesn't remove it from the local_views. So a view exist in the list of local_views that isn't in the launcher.

So when you drag an application over it iterates through the local_views and it finds that view, but it doesn't exist in the launcher. So this means it doesn't create a new favorite which means it doesn't create in bamf_view the local_icon and local_name (since it thinks it already exists). So it gives a blank icon and no name.

Sooo Im trying to figure out what is causing it to not remove the view from the local_views right now....I have more time now to dig into this.

The problem seems to be with the reference counting on glib::Object<BamfApplication> _bamf_app in the Launcher Controller.cpp. A work around I found was to use g_object_run_dispose() and then releasing the Object but that isn't the actual fix...Im looking for the correct one atm.

Felipe Castillo (fcastillo.ec) wrote :

I was having this exact problem with my Matlab icon. It was working at the begining without a problem, until one day the icon became invisible.
I resetted the unity setting using:

gconftool-2 --recursive-unset /apps/compiz-1

After logging out and back in, I fixed my unity settings the way I wanted them and the icon was there again. I hope this can help anybody that is working on a fix to the problem.

Changed in unity:
milestone: 5.14.0 → 6.0
Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → nobody
status: In Progress → Confirmed
John Lea (johnlea) wrote :
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
status: Triaged → Fix Committed
tags: added: udp

I cannot reproduce this bug in unity 5.0 trunk nor in unity 6.0 trunk (20-30+ tries). I can reproduce this though running 12.04 in a few tries though.

Daniel van Vugt (vanvugt) wrote :

I know it's hard for most of use to reproduce this bug. However it's had two new duplicates reported just this week.

Tim Penhey (thumper) wrote :

Brandon, can you please do an apt-cache policy on your bamf libraries please? I know that some changes were done there, perhaps an unreleased fix has solved this.

Didier Roche (didrocks) on 2012-07-10
Changed in unity:
milestone: 6.0 → 6.2
John Lea (johnlea) on 2012-07-10
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu Precise):
status: Confirmed → Triaged

I've been using the trunk version of bamf. Ill see if I can find a rev that fixes it. It could also be a fix on the unity side.

libbamf0:
  Installed: 0.2.118-0ubuntu0.2
  Candidate: 0.2.118-0ubuntu0.2
  Version table:
 *** 0.2.118-0ubuntu0.2 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.2.114-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

Eero Aaltonen (ejn) wrote :

I get this the following ways:

- using spotify
- using skype
- in nautilus, right click on a text file and select 'Open with text editor'

Atul (atulkakrana) wrote :

I get this when I open spotify from sound icon on top right but if I run spotify from dash than icon shows up.

Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in unity:
milestone: 6.4 → 6.6
James (jamesasgrim) wrote :

I confirm I also have this bug with Spotify.

If I launch from the unity panel, it often shows a blank icon. If I fully exit Spotify and launch it in the same way (from the unity bar) it then works and "merges" with the launcher.

The blank icon is clickable and does bring up Spotify.

eros2 (eros2) wrote :

I see this issue very often when doubleclick on excel files and open its using libreoffice calc.

Changed in unity:
milestone: 6.6 → 7.0
Andreas (mr-pink37) wrote :

For me only two apps cause this issue, those are Spotify and Matlab 2012a. It happens very rarely though.

Patrick Marchwiak (pmarchwiak) wrote :

I'm also seeing this issue with only Spotify and Matlab 2012a. It seems to happen with Spotify very frequently.

2012/9/20 Patrick Marchwiak <email address hidden>:
> I'm also seeing this issue with only Spotify and Matlab 2012a. It seems
> to happen with Spotify very frequently.

Is this happening with Precise or Quantal?

I am using Precise 64bit. Again, only apps I noticed this happening with are Spotify and Matlab 2012a.
Appearance seems to be completely random though, sometimes restarting the app helps, sometimes I have to log out of unity and log back in. But it's always only those two apps.

Regards

Nekhelesh Ramananthan (nik90) wrote :

@Marco, I can confirm this with Spotify and Matlab 2012a also on Precise. I cannot say about quantal since I am not running it. This happens almost 9 out of 10 times with Spotify. Temporary fix is to quit the app and then show it again using the spotify indicator.

MaTachi (matachi) wrote :

I'm also experiencing this very often with Spotify. I have attached a screenshot I took earlier today. Restarting Spotify does often help.

Alan Pope ㋛ (popey) wrote :

I also see this with Spotify on up to date quantal.

Alan Pope ㋛ (popey) wrote :

Interestingly if I boot cleanly and start spotify from the dash I end up with a grey icon.
If I then close the spotify window (but spotify is still running - seen in the indicator area) the icon disappears from the launcher (as expected)
I then start spotify from the dash again (which raises the spotify window) I now get a spotify icon in the launcher.

Yeah, this happens since unity has no time to cache the icons data when firstly opened (for few ms).

I've a workaround for this...

Andreas (mr-pink37) wrote :

I am running Quantal since last week and so far no missing icon with either Matlab and Spotify.
However, and possibly more annoying, when I open Spotify from the launcher, unity for some reason adds another spotify icon to the launcher. So I end up with two spotify icons, one permament and one for the instance that is running currently (see screenshot attached). Although I appreciate unity offering me the choice to click on either of them I'd rather have just one ;)

btw. only app this happens with is .. again .. Spotify. (yes, no issue w/ Matlab, you heard right)

John Lea (johnlea) on 2012-10-09
Changed in ayatana-design:
importance: Medium → High
John Lea (johnlea) on 2012-10-10
summary: - Unity launcher single missing/invisible/blank icon
+ Launcher - Unity launcher single missing/invisible/blank icon
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu Precise):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu Precise):
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
description: updated
description: updated
description: updated
description: updated
description: updated
Vadim Peretokin (vperetokin) wrote :

Invisible Eclipse icon, 12.04, nvidia gtx 560 with the supplied 295.49 drivers.

Hello Daniel, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Łukasz Zemczak (sil2100) wrote :

Could not reproduce, so looks fixed!

tags: added: verification-done
removed: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Daniel, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Still seems to fixed with the new upload.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu2

---------------
unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 18:00:00 +0100

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released

bug still open at precise 12.04.1 fresh install.

to reproduce:
1) from google chrome, right click on gmail app and create shortcut on the desktop plus applications menu.
2) test gmail shortcut dragging from applications menu to the launcher
3) enought testing gmail from launcher. remove gmail from launcher by right clicking it.
4) from dash, type gmail, drag icon and drop inside the trash icon.
5) blank icon remains at the same place gmail icon was.

screen shot attached.

cheers

Changed in unity (Ubuntu Precise):
status: Fix Committed → Incomplete

if you reboot, blank space on the launcher is gone.

cheers

Changed in unity (Ubuntu Precise):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu3

---------------
unity (6.10.0-0ubuntu3) raring; urgency=low

  * Upload to raring

unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Didier Roche <email address hidden> Fri, 09 Nov 2012 08:06:47 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

2012/11/8 Adolfo Jayme Barrientos <email address hidden>

> ** Changed in: unity (Ubuntu Precise)
> Status: Incomplete => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/772986
>
> Title:
> Launcher - Unity launcher single missing/invisible/blank icon
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/772986/+subscriptions
>

adolfo,

what about unity 5.16.0? it's still the default version under ubuntu 12.04
and for me this bug is still open.

cheers,
ibere

I can confirm that the bug still exists on 12.04 in Unity 5.16.0 (I reproduced it using LibreOffice Writer). However, @ibere note that it is marked "Fix Committed" for the 5.0 series and milestoned to 5.18.0. This means it has already been fixed but not yet released; the fix will go out during the next SRU if I'm not mistaken, and then it will be Fix Released, meaning you'll see the issue go away if you update to that version once it's available and restart your system.

But first, the fix must be released alongside the other updates, whenever those are ready. So, patience. :)

Didier Roche (didrocks) on 2012-11-16
Changed in unity (Ubuntu Precise):
status: Fix Committed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Precise):
status: New → Confirmed
Jorge Suárez de Lis (ys) wrote :

I can confirm this bug still happens on current Ubuntu 12.04 with Matlab R2012a.

I applied the workaround pointed by comment 27 and it helped the first time, but after closing and opening Matlab again, the bug persists.

Changed in unity (Ubuntu Precise):
status: Confirmed → In Progress
assignee: Marco Trevisan (Treviño) (3v1n0) → Timo Jyrinki (timo-jyrinki)

Hello Daniel, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.18.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Seems fixed now, cannot reproduce anymore.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.18.0-0ubuntu1

---------------
unity (5.18.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher: start the drag icon request from the original mouse-down
      position. (LP: #858540)
    - Ignore transient unmmaped windows on minimize/unminimize
      (LP: #929712)
    - Fixes alt+tab losing focus when alt+tabing to quickly due to ubus
      being to slow to send a message (LP: #1035628)
    - If no icon is found then use the default one. This will cause all
      blank icons to be a '?' icon (LP: #886778)
    - Use GMountOperation in g_volume_mount. GMountOperation provides a
      mechanism for interacting with the use. (LP: #713432)
    - Do not reuse the menu entries if their order changes (LP: #1062283)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes. This avoids to get "?" icons. (LP: #772986)
    - Use linear filtering to draw icons (when needed). (LP: #1036231)
 -- Timo Jyrinki <email address hidden> Mon, 12 Nov 2012 14:17:04 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-02-17
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.