Unity -- Moving min/max/close buttons back to right hand side for full screen windows

Reported by Nadir SOUALEM on 2011-04-28
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

Moving min/max/close buttons back to right hand side with gconf-editor works, but
for full screen windows, min/max/close buttons are in the left side.
This occurs only in unity mode.

Nadir SOUALEM (nsoualem) wrote :

nsoualem@gold: pts/0: 110 files -- GNU Compiler -- 7.3Gb -> cat /etc/*-release && unity --version && uname -a
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
unity 3.8.10
Linux gold 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in unity:
importance: Undecided → Wishlist
Alex Launi (alexlauni) wrote :

honestly my solution to this would be to disable the ability to move the buttons to the right hand side of the window. adding an ayatana-design task for design input.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
tags: added: needs-design
Xahrepap (johnson-joel-86) wrote :

This doesn't only affect the side of the screen the buttons are on, but it also happens if you remove one of the buttons completely. When you go full screen all three are back. For example: in gconf-editor I changed the 'button_layout' field from "close,minimize,maximize:" to "close:" so that only the close button appears. When I maximize the window all three buttons are back. I assume this is because the Unity panel uses different settings to display the buttons rather than the settings listed in /apps/metacity/general. I did a few searches and looking around at different options in gconf-editor but didn't see anything.

The fix for this bug isn't to disable this ability but rather fix it so Unity respect the gconf setting or make it known how to change it in Unity.

Nadir SOUALEM (nsoualem) wrote :

I think that Unity should follow the behaviour of gconf-editor.
DIsabling this ability is clearly a regression and not a solution.

Found the same problem, it doesn't follow gconf-editor's settings.
Also tried Ubuntu-tweek, it doesn't help.

anewguy (anewguy) wrote :

Personally, I see 2 things here:

(1) the need for a Unity configurator. Since Unity is being pushed as separate from Gnome, why not a configurator for it.

(2) the ability to move the buttons to the right may seem trivial to the purist, but for the large number of everyday users coming here from Windows, or like me - dual booting, it only seems logical that the ability to move the buttons to the right should be there. Currently, there are some bugs in this as already noted - windowed versus maximized, etc..

Ronnie (ronnie-10) wrote :

this is one of two things stopping me from using the new unity interface

I might have to stop using the unity interface because of this also. It drives me crazy.

This is not a bug, unity don't designed in multiple configurations for buttons. It breaks a cohesion to much, in right corner you find indicators, before unity it was theme designer desision, now it doesn't.
 I change these with invalid. if you use mutter you can change i think.( in gnome shell)

Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
anewguy (anewguy) wrote :

I don't understand post 9. If someone is saying this isn't a bug - well, the window buttons not only get moved left but also indented. This isn't intuitive.

Omer Akram (om26er) on 2011-09-05
Changed in unity:
status: Invalid → Won't Fix
Changed in unity (Ubuntu):
status: Invalid → Won't Fix
Changed in ayatana-design:
status: New → Opinion
ಸతీशः (bdsatish) wrote :

I'm coming from Windows and left side buttons are TOTALLY unintuitive ! Please change it to right side !

heidiklumsex (heidiklumsex) wrote :

If you're left-handed, Unity is unbearable! I want the window buttons on the right side. I want the launcher on the right side. And I want the system menu on the left. Just provide these options! Stop discriminating left-handed people! Aren't Linux users always promoting how customizable Linux is? Clearly, this is a lie!

Davide Corio @ LS (enlightx) wrote :

following this how-to you can move buttons back to the right side.

http://www.linuxjournal.com/video/move-window-buttons-lucid

it's for gnome2 but it works on unity as well

ಸతీशः (bdsatish) wrote :

What that video doesn't show is this: with fully-maximized windows, those three buttons are again back at top-left ! This is even worse, meaning sometimes they are on the right side and sometimes on the left !

Davide Corio @ LS (enlightx) wrote :

you're right sorry.

that doesn't work if you maximize the windows

anyway... i come from osx so buttons on the left side are fine :-)

finneysan (msfin303) on 2012-09-10
Changed in ayatana-design:
status: Opinion → Fix Committed
status: Fix Committed → Opinion
Ali Najafi (alinajafi) wrote :

There is also two sets of icons in thems Ambiance and Radiance: Metacity and Unity; the first for unmaximized windows and the latter for maximized oenes. It seems “Unity” buttons layout is unchangable.
There is a settings for Unity (here)[http://askubuntu.com/questions/174292/how-can-i-move-all-the-window-controls-to-the-right] in jokerdino’s answer, but that Gnome Shell schema doesn’t exist in 13.04 – please try in 12.10 and 12.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers