Launcher: localise <Super>+number ordering to match locale keyboard layout (eg. 0-9 for Hungarian)

Reported by Istvan Szekeres on 2011-04-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned
Declined for Oneiric by Omer Akram
Natty
Wishlist
Unassigned

Bug Description

In Some keyboard layouts (e.g. Hungarian) "0" (zero) is to the left of the "1" key, not to the right of the "9" key. Therefore it would be more logical if the launcher icons (dynamically appearing bar on the left side of the screen) would number its icons from 0 to 9, not from 1 to 9 followed by the 0.

Pistahh: interesting suggestion. We can look at this aspect of localisation for the Ubuntu 11.10 cycle; we also need to make some design decision about right-to-left languages.

The next Ubuntu Developer Summit (UDS-O) is in Budapest in two weeks' time. Are you likely to be there?

Changed in unity (Ubuntu Natty):
status: New → Won't Fix
Changed in unity:
status: New → Incomplete
Changed in ayatana-design:
status: New → Incomplete
importance: Undecided → Wishlist
milestone: none → later
summary: - keyboard layout not honored in keyboard shortcut for icons
+ Launcher: Wishlist: localise <Super>+number ordering to match locale
+ keyboard layout (eg. 0-9 for Hungarian)
Didier Roche (didrocks) on 2011-04-26
Changed in unity:
status: Incomplete → Won't Fix
Didier Roche (didrocks) wrote :

@Paul: please don't play with status changes as the sync software will sync the states. I'll make it release aware to handle that case in the future (I already have some implementation, but not this one).

Changed in unity:
status: Won't Fix → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu Natty):
status: Won't Fix → Confirmed
Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu Natty):
importance: Undecided → Wishlist
summary: - Launcher: Wishlist: localise <Super>+number ordering to match locale
- keyboard layout (eg. 0-9 for Hungarian)
+ Launcher: localise <Super>+number ordering to match locale keyboard
+ layout (eg. 0-9 for Hungarian)
Sebastien Bacher (seb128) wrote :

will not likely be fixed for natty

Changed in unity (Ubuntu Natty):
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged

In US keyboards (and many others) the order of numbers is
1-2-3-4-5-6-7-8-9-0. In Hungarian the order is 0-1-2-3-4-5-6-7-8-9.

Em 17-11-2011 18:51, Mark Shuttleworth escreveu:
> What's the argument for localisation? They are numbers!
>

Istvan Szekeres (szekeres) wrote :

On the hungarian layout 0 is the leftmost key, then 1,2,3 etc. So it is not
logical that pressing the (physically) first number activates the 10th
item, the 2nd activates the 1st etc.

On Thu, Nov 17, 2011 at 9:51 PM, Mark Shuttleworth <
<email address hidden>> wrote:

> What's the argument for localisation? They are numbers!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/768925
>
> Title:
> Launcher: localise <Super>+number ordering to match locale keyboard
> layout (eg. 0-9 for Hungarian)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/768925/+subscriptions
>

Mark Shuttleworth (sabdfl) wrote :

OK, patch + test welcome.

Mark

John Lea (johnlea) on 2012-09-19
Changed in ayatana-design:
importance: Wishlist → Undecided
status: Incomplete → New
Changed in unity:
status: Triaged → New
Changed in unity (Ubuntu):
status: Triaged → New
Stephen M. Webb (bregma) on 2013-07-26
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers