Launcher - When a app icon de-couples from the Launcher a small shadow should appear on the bottom and right sides of the icon

Reported by John Lea on 2011-04-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
High
Nick Dedekind
unity (Ubuntu)
High
Unassigned

Bug Description

When a user clicks-holds on a app icon in the Launcher for more than 500ms, the icon de-couples from the Launcher allowing vertical reordering. A shadow should appear on the right and bottom sides of the icon when this happens.

Visual designs

See the following assets that are attached to this bug:
- lens_shadow.png
- ordering_shadow.png
- ordering_shadow_lens.png
- Pangolin_launcher_tile_light_wallpaper.png
- tile_shadow.png

Related branches

lp:~nick-dedekind/unity/lp765715.launcher-icon-shadow
Merged into lp:unity at revision 2878
John Lea: Approve (design) on 2012-11-05
Andrea Azzarone: Approve on 2012-11-05
PS Jenkins bot: Pending (continuous-integration) requested 2012-11-05
John Lea (johnlea) on 2011-04-19
tags: added: udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
Alex Launi (alexlauni) on 2011-05-05
Changed in unity:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Jason Smith (jassmith)
milestone: none → ux-backlog-2
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Triaged
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge O. Castro (jorge) on 2011-06-06
Changed in unity:
milestone: ux-backlog-2 → backlog
assignee: Jason Smith (jassmith) → Unity Community Hackers (unity-community-hackers)
Jorge O. Castro (jorge) on 2011-06-06
tags: added: backlog
Changed in unity-2d:
status: New → Triaged
importance: Undecided → Low
Didier Roche (didrocks) on 2011-07-20
Changed in unity-2d (Ubuntu):
status: New → Triaged
Omer Akram (om26er) on 2011-09-24
Changed in unity-2d (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
importance: Low → High
John Lea (johnlea) on 2011-10-19
Changed in ayatana-design:
status: Fix Committed → Triaged
John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: Unity Community Hackers (unity-community-hackers) → nobody
Tim Penhey (thumper) on 2011-11-22
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
description: updated

What about bigger icons? The images will be expanded and lose quality, right?

John Lea (johnlea) wrote :

@marcobiscaro2112; bigger icons? No icon should be expanded at any time during the drag and drop re-ordering process. Could you clarify you question, thanks!

Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Ugo Riboni (uriboni) on 2012-08-08
Changed in unity:
assignee: nobody → Ugo Riboni (uriboni)
Ugo Riboni (uriboni) on 2012-08-10
Changed in unity:
status: Triaged → In Progress
John Lea (johnlea) on 2012-09-03
Changed in unity:
importance: Low → High
Changed in unity (Ubuntu):
importance: Low → High
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-10
no longer affects: unity-2d (Ubuntu)
John Lea (johnlea) on 2012-10-12
Changed in unity:
assignee: Ugo Riboni (uriboni) → nobody
status: In Progress → Triaged
no longer affects: unity-2d (Ubuntu)
Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity:
status: Triaged → In Progress
Andrea Azzarone (andyrock) wrote :
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily12.12.05-0ubuntu1

---------------
unity (6.12.0daily12.12.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/control:
    - Update Vcs-Bzr
  * Automatic snapshot from revision 2905 (bootstrap)
    - Hide launcher tooltip once shortcut overlay appears (LP: #1035860)
    - Update shortcut overlay design (LP: #1049601)
    - Don't cut off shadow on launcher icon drag window (LP: #765715)
    - Provide more immediate feedback when clickong on launcher (LP: #893140)
    - Decorate spread windows in switcher (LP: #838222)
    - Make sure to initialize a variable before it can be used (LP: #1073516)
    - Fix FTBFS due to BAMF API change (LP: #1077937)
    - Run gtest during build (LP: #133637)
    - Make shopping lens test more robust (LP: #1077131)
    - Fix some random autopilot test failures (LP: #1078448)
    - Fix autopilot tests for details mode (LP: #1073892)
    - Fix autopilot tests for indicator-session (LP: #1075350)
    - Fix autopilot tests for non-English locales (LP: #1075898)

  [ Didier Roche ]
  * debian/control:
    - adding libgtest-dev and google-mock build-dep now that there are in main
      (LP: #1076763)
    - add libunity-core -> unity-common dep (LP: #1079132)
    - do not have unity-common dep on compiz-gnome: the migration code is only
      ran if compiz-gnome is installed, but compiz-gnome is pulled by compiz
      directly. We don't care if the migration code isn't executed.

  [ bschaefer ]
  * Ported to nux 4.0

  [ Ricardo Salveti de Araujo ]
  * Doesn't need to depend on gcc 4.6 anymore (LP: #1044836)

  [ Nick Dedekind ]
  * Previews loading more than 454 lines of description text crash Unity
    (LP: #1066788)

  [ Brandon Schaefer ]
  * unity::TimeUtil::TimeDelta returns an int value which overflows
    after 24 days of uptime (LP: #806248)
  * Top panel "tooltip" is gone (regression) (LP: #1085045)
  * Dash - Implement *overlay scrollbars* in Dash. Existing scrollbars
    are too thin to grab on to. (LP: #608124)

  [ Andrea Azzarone ]
  * Dash - Regression: Clicking between filter label and 'All' button no
    longer toggles filter label (LP: #1080534)

  [ Didier Roche ]
  * libunity-core fails without the schemas from unity-common (LP:
    #1079132)

  [ Manuel de la Pena ]
  * There is no common ui element that behaves like a url link (LP:
    #1067705)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 2956
 -- Automatic PS uploader <email address hidden> Wed, 05 Dec 2012 09:27:29 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2012-12-11
Changed in unity-2d:
status: Triaged → Won't Fix
Changed in unity-2d (Ubuntu):
status: New → Won't Fix
Stephen M. Webb (bregma) on 2012-12-11
no longer affects: unity-2d
no longer affects: unity-2d (Ubuntu)
Stephen M. Webb (bregma) on 2013-02-17
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints