title bar fade pointless on large monitors

Reported by Martin Pool on 2011-04-19
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned
unity-2d
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using unity on a 1920px wide monitor, which has something like a foot of empty space between the window title and the indicators. It seems needlessly cramped to truncate the window title to put the menus on top of it when there is plenty of empty space to put them into.

Bilal Akhtar (bilalakhtar) wrote :

This would need design discussion. Should we dynamically calculate the distance of the appmenu from bfb? Or should we use the static distance?

Changed in unity:
status: New → Incomplete
tags: added: needs-design
Changed in unity (Ubuntu):
status: New → Incomplete
JT (spikyjt) wrote :

I agree with this. I have a whole 1400px between the window title and the indicators. Plenty of room for any toolbar, especially true since the system tray has been banned.

Could you make a screenshot of this?

Martin Pool (mbp) wrote :

sure, but it's not exactly hard to reproduce

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

I'm not reproducing this appearance on Precise. The menu replaces the title rather than fade it out.

I also checked that really long titles aren't faded out too short (see attached image).

I think this can be closed as fixed. If I'm mistaken and this can still be reproduced on Precise, please reopen and clarify how to reproduce it.

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Changed in ayatana-design:
status: New → Fix Released
Martin Pool (mbp) wrote :

I can still reproduce this on Precise, at least in unity-2d.

Changed in ayatana-design:
status: Fix Released → Confirmed
Changed in unity-2d:
status: New → Confirmed
Changed in ayatana-design:
status: Confirmed → New
Daniel van Vugt (vanvugt) wrote :

I don't think this is fixed.

The bug description says:
"It seems needlessly cramped to truncate the window title to put the menus on top of it"

Which contradicts the solution that Bryce describes:
"The menu replaces the title"

I believe Martin meant that the menus should appear to the right of the title. And only truncate the title if there is not room for both side-by-side.

Can we re-open this bug?

Changed in unity:
status: Fix Released → Incomplete
Changed in unity-2d:
status: Confirmed → Incomplete

@vanvugh the 'incomplete' is the quirky unity way of saying they can't
fix the code until they get a design decision...

Martin Pool (mbp) wrote :

On 3 January 2012 17:14, Martin Pool <email address hidden> wrote:
> @vanvugh

sorry, vanvugt.

--
Martin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints