(Regression) indicator-weather is not seeded; cannot be right-click added under Unity

Reported by Andrew Somerville on 2011-04-19
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned
Weather Indicator
Undecided
Unassigned
indicator-weather (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Gnome 2 contained a feature which allowed it to show the local weather conditions next to the clock. I personally find this feature extremely useful and I check it nearly every time I leave the house or my office at work. Arguably it's more to me than the date and time display since I wear a watch. This feature appears to be missing in Unity.

Considering its usefulness, and the fact that Unity lacks the ability to add an alternate panel applet to replace it, this feature probably should be added to Unity.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.8-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Mon Apr 18 21:58:52 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-16 (2 days ago)

Andrew Somerville (andy16666) wrote :
Bilal Akhtar (bilalakhtar) wrote :

Just an FYI, you can get weather functionality using indicator-weather. See http://www.omgubuntu.co.uk/2011/03/indicator-weather-adds-data-caching-extra-weather-providers-and-locations/

Andrew Somerville (andy16666) wrote :

That's a great applet. Now if we just had it installed by default, and optionally activated from the panel context menus or settings. Thanks!

Bilal Akhtar (bilalakhtar) wrote :

Not a bug in Unity, since Unity is intended to show only appindicators. The old style weather applet used a GtkStatusIcon instead. And users should now use indicator-weather for the same thing. Closing Unity bug task.

As for adding old style applets, the bug (now declined) was bug #666678 .

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Opinion
Changed in unity:
status: Invalid → Opinion
Andrew Somerville (andy16666) wrote :

This point of this bug was to make weather easily available to users without having to add the PPA repository and install an unstable applet. I could change it to a wish list item, if that would sit better with people.

The point is to get weather functionality as easily accessible as it once was. I'm not personally concerned with the implementation details. I don't think it's really an opinion though, as much as a wish list.

Jorge O. Castro (jorge) wrote :

The weather indicator is in the archive, you don't need to add a PPA.

Andrew Somerville (andy16666) wrote :

So it is. In that case, maybe just installed by default and accessible from system settings?

Paul Sladen (sladen) wrote :

andy16666: Press <Super> and type 'weather', then click to install.

Andrew Somerville (andy16666) wrote :

FYI: I already have indicator-weather installed. I'm not here to ask for support installing it. I'm here to suggest an improvement to Ubuntu. My suggestion is that weather should be available from the right click menu or system settings on the panel.

Although I appreciate you pointing out that indicator-weather can be accessed through the search.

Andrew Somerville (andy16666) wrote :

As a programmer with an MCS, I often feel like an idiot making a usability suggestion like this one. I mean it's not as if I can't figure out how to get weather on my computer. I'm making this suggestion because most of the people I know are not MCS graduates and have found the transition to Unity jarring for this and other reasons. I'm just trying to make a suggestion about something that a lot of people use (including myself), and are finding difficult to locate within the Unity interface.

If you guys are satisfied that it's easy enough for people to find, great. But I'm just saying that this hasn't been my experience. Wherever it moved, whatever replaced it, and however you access it now, it's not where people expect to find it. Maybe that's not an issue that anyone wants to tackle, but I just want to make sure I'm clear on what issue I'm reporting, and that I'm not looking for technical support.

Paul Sladen (sladen) on 2011-04-24
summary: - Weather functionality missing from Unity (Regression)
+ (Regression) indicator-weather is not seeded; cannot be right-click
+ added under Unity
Paul Sladen (sladen) wrote :

Andy: thank you for the clarification; I've tried to refocus this bug report around 'indicator-weather' not being seeded currently, rather than the functionality not existing (ie. not in the base-set on the CD/install image).

From an Ayatana-Design we'll need to look into how optional indicators can be enabled/disabled more easily (for instance via a right-click a la the GNOME2 'notification-area') and to what we want to ship by default for Ubuntu 11.10.

Changed in indicator-weather (Ubuntu):
status: New → Incomplete
Changed in germinate (Ubuntu):
status: New → Incomplete
Changed in unity (Ubuntu):
status: Opinion → Invalid
Changed in unity:
status: Opinion → Invalid
Changed in ayatana-design:
status: New → Incomplete
milestone: none → later
Changed in germinate (Ubuntu):
milestone: none → ubuntu-11.10
Changed in indicator-weather (Ubuntu):
milestone: none → ubuntu-11.10
Colin Watson (cjwatson) wrote :

Can somebody please explain why there's a germinate task on this bug? Germinate is just the program that performs dependency expansion on seeds; it is not responsible for the actual contents of seed files. If what you mean is that indicator-weather should be added to the Ubuntu desktop seed, then the germinate task should be reassigned to ubuntu-meta.

Panagiotis Skintzos (ph7) wrote :

FYI the next version (foggy) of indicator-weather is implemented as a "system" indicator (uses libindicator directly and goes away from appindicator model) so it will be possible to be displayed next to the time indicator.

Don Myers (donmyers) wrote :

Help please. I'm generally good with figuring out how to make things work in Ubuntu. I cannot make indicator-weather work in Ubuntu 11.04 Unity. It shows up in the list of apps if you tyupe weather. Clicking on it doesn't seem to do anything. Right clicking on it doesn't seem to do anything. Adding it to the start menu doesn't help. It still doesn't appear in the top panel. Any assistance would be greatly apprecaited!!!!!!!

Panagiotis Skintzos (ph7) wrote :

@Don:
Please open a new bug report as this one is definitely not the right one.
Also specify the version your are using and attach any log found (~/.cache/indicator-weather.log)

Andrew Somerville (andy16666) wrote :

I'd like to withdraw my endorsement of indicator-weather. It's not a stable piece of software, and routinely freezes up or fails to update. (It's useless) It's certainly not ready to replace the existing gnome 2 version.

I'm also surprised that there is no notification area anymore, so I can't access my dropbox or google desktop applications from Unity.

Changed in weather-indicator:
status: New → Invalid
Colin Watson (cjwatson) on 2011-05-24
affects: germinate (Ubuntu) → ubuntu-meta (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers