Static Application Switcher Plugin does not show window titles

Bug #757814 reported by Carlos Filipe Moreira e Silva on 2011-04-11
274
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

When using Alt+Tab Static Switcher Plugin in Natty the pop-up notification does not show the window name. It also happens with "Exposé". I think (without testing) that it may affect other plugins that deal with windows and that in the past presented windows' names.

Paul Sladen (sladen) wrote :

The classic case for this is Alt-Tabbing around a couple of dozen terminals. They are all alike and the only thing that normal is there it tell them apart is the document title.

Changed in unity:
status: New → Incomplete
Didier Roche (didrocks) on 2011-04-13
Changed in unity (Ubuntu):
status: New → Incomplete
hackel (hackel) on 2011-04-13
summary: - Alt+Tab Swicher Plugin does not show windows title
+ Static Application Switcher Plugin does not show window titles

Retargeting to O, since its not possible to get that window title
shown without changing the API (need to create an API to show that
this window will *become* the active window, but is not the active
window right now)

On Thu, Apr 14, 2011 at 4:38 AM, hackel <email address hidden> wrote:
> ** Also affects: compiz (Ubuntu)
>   Importance: Undecided
>       Status: New
>
> ** Summary changed:
>
> - Alt+Tab Swicher Plugin does not show windows title
> + Static Application Switcher Plugin does not show window titles
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity.
> https://bugs.launchpad.net/bugs/757814
>
> Title:
>  Static Application Switcher Plugin does not show window titles
>
> Status in Ayatana Design:
>  New
> Status in Unity:
>  Incomplete
> Status in “compiz” package in Ubuntu:
>  New
> Status in “unity” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  When using Alt+Tab Static Switcher Plugin in Natty the pop-up
>  notification does not show the window name. It also happens with
>  "Exposé". I think (without testing) that it may affect other plugins
>  that deal with windows and that in the past presented windows' names.
>

--
Sam Spilsbury

areteichi (areteichi) wrote :

I'm a bit frustrated by the lack of this feature as well, especially when the unity launcher is not designed to show the window title.
I believe this would be quite essential for many users.

Tim Cole (tcole) wrote :

I find this frustrating as well.

Alex Peters (alex-peters) wrote :

I note that this bug is marked as "incomplete," suggesting that further information is required by the bug reporter/s (cf. https://wiki.ubuntu.com/Bugs/Status).

What further information is required for work on this bug to progress?

Bilal Shahid (s9iper1) wrote :

to complete this bug go to terminal and write this,follow the instruction ,ur bug will complete.
apport-collect 757814

@Alex: This bug is awaiting design feedback before progress can be made. Confirming that there is a question to be answered. Will be marked triaged when design gives a suitable direction forward.

Please see https://wiki.ubuntu.com/Unity/FilingBugs#Design%20Bugs for more information.

tags: added: needs-design
Martin (martin-leitner) wrote :

Using Unity for 8 days now, this is one of two very annoying issues.
Accessing a couple of similar open windows (lets say some terminal windows like Paul Sladen) via a task bar was a lot more convenient!
Clicking on the Terminal-icon in unity brings up some nice previews doing a nice job animating them around.
Nice - but not good for quickly switching to that other window that I just like to get.
The animation is distracting me and it costs my brain some seconds (!) to scan all the appearing windows to find the one that i want.
Don't get me wrong, I don't say that this is bad for all the people around - it's just bad for the one who want's to quickly jump around some windows of the same type.

As an improvement I suggest to show a list of all the window titles near the launcher bar (at about the position where the tool tip appears).
The titles should be selectable (by left mouse click) and should be arranged alphabetically (maybe the acitve one printed in bold letters).
Making this list of titles semi-transparent would be a good option too.

Kumar Abhishek (manustays) wrote :

I agree with Martin. The lack of text in application-switcher and 'expose' is very annoying and productivity bottleneck; specially for people like me who work with too many apps at the same time. Many times I have to actually switch to a window only to find out it was not the one I needed!

Alan Porter (alan.porter) wrote :

I am using gnome, and the compizconfig-settings-manager. The "ring switcher" and "shift switcher" do not show the window titles, either, even though the "show window title" checkbox is clicked. So maybe the problem is somewhere below the actual component that is doing the alt-tab switching, and in a component that is providing window info.

That being said, the alt-tab "static application switcher" in compizconfig-settings-manager *does* show the window titles... but only for non-minimized windows.

These window switchers used to show the window title in 10.10.

Alan

Omer P. (omerp) wrote :

Alan (#10):

It sounds to me like maybe you don't have the "Text" plugin in the new Natty CCSM enabled...? (It's in the "Image Loading" section, for whatever reason.) Until I enabled it, none of Compiz's switchers were showing text, for me.

Importantly, this bug -- with the Static Application Switcher -- persists regardless of the status of the "Text" plugin...

Alan Porter (alan.porter) wrote :

Omer P., that was it... I enabled the "text" plugin and it works.

So it looks like my problem is unrelated to the original poster's alt-tab problem.

Thanks, and I'll bow out and let you discuss the unity problem.

Alan

Anders Glent Buch (andersgb1) wrote :

When I enable "Focus on Switch" in "Appearance", problem is solved on my system...

It also worked for me, thanks.

I was also able to display the window title in the scale mode (super-w): enable the scale plugin, enable the scale addon plugin, enable the text plugin, and done!

It seems to me that all the features that were in Maverick also exist in Natty, however more plugins need to be enable (because they are not enable by default), which sometimes is annoying.

BR,
Carlos

Changed in compiz (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

See also bug 825545 for the related bug against the new alt-tab switcher plugin.

I've fixed this, at least in the compiz staticswitcher and switcher
plugins with my latest decorator work, will hopefully be in oneiric
within the next few weeks.

On Sat, Aug 13, 2011 at 6:06 AM, Jeremy Bicha <email address hidden> wrote:
> See also bug 825545 for the related bug against the new alt-tab switcher
> plugin.
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.
> https://bugs.launchpad.net/bugs/757814
>
> Title:
>  Static Application Switcher Plugin does not show window titles
>
> Status in Ayatana Design:
>  New
> Status in Unity:
>  Incomplete
> Status in “compiz” package in Ubuntu:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  When using Alt+Tab Static Switcher Plugin in Natty the pop-up
>  notification does not show the window name. It also happens with
>  "Exposé". I think (without testing) that it may affect other plugins
>  that deal with windows and that in the past presented windows' names.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/757814/+subscriptions
>

--
Sam Spilsbury

Niv Klein (nivklein) wrote :

i did everything here, but still cant see the window title.

any ideas?
thanks

Ben Gamari (bgamari) wrote :

Has there been no progress on this?

This bug is not a duplicate of 838222 because this bug describes the CompizConfig Static Application Switcher plug-in, not the default Unity application switcher described in bug 838222. These are different pieces of code so they should have different bug reports.

I am using Ubuntu 14.04 but using the Static Application Switcher instead of the Unity default application switcher because of other undesirable behaviour in the default switcher.

I believe that proper attention to this bug was drawn away by declaring it a duplicate. I hope the developers of the Static Application Switcher are alerted to this bug as it continues to be an issue.

Andrea Azzarone (azzar1) on 2015-09-23
no longer affects: unity
no longer affects: unity (Ubuntu)
Changed in ayatana-design:
status: New → Invalid
fcole90 (fcole90) wrote :

Thank you for taking the time to report this bug. We have tried to recreate this on the latest release of Ubuntu and cannot reproduce it. This bug is being marked as Invalid. If you believe the problem to still exist in the latest version of Ubuntu please comment on why that is the case and change the bug status to NEW.”

Changed in compiz (Ubuntu):
status: Confirmed → Invalid
stuzzo (stuzzo) on 2015-12-06
Changed in compiz (Ubuntu):
status: Invalid → New
stuzzo (stuzzo) wrote :

I am using Ubuntu 14.04 and I changed the default Window Switcher with the Static Application Switcher through the Compiz Manager.

When I alt+tab to windows I can't see the title. Actually I see a window preview with the icon in bottom right.

I tried to enable the Text and the Scale Window plugin, but the result is the same.
One thing I noticed is when I navigate through windows with alt+tab, in the top, under the system bar, it appears a black tiny rectangle, but I can't see if title is there.

Someone has the same problem?

Thank you

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers