Workspace switcher has no quicklist

Bug #750497 reported by Greg A on 2011-04-04
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Committed
Low
Marco Trevisan (Treviño)
unity-2d
Low
Unassigned
unity (Ubuntu)
Low
Marco Trevisan (Treviño)
Xenial
Low
Marco Trevisan (Treviño)
unity-2d (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

Binary package hint: unity

This is the only Unity launcher item with no right-click quicklist.

To me it seems important to have consistency. Though of course we know that we shouldn't just add things for the sake of it.

I don't know if added "Switch to Workspace X" options is considered a good idea?

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,regex,vpswitch,move,animation,imgpng,mousepoll,grid,unitymtgrabhandles,gnomecompat,place,workarounds,wall,wobbly,expo,ezoom,staticswitcher,session,fade,scale,unityshell]
Date: Mon Apr 4 18:06:36 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-09 (26 days ago)

Related branches

lp:~3v1n0/unity/expo-icon-quicklist
Andrea Azzarone: Approve on 2015-11-20
PS Jenkins bot: Approve (continuous-integration) on 2015-11-20
Greg A (etulfetulf) wrote :
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
tags: added: needs-design

Good catch, but let's ship it with no quicklist in Natty. Less changes,
more bug fixing. In Oneiric, MPT suggested a couple of different options
we can consider.

Mark

Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity-2d:
status: New → Incomplete
importance: Undecided → Low
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Incomplete

tomorrow onerici going to beta1, and i think it will not be fix.

Chris Wilson (notgary) on 2012-06-11
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → quantal-5-unity
Chris Wilson (notgary) on 2012-06-12
Changed in hundredpapercuts:
status: New → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) on 2012-06-22
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Shaun P (sigmagammapi) wrote :

It's too bad this wasn't done in time for Quantal. Perhaps it could be considered for 13.04?

I'd suggest having a quicklist that just says "Workspace 1, Workspace 2," etc but replacing the "Workspace #" with a name if the Compiz Workspace Naming plugin is being used.

Chris Wilson (notgary) on 2012-10-22
Changed in hundredpapercuts:
milestone: quantal-5-unity → raring-round-3
Chris Wilson (notgary) on 2012-12-21
Changed in hundredpapercuts:
assignee: nobody → Nick Tait (jnick-tait)
affects: hundredpapercuts → ubuntu-ux
Changed in ubuntu-ux:
assignee: Nick Tait (jnick-tait) → nobody
no longer affects: ayatana-design
Changed in ubuntu-ux:
assignee: nobody → John Lea (johnlea)
Changed in ubuntu-ux:
status: Confirmed → Triaged
John Lea (johnlea) on 2015-07-30
no longer affects: ubuntu-ux
dino99 (9d9) wrote :

This version has expired

Changed in ayatana-design:
status: New → Invalid
Changed in unity:
status: Incomplete → Invalid
Changed in unity-2d:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
Changed in unity-2d (Ubuntu):
status: Incomplete → Invalid
Changed in unity:
status: Invalid → In Progress
Changed in unity (Ubuntu):
status: Invalid → In Progress
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → 7.4.0
Changed in unity (Ubuntu):
milestone: none → ubuntu-16.04
tags: added: rls-x-incoming
Will Cooke (willcooke) wrote :

We have an approved branch, just needs merging. So targeting for X.

tags: removed: needs-design rls-x-incoming
tags: added: unity-backlog
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20151211-0ubuntu1

---------------
unity (7.4.0+16.04.20151211-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * unity: ensure we use python3 for the launch script and
    python2.7 for autopilot (LP: #1512909)

  [ Andrea Azzarone ]
  * Places(Overlay)VScrollBar: impelement gtk-like overlay scrollbars
    (LP: #1481706)
  * Properly hide shortcut overlay window to avoid unnecessary redraws.

  [ Bryan Quigley ]
  * debian/control: Remove telepathy from recommends

  [ Eleni Maria Stea ]
  * Replaced deprecated calls in tests to get rid of compiler warnings

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: if a new window opens while spreading,
    spread again with proper match (LP: #1517455)
  * ExpoLauncherIcon: add Quicklist to switch workspace and see the
    selected one (LP: #750497)
  * PanelIndicatorEntryView: Activate menus on click, by drawing them as
    active (LP: #1513523)
  * PanelMenuView: ignore leave events when triggered by feeding nux
    manually (LP: #1513496)
  * Places(Overlay)VScrollBar: impelement gtk-like overlay scrollbars
    (LP: #1481706)
  * SwitcherModel: allow to add/remove icons dynamically and update them
    when they require it (LP: #1512349)
  * SwitcherView: Add support to Alt+Key-right-to-tab to close the
    selected app/window
  * Switcher{View,Controller}: close active selection on Alt+q (LP:
    #1468820)
  * TextInput: show warning also when num lock is enabled
  * XKeyboardUtil: add ability to get keycodes from any relative
    position
  * debian/rules: enable unit tests on arm64 again (LP: #1514538)

  [ Sebastien Bacher ]
  * Updated apport hook to include: the compiz and xorg details, not
    only after asking users if the issue is a graphical one (which is
    weird question) the upstart logs for unity/ups/lockscreen some
    gsettings configurations (LP: #1508974)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 11 Dec 2015 12:46:16 +0000

Changed in unity (Ubuntu Xenial):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers