Ubuntu 11.04 doesn't show the Scim icon on top panel

Reported by Duy Anh on 2011-04-03
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
SCIM
New
Undecided
Unassigned
Unity
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

Scim had worked fine in last Ubuntu ver. but when i upgrade to 11.04, it doesn't show the icon on top panel !

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,place,move,imgpng,snap,session,mousepoll,unitymtgrabhandles,resize,commands,vpswitch,grid,regex,wall,animation,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
Date: Sun Apr 3 18:55:54 2011
DistroCodename: natty
DistroVariant: ubuntu
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InstallationMedia__: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=vi_VN:en
 LANG=vi_VN
 LC_MESSAGES=vi_VN.UTF-8
 SHELL=/bin/bash
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-31 (2 days ago)
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu1

Duy Anh (myfanisuuuu) wrote :
Bilal Akhtar (bilalakhtar) wrote :

Hi,

It appears Scim uses an old-style GtkStatusIcon on the panel, which isn't encouraged for use in Unity. If you want the Scim icon back then follow the steps at http://www.omgubuntu.co.uk/2011/03/how-to-hide-or-show-app-tray-applets-in-ubuntu-11-04/ . We don't plan to add scim to the default whitelist.

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Paul Sladen (sladen) wrote :

SCIM is required for normal input by a large number of people in the world (particularly in far-eastern Asia).

This probably should be whitelisted; note that this needs clarification about the interaction with IBus and which is being pushed as the default.

Sebastien Bacher (seb128) wrote :

isn't scim deprecated by ibus nowadays?

Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in unity:
importance: Undecided → Wishlist
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
tags: added: unity-notification-icon
Duy Anh (myfanisuuuu) wrote :

Can't in some religions. iBus is copy from Mac, which has underline in word. Scim not like that !

A.K.Karthikeyan (mindaslab) wrote :

I hope some one will fix this bug soon.. I am unable to type in Tamil :-(

Guillermo Molleda (gmolleda) wrote :

While, you could start session with desktop "Ubuntu Classic" (Ubuntu clásico en español), then you can view menu Aplications, Place, System, and so on.

But I can't choice esperanto eo-x-sistemo, I don't know.

Michael Tsang (miklcct) wrote :

I tried to use ibus, but ibus didn't produce the correct db for my ime table so scim is the only way to go currently.

Thank you for reporting this bug to Ubuntu. Ubuntu 11.04 reached EOL on October 28, 2012.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

Are you facing this bug in any current supported release?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers