Launcher - The Workspace, File Lens, App Lens and Trash Launcher icons need to be rendered correctly

Reported by John Lea on 2011-03-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Medium
Unassigned
Unity Asset Pool
Undecided
Unassigned
unity-2d
Medium
Unassigned
unity-lens-applications
Undecided
Unassigned
unity-lens-files
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-asset-pool (Ubuntu)
Undecided
Unassigned
unity-place-applications (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Undecided
Unassigned

Bug Description

To summarize the required fix:
1) look at the Workspace, File Lens, App Lens and Trash Launcher icons in "Natty_launcher.png"
2) Replicate the exact appearance of these icons as shown in "Natty_launcher.png" in Natty

----------------------------------------
Original bug description

The Workspace, Lens, and Trash icons should appear in the Launcher exactly exactly as depicted in 'Natty_launcher.png' (see inside the attached archive).

Currently in Natty these Launcher icons appear very differently from how they are depicted in the design.

We need to make the visual appearance of these icons match the design. In case it helps three versions of the launcher icons are included in the archive attached to this bug. However if different designs are required please email Otto and myself so that we can get the correct assets made up and sent over.

John Lea (johnlea) wrote :
Changed in ayatana-design:
status: New → Fix Committed
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
tags: added: udt
John Lea (johnlea) on 2011-03-30
description: updated
David Barth (dbarth) wrote :

This requires integrating the new graphics resources provide by Paul.

Ping John any time if the resources are not appropriate for integration.

The technical issue with this change request is to turn the tile backlighning off for those 4 icons: files, apps lenses laucnhers, workspace switcher and trash.

And maybe check the border rendering.

Changed in unity:
status: New → Incomplete
milestone: none → 3.8.2
importance: Undecided → Medium
David Barth (dbarth) on 2011-03-31
tags: added: ffe
Changed in unity-2d:
status: New → Confirmed
milestone: none → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
John Lea (johnlea) wrote :

Note that the workspace, file lens, app lens and trash Launcher icons need to look exactly as rendered in the attached "Natty_launcher.png" file. If any additional graphic assets are required to complete this task please contact me immediately as the task is very high priority.

Changed in ayatana-design:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-05
Changed in unity (Ubuntu):
status: New → Incomplete
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Changed in unity-2d:
milestone: 3.8.2 → 3.10
David Barth (dbarth) wrote :

No news about the new assets.

Changed in unity:
milestone: 3.8.6 → backlog
tags: added: toolate
tags: added: too-late
removed: toolate
Paul Sladen (sladen) wrote :

Confirmation that Bug #750471 ("Ensure Unity prioritises icon loading from Unity-icon-theme") _won't_ be fixed for Ubuntu 11.04 which means that these need to go into elsewhere such that they get loaded first but Unity, but don't screw other things up wanting to use the same icons generically.

Paul Sladen (sladen) wrote :

Further update/clarification at request of dbarth and following conversation with njpatel. Latest plan:

  1. These will go into 'unity-asset-pool', then
  2. njpatel will do the patch (bug #750471) to make sure they are loaded from unity-icon-theme.

Absolute worst case, at SRU time.

Didier Roche (didrocks) on 2011-04-12
Changed in unity-place-files (Ubuntu):
status: New → Triaged
Changed in unity-place-applications (Ubuntu):
status: New → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Fix Committed
Changed in unity-place-files (Ubuntu):
status: Triaged → Fix Committed
Changed in unity-place-applications:
status: New → Fix Committed
Changed in unity:
status: Incomplete → Fix Committed
Changed in unity-place-applications (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
milestone: backlog → 3.8.8
Changed in unity-place-files:
status: New → Fix Committed
John Lea (johnlea) on 2011-04-12
tags: added: fitandfinish
Didier Roche (didrocks) on 2011-04-12
Changed in unity-asset-pool (Ubuntu):
status: New → Fix Committed
Changed in unity-asset-pool:
status: New → Fix Committed
Didier Roche (didrocks) on 2011-04-14
Changed in unity-asset-pool:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-applications - 0.2.46-0ubuntu3

---------------
unity-place-applications (0.2.46-0ubuntu3) natty; urgency=low

  * applications.png:
    - new correct export from sladen by design (LP: #745555)
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 18:09:25 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.46-0ubuntu5

---------------
unity-place-files (0.5.46-0ubuntu5) natty; urgency=low

  * files.png:
    - new correct export from sladen by design (LP: #745555)
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 18:18:05 +0200

Changed in unity-place-applications (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-place-files (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-asset-pool - 0.8.20-0ubuntu1

---------------
unity-asset-pool (0.8.20-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Make unity-icon-theme inherit from Humanity
    - new correct export from sladen by design (LP: #745555)
      (those will be visible only when unity 3.8.8 will land)
  * debian/control:
    - add Vcs-Bzr tag
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 14:08:51 +0200

Changed in unity-asset-pool (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-place-applications:
status: Fix Committed → Fix Released
Changed in unity-place-files:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.8-0ubuntu1

---------------
unity (3.8.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Empty desktop after login (LP: #687660)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #757709)
    - compiz crashed on initial load of Java Citrix Client/Inkscape in
      PrivateWindow::processMap() (LP: #758307)
    - Sometimes dragging down from the panel just stops working (LP: #750155)
    - Ensure Unity prioritises icon loading from Unity-icon-theme
      (LP: #750471)
    - text truncated in Dash. Empty search from Applications or Files lense
      returns “Your search did not” due to cut off label (LP: #757362)
    - should list PlacesGroup.cpp in POTFILES.in (LP: #757663)
    - Launcher intellhide stuck after edge reveal (LP: #757810)
    - unity-preferences doesn't load translations (LP: #759682)
    - dynamic quicklists are not working (LP: #729074)
    - with second monitor, first monitor does not show nautilus
      application/global menu when displaying desktop (LP: #743149)
    - Launcher - The Workspace, File Lens, App Lens and Trash Launcher icons
      need to be rendered correctly (LP: #745555)
    - the launcher background gets dimmed after icons dnd (LP: #747304)
    - Numpad 'Enter' does not work on unity launcher when navigating through
      keyboard (LP: #760003)
    - Launcher shouldn't hover when being in the dash (LP: #760770)
    - Launcher displays key shortcuts while holding Super while the dash is
      open but the shortcuts are unfunctional (LP: #760728)
    - Running/active indicators point to space between launcher icons for
      folded icons (LP: #703067)
    - user-trash.svg and user-trash-full.svg not lens grayscale versions
      (LP: #741804)
    - code-cleanup: unregistered any established ubus-interests (LP: #757588)
    - dropdown box in places search bar does not resize when font size changes
      (LP: #759763)
    - [FFE] Centered layout for expo plugin (LP: #754689)
    - Unity launcher icons tooltips do not disappear when swiching workspaces
      (LP: #744795)
    - Dash - Update Dash scroll bar (LP: #750374)
    - Letters cut off at the end in the applications window (LP: #753083)
  * debian/control:
    - build-dep on grail/geis with version bumped
  * 01_dont_dep_on_latest_geis_grail.patch:
    - not needed anymore
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 22:03:42 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
importance: Undecided → Medium
Changed in unity-2d:
milestone: 3.10 → none
status: Confirmed → Fix Released
Aritchie (aritchie) wrote :

I thoght I would mention this here instead of filing a new bug. What is the status on giving a visual clue there is something in the trash like you have in unity? I know there is a user-trash-full icon for it in the unity icon theme or is there still some debate on the icons to use for the trash?.

Olivier Tilloy (osomon) wrote :

Adam: this specific issue is tracked by bug #715611.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers