Window buttons disappear on maximized windows by changing focus to another maximised window on multi-monitor setups

Reported by Nicholas Christian Langkjær Ipsen on 2011-03-24
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

What happens:
1. Maximise at least two windows on separate displays.
2. Change the focus between them.
3. Note how the windows buttons and menu of the unfocused windows disappear, despite it having its own panel to display them.

What should happen:
1. Maximise at least two windows on separate monitors.
2. Change the focus between them.
3. The unfocused window keeps its window buttons and menu in its own panel, despite not having focus.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,imgjpeg,gnomecompat,text,vpswitch,place,session,mousepoll,snap,regex,grid,move,imgsvg,resize,imgpng,wall,animation,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
Date: Thu Mar 24 11:39:27 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
ProcEnviron:
 LANGUAGE=en_DK:en
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-02-25 (26 days ago)

Gord Allott (gordallott) on 2011-03-24
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Glauco (glauco-hass) wrote :

You don't have to maximize two windows on separate displays. Just maximize one, and let the other window with focus. You must click on the maximized window do bring focus back and only then you can minimize/restore/close it.

Changed in ayatana-design:
status: New → Confirmed
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
John Lea (johnlea) wrote :

Currently working on designing multi-monitor functionality, this is one of the issues we are looking in to.

Changed in ayatana-design:
status: Confirmed → New
tags: added: multi-monitor
Omer Akram (om26er) wrote :

changed the tag back to multi-monitor as it maybe design specific.

tags: added: multimonitor
removed: multi-monitor
tags: added: multi-monitor
removed: multimonitor
Bilal Shahid (s9iper1) wrote :

these 2 bugs may be also related to this bug.any body confirm it please.
bug # 741143
and this bug also
bug # 750186

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in ayatana-design:
status: New → Invalid
status: Invalid → New
Changed in unity:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
John Lea (johnlea) on 2011-11-25
Changed in ayatana-design:
status: New → Opinion
Omer Akram (om26er) on 2011-11-25
Changed in unity:
status: Confirmed → Opinion
Changed in unity (Ubuntu):
status: Confirmed → Opinion
entonjackson (aj-mysc) wrote :

This is IMO one of the biggest problems of Unity! It's a Design and Usability Bug.
It should be solved ASAP! It makes the workflow stuck. In Windows, this is a great advantage, you kann close every window, that is seen on the screen, because every window has its own control.

A simple alpha solution could be as follows...
Imagine a maximized window without focus.
and a non-maximized window, which has the focus.
Hovering over the top bar will give you this 2 things:
1. The menus of the focussed, non-maximized window (this is also how unity is implemented at the moment)
2. The window controls for the maximized window (this is new)

On the first thought, this might be confusing, but on the second it's not bad i think.
For sure it's a better solution, than it is right now...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints