dash home screen can become outdated

Reported by 6205 on 2011-03-07
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Medium
Friik
unity-2d
High
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Dash do not detect new installed or removed applications, until user log off and back log on.

Also shortcuts like View Photos, Check Email or Listen to Music should be removed when user removes applications like Shotwell or Evolution and replaces them with nothing, because in this case will these shortucs launch Firefox. Or you could make those shortcuts faded out and unclickable, unless supported apps are installed. This would propably require some whitelist of apps for music, picture management or email clients...

Currently for exaple it does not recognize Banshee and launches Firefox and beside of that, if i would remove Banshee, it should launch Totem or something else what is available. If i remove Shotwell it should launch EOG or other installed alternative, based on those whitelists etc..

Related branches

lp:~slash-m3/unity/fix-bug-730623
Merged into lp:unity at revision 1012
Gord Allott (community): Needs Fixing on 2011-03-22
Jason Smith (community): Needs Information on 2011-03-18
Alex Launi (alexlauni) on 2011-03-08
summary: - dash do not update itself
+ dash home screen can become outdated
Alex Launi (alexlauni) on 2011-03-08
tags: added: bitesize
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Friik (slash-m3) on 2011-03-12
Changed in unity:
assignee: nobody → Friik (slash-m3)
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Friik (slash-m3) on 2011-03-13
Changed in unity:
status: Confirmed → In Progress
Friik (slash-m3) on 2011-03-14
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity - 3.6.8-0ubuntu1

---------------
unity (3.6.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - crash at the second drag and drop from an unity place (LP: #736704)
    - Compiz crashes with SIGSEGV in nux::GraphicsDisplay::GrabPointer when
      opening the Dash (LP: #737287)
    - Visual Tearing/Rendering Issues with Unity Launcher (LP: #737476)
    - unity-window-decorator crash on unity panel dragout (LP: #740480)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #694699)
    - compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()
      (LP: #692823)
    - the "no result" and "search the web" items need icons (LP: #711199)
    - Resizing with external padding/grab area prevents reaching edge of
      screen (LP: #710356)
    - drag and drop of launcher icons uses microscopic drag icon (LP: #727647)
    - text in places look squeezed (LP: #727799)
    - at-spi-registry consumes most of the CPU and make the system unusable on
      Natty (LP: #729827)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
      directory name: "/desktop/unity/launcher/favorites/app-
      dc++.desktop/type": `+' is an invalid character in key/directory names
      (LP: #737016)
    - Launcher hide state is confusing (LP: #739850)
    - Polish new launcher hide state (part 2) (LP: #740020)
    - launcher icons should expan on super or when entering keynav
      (LP: #741319)
    - Launcher - Dragging a Launcher icon to the Trash should remove the icon
      (LP: #676466)
    - Launcher - Enable dragging and dropping of files & folders to Launcher
      icons (LP: #676549)
    - Dash - Add Dash group header mouseover effect (LP: #689640)
    - unity aborts when you plug in an external monitor (LP: #700757)
    - Keyboard-navigation: focus on launcher remembered (LP: #713340)
    - Launcher Quicklists should always contain the application title
      (LP: #723877)
    - When a maximized window has window on top of it in 'restored state' (not
      maximised) , it is not possible to un-maximized the window by dragging
      the title bar downwards (LP: #723882)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - UI blocked when expanding a section with more than 2000 items
      (LP: #736059)
    - Change ALT-Tab to bring the target window to the front (LP: #736938)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #737814)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - Implement new style scrollbars in Dash (LP: #608124)
    - Closing launcher menu raises window under mouse (LP: #728787)
    - adding url launcher support from the search (LP: #739038)
    - Launcher - Set Launcher 'Hide Animation' to 'Slide only' by default.
      Also introduce subtle fade in effect. (LP: #739567)
    - "Time & Date" settings appears in launcher with empty tooltip
      (LP: #740907)
    - ZeitgeistLog missing implementation of get_property for "connected"
      (LP: #734080)
    - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
    - The Unity P...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Florian Boucault (fboucault) wrote :

Related to bug #736097 and bug #708479

Changed in unity-2d:
importance: Medium → High
milestone: none → 3.10

This problem is still present in fully updated Natty with Unity (not unity-2d). I have just uninstalled Picasa because of bad Wine support, but application shortcurs are still in dash...

Friik (slash-m3) wrote :

The default browser, email program and music player is stored in a GConf key (you can adjust these via the default applications dialog), but there is no such option for an image viewer. Therefore, the dash behaves the following way: It checks for Shotwell, gThumb, F-Spot and EOG and chooses the first available option. If none of these are installed, the icon is not displayed. So you shouldn't have been able to start Picasa from the dash home screen in the first places, because Unity as (atm) no way of knowing whether it is installed or not. Clicking the image viewer icon on the dash home screen should have opened Shotwell (or another of the mentioned alternatives) both before and after you uninstalled Picasa.

I understand, but i have not opened default dash(ubuntu button) but Applications dash/lens and between more applications were still available both Picasa shortcuts, but they did not worked, because i have uninstalled it.. After logout/login they were finally gone. It has looked like dash was not cabable of updating itself in real time..

Changed in unity-2d:
milestone: 3.10 → 3.8.2
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers