[dash search] Searching for a section should display section's app/files

Reported by David Callé on 2011-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned
unity-lens-files
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Undecided
Unassigned

Bug Description

In app-place, searching for "games" should display the same applications as selecting the "Games" section + other apps relevant to the search "games".

In files-place searching for "documents" should display the same files as selecting the "Documents" section + other files relevant to the search "documents".

Omer Akram (om26er) wrote :

rendering is actually done by unity itself but just realized changing the places task to invalid would mark unity bug as invalid(with the script) so not touching the status.
though the bug is confirmed

affects: unity-place-applications → null
David Callé (davidc3) wrote :

Omer, how is it a duplicate of 729023? This bug is not about the way results are displayed (poor wording in my report). It's about searching for section names (Internet, Presentations, Media, Videos etc.) and not obtaining items that are displayed when selecting the section without searching.

Omer Akram (om26er) wrote :

sorry for quickly marking duplicate, the title was tricky ;)

David Callé (davidc3) wrote :

Tricky indeed, edited.

summary: - [dash search] Searching for a section should display every items of it
+ [dash search] Searching for a section should display section's app/files
Alex Launi (alexlauni) on 2011-03-08
Changed in unity:
status: New → Incomplete
Changed in unity-place-files:
status: New → Invalid
Changed in unity-place-files (Ubuntu):
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Incomplete
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
Stephen M. Webb (bregma) wrote :

This is how the applications scope now works. Updating the paperwork to reflect reality.

Changed in unity:
status: Incomplete → Fix Released
Changed in ayatana-design:
status: New → Fix Released
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers