New Evolution instances are open upon clicking on appointments on the indicator

Reported by David Planella on 2011-03-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Indicator Date and Time
Wishlist
Unassigned
indicator-datetime (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: indicator-datetime

If I've got Evolution running, say, I'm checking e-mail, I've noticed that clicking on one of the appointments from my calendars shown in the indicators trigger the opening of a new Evolution instance.

I would rather expect to focus on the current instance I'm using and switch it to the event in calendar mode.

Sebastien Bacher (seb128) wrote :

That's the same behaviour that the gnome version, would require design input because some people might not want to be switched out of context if they are reading emails for example

Changed in indicator-datetime:
importance: Undecided → Low
Changed in indicator-datetime (Ubuntu):
importance: Undecided → Wishlist
Changed in indicator-datetime:
importance: Low → Wishlist
Karl Lattimer (karl-qdh) wrote :

I'm not sure if evolution even has a way of doing single instance but still switching to the right UI

Changed in indicator-datetime:
status: New → Confirmed
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Javier Jardón (jjardon) wrote :

> That's the same behaviour that the gnome version, would require design input because some people might not want to be
> switched out of context if they are reading emails for example

Added ayatana-design team to the bug report

Charles Kerr (charlesk) wrote :

Looks like at some point Evolution started handling being a single-instance app and is doing this automatically now.

Testing this in 14.04, clicking on a second appointment in the calendar or upcoming events list now raises the existing instance of Evolution instead of launching a second copy of evolution.

Changed in indicator-datetime:
status: Confirmed → Fix Released
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Changed in ayatana-design:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers