Spread, Window Management - XDnD directly to a window in the spread fails

Reported by John Lea on 2011-03-02
292
This bug affects 77 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Compiz
High
Unassigned
Unity
High
Unassigned
unity-2d
High
Unassigned
compiz (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Dropping a file into a window via the 'drag file to Launcher, then drag file to Spread' interaction fails to load the file into the selected window.

To reproduce: Open two firefox windows. Drag a .html or .png file to the Firefox icon in the Launcher. As soon as the spread appears quickly drop the file to one of the firefox windows while still in the spread view. The file should open into the window it was just dropped on but nothing happens.

Does not work, needs to be fixed ;-)

The fix requires input redirection

Bug #607796 needs to be fixed at the same time.

John Lea (johnlea) on 2011-03-02
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → John Lea (johnlea)
John Lea (johnlea) on 2011-04-04
tags: added: udt
John Lea (johnlea) on 2011-04-18
tags: added: udo
John Lea (johnlea) on 2011-04-18
description: updated
John Lea (johnlea) on 2011-05-04
Changed in ayatana-design:
status: Fix Committed → Fix Released
Alex Launi (alexlauni) on 2011-05-04
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Alex Launi (alexlauni) on 2011-05-04
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Alex Launi (alexlauni) on 2011-05-05
Changed in unity:
status: Confirmed → Triaged
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
milestone: none → alpha2
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Jason Smith (jassmith) on 2011-06-06
description: updated
Jorge O. Castro (jorge) on 2011-06-06
Changed in unity:
milestone: alpha2 → backlog
assignee: Jason Smith (jassmith) → Unity Community Hackers (unity-community-hackers)
tags: added: bitesize
Jorge O. Castro (jorge) on 2011-06-06
tags: added: backlog
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Andrea Azzarone (andyrock) wrote :

Sorry, i changed status to the wrong bug!

Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed

Is this bug fixed or not ? I still have this problem.

Andrea Azzarone (andyrock) wrote :

@Loic, please see the status next time. It is not fixed btw.

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
Sam Brightman (sambrightman) wrote :

This also occurs with tabs in Firefox (6). If you accidentally detach a tab into a new window, there is no obvious way to put it back again. Instinct is to drag to bar, at which point they spread out and you drop on the old window. This cancels the drag action, however. I didn't get it to zoom to that window at any point.

James Haigh (james.r.haigh) wrote :

Workaround is to hover over the window, then touch the edge of the screen. This allows me to get by with this bug.

HTH.
James.

James Haigh (james.r.haigh) wrote :

Will this be fixed in Oneiric?

Changed in compiz-core:
status: New → Confirmed
Andrea Azzarone (andyrock) wrote :

Dropping something directly into a spread window is something really really really hard to code using X Window System after all if the target is not the entire window but just a single widget.

So only the timeout stuff should be fixed.

John Lea (johnlea) wrote :

@andyrock

Could you open a separate bug for the timeout stuff? It would be great to fix the timeout issue, but as this is a important bug so we should keep it open until the whole bug is fixed.

thanks,
John

Andrea Azzarone (andyrock) wrote :

@John Lea, i'm trying the solve the whole stuff. If i find too hard to fix it I will separete this bug into two ones.

John Lea (johnlea) wrote :

@andyrock

Great, thx! fingers crossed ;-)

Andrea Azzarone (andyrock) wrote :

@John, i think that without input redirection (both in X and Compiz) the solution of this bug is pretty tricky. So we should split this bug into two separate ones.

Maybe DBO or Sam can confirm or propose a solution without inpur redirection.

On Wed, Aug 24, 2011 at 3:32 PM, Andrea Azzarone
<email address hidden> wrote:
> @John, i think that without input redirection (both in X and Compiz) the
> solution of this bug is pretty tricky. So we should split this bug into
> two separate ones.
>
> Maybe DBO or Sam can confirm or propose a solution without inpur
> redirection.

You can't do it without input redirection. Maybe its possible to
forward DnD events, but that's not something I want to do because
that's error prone due to applications which might activate cursor
grabs on DnD.

>
> --
> You received this bug notification because you are a member of Compiz
> Maintainers, which is the registrant for Compiz Core.
> https://bugs.launchpad.net/bugs/727903
>
> Title:
>  Dropping a file into a window via the 'drag file to Launcher, then
>  drag file to Spread' interaction fails to load the file into the
>  selected window
>
> Status in Ayatana Design:
>  Fix Released
> Status in Compiz Core:
>  Confirmed
> Status in Unity:
>  Confirmed
> Status in Unity 2D:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Dropping a file into a window via the 'drag file to Launcher, then
>  drag file to Spread' interaction fails to load the file into the
>  selected window.
>
>  To reproduce:  Open two firefox windows.  Drag a .html or .png file to
>  the Firefox icon in the Launcher.  As soon as the spread appears
>  quickly drop the file to one of the firefox windows.  The file should
>  open into the window it was just dropped on but nothing happens.
>
>  Does not work, needs to be fixed ;-)
>
>  ============================
>
>  This bug would be an ideal bug for someone to get started hacking on
>  Unity, here's some information:
>
>   * Time to fix: 3h
>   * Difficulty: bitesize to normal
>   * Implementation:
>
>  There is a timer in compiz responsible for how long the user must
>  hover a window when the spread is active in order to trigger the
>  spread to collapse back on this window. It is currently way to finicky
>  to get to work right and needs to be "played with" in order to get a
>  better feel. Probably needs a shorter timer that doesn't reset every
>  time the mouse moves a single pixel. Look in the scale plugin in the
>  compiz source tree.
>
>   * Workflow information: http://unity.ubuntu.com/getinvolved/
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/727903/+subscriptions
>

--
Sam Spilsbury

@andyrock

Could you open a new bug for the timer issue, and ping me the bug number to I can design approve it? I'll then update this bug description to cover only dropping directly into a spread window.

thanks!

Andrea Azzarone (andyrock) wrote :

@johnlea
Here's https://bugs.launchpad.net/ubuntu/+source/unity/+bug/832631

@smspillaz
Any plans to add IR to X and Compiz?

John Lea (johnlea) on 2011-08-24
description: updated
tags: removed: bitesize
Sam Brightman (sambrightman) wrote :

From my point of view I only tried to drop because nothing was happening. If I understand correctly, hover is supposed to result in zooming to that window, after which you could drop. If that's correct then fixing it would be satisfactory & v useful.

I'm marking this as "Wont Fix" in compiz and Unity because it requires server side input redirection. I think that the timeout is a useful enough workaround for this.

summary: - Dropping a file into a window via the 'drag file to Launcher, then drag
- file to Spread' interaction fails to load the file into the selected
- window
+ XDnD directly to a window in the spread fails
Changed in unity:
status: Confirmed → Won't Fix
Changed in compiz-core:
status: Confirmed → Won't Fix
Sam Spilsbury (smspillaz) wrote :

Changing the status to Confirmed but targeting to backlog, as this isn't something easily done. Jason says that forwarding XDnD is unreliable and as such this would require server side input redirection. I'll talk to the relevant X people once they're back from XDC to see what was needed.

Changed in compiz-core:
status: Won't Fix → Confirmed
Changed in unity:
status: Won't Fix → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
hdpq (defectoscopny) wrote :

How do you get 'spread' to activate? In 11.10, Unity 4.24 I tried dragging and dropping between two maximized nautilus windows and couldn't even get the spread to activate OR alt-tab to the desired window to drop the file...

@hdpq: same problem here!

cicoandcico (cicoandcico) wrote :

this bug has regressed in oneiric and is no longer reproducible. see bug #607796.

Omer Akram (om26er) on 2012-02-13
Changed in unity-2d:
status: Confirmed → Triaged
Changed in unity:
assignee: Unity Community Hackers (unity-community-hackers) → nobody
Changed in unity-2d (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity-2d (Ubuntu):
status: Confirmed → Triaged
Changed in compiz-core:
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in compiz-core:
importance: Undecided → High
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Critical → High
Andrzej Jarmoniuk (ajarmoniuk) wrote :

Any chances it will be fixed in Precise?

Sadly, Precise still behaves the same way regarding this.

dimovnike (dimovnike) wrote :

I updated to Precise and the drag and drop still sucks... The current way of handling it is unproductive. I agree that the current behavior when dropping to icon opens a NEW app instance with the dropped file loaded, is useful too, but this is not the purpose of the drag and drop. Because the app instance can be opened by simply doubleclicking the file (if from nautilus).

The real problem now is that it should only raise windows, so the user can select to which windows to drop the file, and even in which place!

Ideally i see it working like this:
1. Dropping to an icon opens a new instance with the file loaded.
2. Hovering over an icon exposes all app windows then user has the possibility to hover over needed window, and after that window is raised. In case the application has one single window - it is raised automatically.
3. Now the user can select where to drop the file. (e.g. in Thunderbird he can drop it in attachment field, or in the body directly which is different, same for nautilus with 2 panes open, user can drop the file to the right pane)
4. A hot key must exist, which if pressed while dragging a file will clear all mime type restrictions :)
5. When doing 2, the 1 should still work.

Is there any chance these are done in ubuntu? if i get some free time and produce patches what are the chances these are accepted? Weird thing about unity is that the idea is great but realization is disappointing (this is not the only bug which affects productivity, there are others too).

Changed in compiz:
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
dimovnike (dimovnike) wrote :

Hi,
i made a mistake while trying to view the bug status, i accidentally clicked to "fix released" and it changed the bug status to it.. please, supervisors, change it back.

Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-07-02
Changed in ayatana-design:
status: Fix Released → Fix Committed
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
description: updated
Omer Akram (om26er) wrote :

That won't fix in unity-2d only critical issues are now considered for it.

no longer affects: compiz-core
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in unity-2d:
status: Triaged → Invalid
Changed in unity-2d (Ubuntu):
status: Triaged → Won't Fix
John Lea (johnlea) on 2012-07-10
no longer affects: unity-2d (Ubuntu)
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-09-19
summary: - XDnD directly to a window in the spread fails
+ Spread, Window Management - XDnD directly to a window in the spread
+ fails
dimovnike (dimovnike) wrote :

any idea how to make opened windows to spread? on my systems windows don't even spread .

Do we have a coherent strategy to address this bug? I.e. do we know how
to do it? Reading the comments there's a lot of "defer" and "it's hard"
but the ability to drag to any open window is critical.

The importance is, appropriately, High.

Mark

On Sat, 22 Sep 2012, Mark Shuttleworth wrote:

> Do we have a coherent strategy to address this bug? I.e. do we know how
> to do it? Reading the comments there's a lot of "defer" and "it's hard"
> but the ability to drag to any open window is critical.
>

Making any input including XDnD to a window in the spread requires either
patching toolkits or input redirection in the server. Either one of these
are large work items (eg, 1+ cycle to get it right along with other load),
so if we are to commit to it, we should only do it when writing the new
spread.

I've played around with input redirection in the X Server before,
and I know what it takes to make it work. If we do want to take this on, I
can circulate how its done.

Sam

> The importance is, appropriately, High.
>
> Mark
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/727903
>
> Title:
> Spread, Window Management - XDnD directly to a window in the spread
> fails
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/727903/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help : https://help.launchpad.net/ListHelp
>

Andrea Azzarone (andyrock) wrote :

I started to implement a xdnd proxy, but it has limits. e.g some applications perform different dnd actions if the target window belongs to the same application. There is no way to fix this issue without patching toolkits/apps (or with input redirection).

John Lea (johnlea) on 2012-10-10
Changed in ayatana-design:
importance: High → Critical
MC Return (mc-return) on 2013-07-08
Changed in compiz:
milestone: none → 0.9.10.0
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
tags: added: dnd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions