Slider movement direction in Ubuntu inconsistent when using mouse wheel

Reported by Mario Vukelic on 2011-02-25
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Indicator Display Objects
Undecided
Unassigned
indicator-sound (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: indicator-sound

In LP#725160 and LP#725167 I reported inconsistent wheel direction issues for particular sliders, but now I realized there is a wider issue and thought a separate report is in order. I see the following behavior on up-to-date Natty:

Indicator and indicator menu:
Forward (away from me): increase volume
Backward (toward me): decrease volume

K3b (only KDE app I have installed) is the same. I tried menu Settings -> Configure K3b -> Plugins -> K3b Ogg Vorbis encoder -> Quality level

However other sliders use "Forward (away from me)" to DEcrease, and "Backward (toward me)" to INcrease whatever value:
gnome-power-manager: set brightness
gnome-screensaver: time to idle
tracker-preferences: all sliders
gnome-window-properties: time to raise
Gimp: all filter sliders I tried
And so forth

It seems that sound indicator is the odd one out, which is why I filed it here. However, to me the sound indicator behavior seems more intuitive and so I guess the bug may be elsewhere. K3b behaving the same as sound indicator may be a sign for that.

In case it matters, I use a Logitech Cordless TrackMan on an Apple MacBook Pro 5.34 the trackpad scrolling of which works exactly as the wheel.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: indicator-sound 0.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Fri Feb 25 19:42:06 2011
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100131)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=de_DE.utf8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-sound
indicator-applet-session.log:
 Looking at Module: libsession.so
 Get the username
 entry hint: Post message...
 id_prop_update: assertion `priv->root != NULL' failed
 Using user icon for 'Guest Session' from file: (null)

Mario Vukelic (mario-vukelic) wrote :
Mario Vukelic (mario-vukelic) wrote :

Sorry, can I edit the subject line? There's a typo, "insonsistent" -> "inConsistent"

summary: - Slider movement direction in Ubuntu insonsistent when using mouse wheel
+ Slider movement direction in Ubuntu inconsistent when using mouse wheel
Mario Vukelic (mario-vukelic) wrote :

*facepalm*

Conor Curran (cjcurran) on 2011-05-02
Changed in indicator-sound (Ubuntu):
status: New → Invalid
Olli Ries (ories) wrote :

thank you for your report - please reopen if this issue still exists in 12.04

Changed in ido:
status: New → Incomplete
Mario Vukelic (mario-vukelic) wrote :

Yes, the same issue still exists in Precise Beta 2. In addition, the sliders in System Settings -> Sound do not react to the mouse wheel at all anymore (but the slider in the Sound Indicator still behaves as described in my initial comment)

tags: added: precise
Changed in indicator-sound (Ubuntu):
status: Invalid → New
Changed in ido:
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

This is a question for Ayatana Design and is not an ido / indicator-sound bug -- they are behaving as per the specification. <https://wiki.ubuntu.com/SoundMenu> "Whenever the volume item is highlighted: The Left and Right arrow keys should instantly decrease or increase the volume, respectively, to the nearest 5 percent step. "

And, as the original description says, it would be counter-intuitive to have the volume levels work the other way around.

Changed in ido:
status: New → Invalid
Changed in indicator-sound (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers