When a window is maximised, clicking in the menu bar should bring the window to the top of the window stack.

Bug #723879 reported by John Lea on 2011-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Description:

To reproduce, maximise a window like Thunderbird. Then open a new window into the 'restored state' (non-maximised) on top of the maximised window. Clicking in the empty space in the top bar does not bring the maximised window back to the top of the window z order stack.

Desired resolution:

When a window is maximised, clicking in the empty space in the menu bar bar should bring the maximised window to the front of the z order stack.

John Lea (johnlea) on 2011-02-23
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → John Lea (johnlea)
importance: High → Critical
tags: added: udt
John Lea (johnlea) on 2011-02-28
description: updated
John Lea (johnlea) on 2011-03-01
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Medium
John Lea (johnlea) on 2011-03-04
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-04-19
tags: added: reviewedbydesign
removed: udt
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Lohith D Shivamurthy (dyams) wrote :

Is this a duplicate of lp:731761?

Alan Jenkins (aj504) wrote :

I saw this as a dupe independently. Marking this one as a duplicate of the newer bug, because it has "fix committed" in unity-2d.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers