When windows open for the first time they should not hide the launcher

Reported by John Lea on 2011-02-23
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Alex Launi
unity-2d
Medium
Olivier Tilloy
compiz (Ubuntu)
Medium
Sam Spilsbury
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Description: When a window opens for the first time e.g. when there is no history of it's previous location, it should never open in the space that can be occupied by the Launcher.

Desired solution: When a window opens for the first time, the window should always open into the 'restored state' (non-maximised), and should be positioned so that no part of the window is over the section of the desktop that can be occupied by the launcher.

John Lea (johnlea) on 2011-02-23
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → John Lea (johnlea)
tags: added: udt
John Lea (johnlea) on 2011-03-01
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Medium
David Barth (dbarth) wrote :

It is a valid bug, not a design change request. It requires active support from the compiz/place plugin.

John Lea (johnlea) on 2011-03-08
Changed in ayatana-design:
status: Fix Committed → Fix Released
David Barth (dbarth) wrote :

@Sam: how much of a change would that be in compiz?

Changed in unity:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in unity:
milestone: none → 3.6.6
tags: added: unity
Changed in compiz (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)

I always set up compiz to center windows in "Place Windows" plugin and not use smart placement or what is the name...

On Wed, Mar 9, 2011 at 1:50 AM, David Barth <email address hidden> wrote:
> @Sam: how much of a change would that be in compiz?

I need to fix up the API change which allows plugins to set a
difference between real frame extents and placement ones.

>
> ** Also affects: compiz (Ubuntu)
>   Importance: Undecided
>       Status: New
>
> ** Changed in: unity
>       Status: New => Confirmed
>
> ** Changed in: compiz (Ubuntu)
>       Status: New => Confirmed
>
> ** Changed in: unity
>   Importance: Undecided => Medium
>
> ** Changed in: compiz (Ubuntu)
>   Importance: Undecided => Medium
>
> ** Changed in: unity
>    Milestone: None => 3.6.6
>
> ** Tags added: unity
>
> ** Changed in: compiz (Ubuntu)
>     Assignee: (unassigned) => Sam "SmSpillaz" Spilsbury (smspillaz)
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity.
> https://bugs.launchpad.net/bugs/723878
>
> Title:
>  When windows open for the first time they should not hide the launcher
>
> Status in Ayatana Design:
>  Fix Released
> Status in Unity:
>  Confirmed
> Status in Unity 2D:
>  Confirmed
> Status in “compiz” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Description:  When a window opens for the first time e.g. when there
>  is no history of it's previous location, it should never open in the
>  space that can be occupied by the Launcher.
>
>  Desired solution: When a window opens for the first time, the window
>  should always open into the 'restored state' (non-maximised), and
>  should be positioned so that no part of the window is over the section
>  of the desktop that can be occupied by the launcher.
>

--
Sam Spilsbury

Paul Sladen (sladen) wrote :

Description copied from dup, I think the window placement code is right, but the addition of the shade frame (then being see by the Launcher as part of the window) is what is initiating the hide:

  Starting with a clean desktop and launching a single application (eg. Ctrl-Alt-t for a Terminal) this causes the Launcher to always immediately hide.

  It appears that the window itself is being aligned to not overlap with the Launcher, but that the shadow around it on the left-hand-side overlaps with the Launcher. Ideally the Launcher should not take outside/shadow space into consideration when determining if to hide.

David Barth (dbarth) wrote :

Nice observation, and that would make for an easier fix, ie launcher side, as opposed to doing more of the kind of infrastructure changes compiz doesn't need right now.

David Barth (dbarth) wrote :

I'll mark as a bitesize if someone wants to tackle it. Otherwise we'll come back to that once other priority bugs are fixed.

tags: added: bitesize
Sam Spilsbury (smspillaz) wrote :

It's a more complicated issue with compiz itself.

On Wed, Mar 9, 2011 at 9:55 PM, David Barth <email address hidden> wrote:
> I'll mark as a bitesize if someone wants to tackle it. Otherwise we'll
> come back to that once other priority bugs are fixed.
>
> ** Tags added: bitesize
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity.
> https://bugs.launchpad.net/bugs/723878
>
> Title:
>  When windows open for the first time they should not hide the launcher
>
> Status in Ayatana Design:
>  Fix Released
> Status in Unity:
>  Confirmed
> Status in Unity 2D:
>  Confirmed
> Status in “compiz” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Description:  When a window opens for the first time e.g. when there
>  is no history of it's previous location, it should never open in the
>  space that can be occupied by the Launcher.
>
>  Desired solution: When a window opens for the first time, the window
>  should always open into the 'restored state' (non-maximised), and
>  should be positioned so that no part of the window is over the section
>  of the desktop that can be occupied by the launcher.
>

--
Sam Spilsbury

Sam Spilsbury (smspillaz) wrote :

Or rather, I think I'd prefer for compiz to be setting the correct _NET_WM_FRAME_EXTENTS rather than the launcher hack around these problems.

tags: removed: bitesize
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Sam Spilsbury (smspillaz) wrote :

The unity-2d bug needs to be changed back to reflect the actual state of unity-2d

Changed in unity:
status: Confirmed → Fix Released
Changed in unity-2d:
status: Confirmed → Fix Released
Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4git20110322-0ubuntu1

---------------
compiz (1:0.9.4git20110322-0ubuntu1) natty; urgency=low

  * New upstream bug fix snapshot:
    - Application windows can sometimes fail to display and will
      mask regions of the screen (LP: #709461)
    - Compiz switcher Alt-Tab order is not predictable - should
      maintain LIFO ordering in application switcher (LP: #175874)
    - after compiz crashed, gnome-panel isn't mapped again (LP: #711378)
    - invisible windows border problem (LP: #710271)
    - Compiz thinks you are clicking in an edge window when you
      are not (LP: #734250)
    - Add test case for invisible window regressions (LP: #736876)
    - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
    - When windows open for the first time they should not hide (LP: #723878)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - Pixmaps trashed during animations when window is unmapped (LP: #733331)
    - Windows have blank decorations when rapidly closing and
      reopening (LP: #733328)
    - Unity is not restored on unity/compiz crash: compiz doesn't register
      properly with gnome-session (LP: #716462)
  * remove the patch taken from upstream
  * refresh u-w-d patch with latest upstream work
  * debian/compiz-core.install:
    - image move to the final destination
  * debian/patches/100_bump_core.h.patch:
    - bump for ABI breakage
  * debian/compiz-decorator:
    - use gtk-window-decorator and not unity-window-decorator as it's really
      crashy for now (will probably redo an upload tomorrow with a fixed
      decorator)
 -- Didier Roche <email address hidden> Tue, 22 Mar 2011 21:45:34 +0100

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-03-22
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Florian Boucault (fboucault) wrote :

@Sam: I do not understand what "The unity-2d bug needs to be changed back to reflect the actual state of unity-2d" means. In any case, no work was done in Unity 2D (that is metacity in the case of this bug) in order to solve the bug.

Changed in unity-2d:
status: Fix Released → Confirmed
tags: added: delta-with-3d
John Lea (johnlea) wrote :

Reverted because the fix for this issue has not landed in the latest release.

Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
David Barth (dbarth) wrote :
Changed in unity:
milestone: 3.6.8 → backlog
milestone: backlog → none
status: Triaged → Fix Released
status: Fix Released → Fix Committed
assignee: nobody → Alex Launi (alexlauni)
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
milestone: none → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Anders Ström (strom-anders) wrote :

Windows still seem to open below the launcher if you have activated "Hide Launcher: Never".

If you set "Hide Launcher" to anything else, they open to the right of the launcher, no matter if it's hidden or not.

Timo Reimerdes (timorei) wrote :

Not quite shure if this is related, but since the last time I upgraded new windows don't even pay any attention to what I set in compiz place windows plugin anymore (I set it to center, and they always open in the top left corner of the screen).

This happens on a new user with default settings as well.

John Lea (johnlea) on 2011-04-19
tags: added: reviewedbydesign
removed: udt
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :

Pushed metacity 1:2.30.3-0ubuntu9upicek2 to unity-2d’s daily PPA.

Changed in unity-2d:
milestone: none → 3.10
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-06-06
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
Changed in unity-2d:
milestone: 3.10 → 3.8.8
Didier Roche (didrocks) on 2011-06-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 3.8.8-0ubuntu1

---------------
unity-2d (3.8.8-0ubuntu1) oneiric; urgency=low

  [ Didier Roche ]
  * new upstream release:
    - [spread] Corruption when switching workspaces after windows have been
      moved to other workspaces (LP: #760787)
    - [launcher] launcher won't fully paint, corrupted view (LP: #764690)
    - [launcher] icons no longer active after an incomplete drag (LP: #768812)
    - drag from dash to launcher (LP: #662616)
    - Don't create windows over the launcher (LP: #688816)
    - [launcher] Does not reveal when hovering over the left edge of the
      screen (LP: #760537)
    - UIFe: Launcher - update launcher reveal interaction to make it more
      accessible to first time users (LP: #754583)
    - [launcher] Trash icon should indicate when it has deleted elements
      (LP: #715611)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - double clicks should be disabled on bfb/Place launcher icon/double key
      press (LP: #766776)
    - [dash][launcher] Should use real transparency when a compositing manager
      is running (LP: #794042)
    - [dash] Thunderbird icon is pixelated (LP: #767115)
    - [panel] Hovering the mouse cursor over the BFB reveals the current
      window’s menu (LP: #793403)
    - [panel] Hovering the mouse cursor away from the appmenu applet doesn’t
      hide the menu (LP: #793406)
    - unity-2d: does not parse QT_GRAPHICSSYSTEM env var (LP: #791852)
    - Cannot drag applications from dash to desktop (LP: #756614)
  * debian/control:
    - unity-2d-panel recommends the indicator, not unity-2d
    - appmenu-gtk and appmenu-qt are already provided by indicator-appmenu
    - remove other meaningless recommends
  * debian/libunity-2d-private0.install:
    - install everything in Unity2d private directory

  [ Florian Boucault ]
  * debian/unity-2d-launcher.install:
    - do not install usr/lib/qt4/imports/UnityApplications/ anylonger as all of
      UnityApplications features have been moved to the Unity2d QML plugin
      installed by libunity-2d-private0
  * debian/control:
    - unity-2d-places and unity-2d-spread do not depend on unity-2d-launcher.
      All they need is now in libunity-2d-private0.
 -- Didier Roche <email address hidden> Tue, 14 Jun 2011 16:14:18 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Sam Brightman (sambrightman) wrote :

I have been trying to use --geometry to e.g. get a gnome-terminal to open flush-left as it behaves when snapped to the left by dragging. Even if the launcher is not open, it will always leave space there. Likewise, playing with place windows plugin fixed settings doesn't seem to achieve this. From a design point of view, it seems inconsistent that the snap action ignores the launcher whilst other placement actions pretend it is showing even when it is not. An example problem resulting from this is that you cannot startup an applicatiojn snapped left.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers