Nautilus quicklist does not contain the locations previously found under the 'Places' menu.

Reported by John Lea on 2011-02-23
106
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
One Hundred Papercuts
Low
Didier Roche
Unity
Medium
Didier Roche
nautilus (Ubuntu)
Low
Didier Roche
unity (Ubuntu)
Medium
Unassigned

Bug Description

Description: The right clicking on the Nautilus icon in the Launcher should open a quicklist that lists the bookmarks and locations displayed as Nautilus 'Places'. These locations used to be displayed in the 'Places' menu bar menu, and are still displayed inside Nautilus in the left hand 'Places' sidebar.

Desired resolution:
The Nautilus Launcher quicklist should list all the bookmarks displayed inside Nautilus in the 'Places' sidebar. This list needs to be dynamic, so that if user changes their bookmark, their new bookmarks are reflected in the quicklist. In addition, a 'Open a new window' option should be added to the top of the quicklist.

The quicklist should be formatted as follows:

-----------------------
Open a new window
---------
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
etc... (all nautilus bookmarks should be displayed)
---------
Files
---------
Keep in launcher
Quit
-----------------------

John Lea (johnlea) on 2011-02-23
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → John Lea (johnlea)
tags: added: udt
David Barth (dbarth) wrote :

As a first step, we could add the pre-defined folders to the .desktop file (Music, Videos, etc.) to fill the quicklist. However, we cannot add user-defined places at this stage, since that would take a patch to Nautilus, and we're way past feature freeze.

Changed in ayatana-ubuntu:
importance: Undecided → Wishlist
status: New → Triaged
milestone: none → ubuntu-11.04-beta
affects: ayatana-ubuntu → unity-shell
Changed in unity-shell:
milestone: ubuntu-11.04-beta → none
affects: unity-shell → unity
Changed in unity:
milestone: none → 3.8
importance: Wishlist → Low
John Lea (johnlea) on 2011-03-09
Changed in ayatana-design:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
David Barth (dbarth) on 2011-04-08
Changed in unity:
milestone: 3.8.6 → backlog
tags: added: too-late
John Lea (johnlea) wrote :

For Oneiric the Nautilus quicklist should be dynamic include all folders currently bookmarked by the user in Nautilus.

tags: added: udo
John Lea (johnlea) on 2011-04-19
Changed in ayatana-design:
importance: High → Medium

LOL
"How to make Unity usable" xD

Jason Smith (jassmith) on 2011-05-05
Changed in unity:
milestone: backlog → ux-backlog-2
milestone: ux-backlog-2 → ux-backlog-1
assignee: nobody → Didier Roche (didrocks)
John Lea (johnlea) on 2011-05-06
Changed in ayatana-design:
importance: Medium → High
Jorge O. Castro (jorge) on 2011-06-07
tags: added: backlog
Omer Akram (om26er) on 2011-06-19
Changed in nautilus (Ubuntu):
status: New → Triaged
wiz (wiz) wrote :

Will it get a go in oneiric?

Didier Roche (didrocks) wrote :

This is related to Bilal's work

Changed in unity:
assignee: Didier Roche (didrocks) → Bilal Akhtar (bilalakhtar)
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in nautilus (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Low → Medium
assignee: Bilal Akhtar (bilalakhtar) → nobody
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-19
Changed in ayatana-design:
status: Fix Committed → Triaged

Is it so difficult to add at least some default places to the Nautilus quicklist?
As it is now, to open a new Nautilus window I have to go in the Nautilus' menu!

Adolfo Jayme (fitoschido) wrote :

Mar Castelliccio hit the spot.

Isn't this quicklist redundant with the desktop's Places menu? Is so hard to disvover/get into the Places menu?

Adolfo Jayme (fitoschido) wrote :

I mean, the desktop's ‘Bookmarks’ menu.

I think it's hard to discover, as I can't find it (and have never seen it since 11.04).
What is this desktop's "Bookmarks" menu?

- Click on desktop to get it focused
- Move the mouse to top panel
- You should see the deskop menu now

This doesn't work with Unity 2D, see bug 769254 for that.

I don't see this menu.
However it's different from the problem of the bug, because if you have other applications opened, it's really slow to go to the desktop to open new windows.

John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in nautilus (Ubuntu):
importance: Medium → Low
John Lea (johnlea) on 2011-11-18
description: updated
John Lea (johnlea) on 2011-12-12
description: updated
Lars Jarlvik (lars-jarlvik) wrote :

There's a how to on OMG Ubuntu! which works fine for people who would like to add places to their quicklist in 11.10:
http://www.omgubuntu.co.uk/2011/04/how-to-add-folder-quicklists-to-the-home-launcher-in-ubuntu-unity/

Chris Wilson (notgary) on 2011-12-12
Changed in hundredpapercuts:
milestone: none → precise-1-file-management
Chris Wilson (notgary) on 2011-12-12
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
assignee: nobody → Papercuts Ninja (papercuts-ninja)
tags: added: bitesize
Dmitry Shachnev (mitya57) wrote :

Speaking about the implementation, I see two possibilities here:

 - Write a simple script that watches .gtk-bookmarks file and exports its contents to the quicklist of nautilus(-home).desktop.
 - Write a patch for Nautilus itself that makes use of NautilusBookmarkList object, exports it to the quicklist, and connects its signals to an internal function which opens a new window/tab.

The latter is much easier to implement, but it will probably increase boot time.
@seb128, didrocks: Any ideas on what's better?

Sebastien Bacher (seb128) wrote :

@Dmitry: why would the second one impact on boot speed? couldn't we just add a dbus method or callback to nautilus that get called on first list opening?

Note that upstream is working into moving the nautilus bookmark side panel logic to gtk so the gtkfileselector uses the same one:
http://live.gnome.org/GTK%2B/GtkPlacesSidebar

Dmitry Shachnev (mitya57) wrote :

s/boot time/login time/g
It depends on a language used. If it's Python, it will take at least 1s to load, if not 2. It has no sense to write such a program in C — because we'll have to re-implement things that already exist in libnautilus-private/nautilus code. And I don't know about Vala.

I'll now take a look at nautilus code and try to write a basic patch for that.

Sebastien Bacher (seb128) wrote :

ok, I think I misread your comment about which solution will increase start time (or you wrote it backward?), either way having nautilus doing the job would be nicer than having a script ;-)

Dmitry Shachnev (mitya57) wrote :

My idea was like that: http://paste.ubuntu.com/771189/, but I doesn't work (and even no error messages appear). I need someone who knows dbusmenu/unity api well to help me debug that :)

Also, that patch needs better memory management, as now all existing menuitems are not deleted when the quicklist is updated.

Dmitry Shachnev (mitya57) wrote :

… but it doesn't work …

Sebastien Bacher (seb128) wrote :

You might want to email https://lists.launchpad.net/ayatana-dev/ for questions, it's not likely that lot of people will notice comments on that bug

summary: - Natuilus quicklist does not contain the locations previously found under
+ Nautilus quicklist does not contain the locations previously found under
the 'Places' menu.
Sebastien Bacher (seb128) wrote :

(or attach the patch to the bug and subscribe ubuntu-sponsors)

Sebastien Bacher (seb128) wrote :

(or do a merge request against the packaging ;-)

Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
John Lea (johnlea) on 2012-01-09
Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
status: Invalid → Confirmed
status: Confirmed → Triaged
Didier Roche (didrocks) wrote :

Actually, I started it on the plane

Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Didier Roche (didrocks)
milestone: backlog → 5.0.0
Changed in nautilus (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Dmitry Shachnev (mitya57) wrote :

@Didier: this should be compatible with quicklist entries that are displayed during file operations, see 12_unity_launcher_support.patch for details.

Gord Allott (gordallott) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.2.0 → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Didier Roche (didrocks) wrote :

@Dmitry: Thanks! I noticed that last week and will merge the 2 patches with a quicklist provider in nautilus.

Didier Roche (didrocks) wrote :

Ok, patch done, will upload it tomorrow morning. Please note that the "Open a new window" is a static quicklist (so, it's there even if nautilus isn't running or showing the desktop). But in the current implementation, static quicklist are displayed after dynamic one. That shoudln't be the case IMHO and they should be displayed before anything (and this will then follow the spec).

Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-2ubuntu9

---------------
nautilus (1:3.2.1-2ubuntu9) precise; urgency=low

  * debian/patches/12_unity_launcher_support.patch:
    - add support for a second quicklist for nautilus: bookmarks (LP: #723862)
    - refactoring a great part of the patch to allow multiple
      "quicklist groups" for nautilus, and each part managing just a subset,
      grouping elements and such.
  * debian/patches/20_static_unity_quicklist.patch,
    debian/nautilus-home.desktop,
    debian/nautilus-home.desktop.in:
    - adding a static "Open a new window" quicklist to both nautilus.desktop
      and nautilus-home.desktop
 -- Didier Roche <email address hidden> Tue, 17 Jan 2012 09:22:04 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Bowmore (bowmore) wrote :

A comment to this fix:
It's not a good idea to alphabetically sort folders and bookmarks as one group of objects. The quicklist should group Computer folders and Bookmarks separatelly and preferably in that order. Confer the presentation in Nautlius sidebar.

Didier Roche (didrocks) wrote :

Indeed, I agree with you. However, it seems there is no easy way to get that list of bookmarks sorted as you say here (we don't have the information in the same order and I don't want to rely on a nautilus window to be opened to get that list). Patches to fix it are more than welcome there :)

Bowmore (bowmore) wrote :

Ok, I see.

Anyhow, one approach could be to use the output from command ls below
cd ~
ls -d */
which lists ALL not hidden user top folders.

Another approach is to extract the default top folders from the file ~/.config/user-dirs.dirs and adding the home folder.

From that those top folders can be removed from the "bookmark list" in the quicklist.

The second approach is more in line with Nautilus computer folder list content.

Bowmore (bowmore) wrote :

I prefixed the bookmarks from the top folders with "|> " without quotes as a wotkaround. This will list top folder (Desktop, Documents, Downloads, Music etc) first and "remaining" bookmarks last in the quicklist. I think this is the preferred way as top folder are few (at least if only default folders are listed) and bookmarks can be numerous.

Doug McMahon (mc3man) wrote :

Maybe I need to do a fresh install to check but there appears to be a downside here -
All quicklists are now opening in the same browser window when previously thru a custom nautilus-home.desktop, quicklists would open in a new window

Additionally if one moves to another workspace again the current quicklists open in the previous window, not on the current workspace. So now users must first open a new Home folder window to get to a new quicklist location in a new window??

psypher (psypher246) wrote :

There are some other inconsistencies as well.

1. If nautilus is open in the background behind another app, clicking a QLBM (quicklist bookmark) opens and browses to that bookmark in the background nautilus but does not bring the window to the foreground. This is intermittent, sometimes the window is brought to foreground, sometimes not. Sometimes it happens when nautilus is already open. Sometimes it browses to the folder, sometimes it opens a whole new window and browses to it. really struggling to consistently reproduce, seems to happen at random.

2. With an open nautilus window, in foreground when you try clicking the home folder QLBM, nothing happens. But then trying to click any other QLBM after that suddenly a new nautilus window opens focusing on home folder. Do the same for when nautilus is in the background, it just brings the window to the foreground but does not open home folder.

3. Sometimes the QLBM's don't work at all and causes a nautilus crash. Click bookmark and nothing happens, click another bookmark nothing happens. Click home folder QLBM or just the home folder icon in launcher and then it opens, or nothing will happen for a second and then nautilus crashes. This too is intermittent, struggling to reproduce consistently.

Will play around some more and report back tomorrow

Doug McMahon (mc3man) wrote :

One such crash - bug 917717

Thanks for the feedbacks!
The crash doesn't seem to be related to the quicklist.

For the behavior, I tried to be consistent with the nautilus accelerator (which seems to be used in the nautilus desktop menu as well) and am using the same code path on purpose. I agree this can seem to have some inconsistencies there, but I think this should be fixed everywhere: when using the menu, when using the shortcut and in the quicklist, consequently. (maybe another bug report for that?)

Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) wrote :

I think you would find that desktop merger was myself ;)

Didier Roche (didrocks) wrote :

FYI, I pushed in lp:~ubuntu-desktop/nautilus/ubuntu a new version which always open a new window with the bookmark content.

Doug McMahon (mc3man) wrote :

Didier Roche (didrocks) wrote >
>I pushed in a new version which always open a new window with the bookmark content.
That will be nice to see, though I'm sure there will be varying opinions as to the way to go

As far as the crash, which I can't see the main report - at least here with the current nautilus packages get it consistently.
If I re-build nautilus without the 12_. patch then no crashes, built off of the gtk 3.3.6 libs, used with both those & the new ones (3.3.8)
(- The new gtk/gail is causing some issue here with light-themes, but as far as crash behavior is consistent

Do we need a static "Open a new window" action now? It does the same
thing as "Home" bookmark and middle-click on the launcher item.

Dmitry Shachnev (mitya57) wrote :

Ignore that, there's no bookmark for Home...

Bowmore (bowmore) wrote :

I would rather prefer that shortcuts in the quicklist open new tabs than new windows. That was also what I expected the first time I tested this new Home quicklist.

Myself I use a number of customized quicklists and one example here is firefox. There I use "firefox -new-tab <url>" to achieve that and the firefox window is always focused. That's to me an expected behaviour not new windows each time crowding the desktop.

However, I was going to test that case for nautilus but can't find a command option for setting up a new nautilus tab. Maybe that's why this behaviour was not implemented?

Didier Roche (didrocks) wrote :

There is a gsettings key for other tab behavior in nautilus. We can maybe link to that, but we have to take into account the case where there is no nautilus window opened, raise to focus this one, move your current workspaces and such.
I do not have enough time to work on that and need to fix other bugs to make precise rock solid. I would though gladly accept a patch doing it :)

Bowmore (bowmore) wrote :

> We can maybe link to that, but we have to take into account the case where there
> is no nautilus window opened, raise to focus this one, move your current workspaces
> and such.
All that work for e.g. firefox even when there is no current firefox window but I guess nautilus is not designed to support this behaviour fully and easily as one have to patch nautilus to implement the quicklist.

> I would though gladly accept a patch doing it :)
I would gladly help if I had the skills ;)
Hope that someone having that and time will look into this.

Thanks anyway.

Nick Tait (jnick-tait) on 2012-03-08
tags: added: furtherdesignreviewrequiredp
John Lea (johnlea) on 2012-04-26
tags: added: reviewedbydesignp
removed: backlog bitesize furtherdesignreviewrequiredp too-late udo udp udt
Changed in ayatana-design:
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

The Bug Desciption formats Desktop Actions at the top of the quicklist, currently they show below Bookmarks, does the unity bug need re-opening or the Desctiption changed?

John Lea (johnlea) wrote :

Marking as fixed released, however one of the issues in the original bug report is outstanding so I have reported this in a new bug. See https://bugs.launchpad.net/ubuntu/+source/unity/+bug/988788

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers