Right clicking on the desktop still displays the “Create Launcher...” option.

Reported by John Lea on 2011-02-23
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Nautilus
Fix Released
Wishlist
Unity Foundations
Wishlist
Didier Roche
nautilus (Ubuntu)
Wishlist
Didier Roche

Bug Description

Right clicking on the desktop still displays the “Create Launcher...” option. This option needs to be removed and this functionality disabled.

John Lea (johnlea) on 2011-02-23
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → John Lea (johnlea)
tags: added: udt
David Barth (dbarth) wrote :

It needs to be disabled, when not running in the classic mode, that is...

Changed in ayatana-ubuntu:
importance: Undecided → Medium
status: New → Triaged
milestone: none → ubuntu-11.04-beta
John Lea (johnlea) on 2011-03-01
Changed in ayatana-design:
status: Fix Committed → Fix Released
David Barth (dbarth) wrote :

I doubt we'll be able to land that at this stage. Besides, creating a launcher when right clicking on the desktop will create a launcher on the destkop, which is a feature we still permit since nautilus displays launchers on the desktop as well.

affects: ayatana-ubuntu → unity-foundations
Changed in unity-foundations:
milestone: ubuntu-11.04-beta → none
milestone: none → ubuntu-11.04-beta-1
importance: Medium → Wishlist
milestone: ubuntu-11.04-beta-1 → none
John Lea (johnlea) on 2011-04-19
Changed in ayatana-design:
importance: Medium → Low
tags: added: udo
Jason Smith (jassmith) on 2011-05-05
Changed in unity-foundations:
assignee: nobody → Didier Roche (didrocks)
Jorge O. Castro (jorge) on 2011-06-06
Changed in unity:
status: New → Confirmed
assignee: nobody → Unity Community Hackers (unity-community-hackers)
milestone: none → backlog
Jorge O. Castro (jorge) on 2011-06-06
tags: added: backlog
Didier Roche (didrocks) on 2011-06-07
Changed in unity (Ubuntu):
status: New → Confirmed
David Raid (davidraid) wrote :

I actually find this functionality to be invaluable.
When downloading and testing something that does not install itself onto your system, it's useful to be able to make a launcher with a custom icon and then throw it onto the Launcher.

Robert Roth (evfool) on 2011-06-23
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
Bazon (bazonbloch) wrote :

Using "create launcher" on desktop is an easy way to create a custom Unity-launcher:
http://askubuntu.com/questions/13758/how-can-i-edit-create-new-launcher-items-in-unity-by-hand
(see second answer which starts with "This is a method without editing config files and without root privileges.
First create the Launcher on the Desktop (only temporary)")

Will there be another easy way to create custom launchers (including command line options) without this option?

Didier Roche (didrocks) on 2011-06-24
Changed in unity:
status: Confirmed → Triaged
Steve George (slgeorge) wrote :

I have a 24" screen which I use for all sorts of launchers and project files (links), it's very useful. So removing the ability to have custom launchers would be a significant _regression_ for my use-case.

This seems to be set to Wishlist. But, when someone gets to fixing it please explain _why_ this is considered a bug?

Thanks,

SG

This bug should be closed. It is not constructive.

François Rey (fmjrey) wrote :

Could someone explain:
-why this functionality needs to be removed?
-what the recommended way to create launcher?

I find this feature very useful, so please don't remove it unless you have a good reason and an easy way to do the same.
Thanks

Didier Roche (didrocks) wrote :

@François:
- the dialog brought confusion from some user testing from our design between unity and the desktop.
- furthermore, this feature depends on gnome-panel, which we won't install by default in Oneiric

You can still launch this binary manually (which was what this entry did): gnome-desktop-item-edit --create-new <name of the desktop file>

affects: unity (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
affects: unity → nautilus
Changed in nautilus:
milestone: backlog → none
assignee: Unity Community Hackers (unity-community-hackers) → Didier Roche (didrocks)
assignee: Didier Roche (didrocks) → nobody
importance: Undecided → Unknown
status: Triaged → Unknown
Changed in unity-foundations:
status: Triaged → Invalid
Changed in nautilus (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in nautilus:
importance: Unknown → Wishlist
status: Unknown → New
Dilton McGowan II (diltonm) wrote :

"furthermore, this feature depends on gnome-panel, which we won't install by default in Oneiric"

I am about 100% certain it uses nautilus not gnome-panel.

Furthermore, instead of removing this incredibly valuable tool how about REMOVING UNITY AND INSTALLING FREAKING GNOME 3.

Furthermore, if you remove this needed functionality you will be removing more users from Ubuntu than you add.

Sebastien Bacher (seb128) wrote :

> I am about 100% certain it uses nautilus not gnome-panel.

the current oneiric code in nautilus-desktop-icon-view.c is

" nautilus_launch_application_from_command (gtk_widget_get_screen (GTK_WIDGET (data)),
        "gnome-desktop-item-edit",
        FALSE,
        "--create-new", desktop_directory, NULL);"

gnome-desktop-item-edit is a gnome-panel binary

note that the binary is not removed, only the context menu access to it is dropped, you can style type "gnome-desktop-item-edit" in the "run a command" entry for example or make a launcher to it

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.1.3-0ubuntu3

---------------
nautilus (1:3.1.3-0ubuntu3) oneiric; urgency=low

  * debian/patches/12_remove_create_launcher_on_desktop.patch:
    - remove the "create launcher" entry from desktop right-click. It's depending
      on a gnome-panel binary, confusing the user when unity is running and
      default upstream sessions don't have even nautilus drawing the icons on
      the desktop. Do the same for other places as well. (LP: #723861)
 -- Didier Roche <email address hidden> Mon, 25 Jul 2011 11:44:24 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Changed in nautilus:
status: New → Fix Released
Pacho Ramos (pacho) wrote :

Personally I don't think people wanting to create a launcher to run a custom program will know that they will need to run "gnome-desktop-item-edit" to create a launcher. Isn't there any easier way to generate a launcher? Even creating it as a menu entry for gnome-shell/unity and then drag&dropping it to the desktop (if enabled) (not sure if it's allowed as I am still using Gnome 2.32)

Vicenç Juan Tomàs (vtomasr5) wrote :

I do not like is removed a good functionality without having another replacement. I hope that next LTS again be present.

Many people I know you create your own shortcuts on the desktop. (They still use 10.04 LTS)

anthropornis (anthropornis) wrote :

I am confused by the advise above to launch the binary manually. I am using Natty and currently do not have gnome-panel installed, and thus the binary itself is not working. The terminal output prompts me thusly:

gnome-desktop-item-edit --create-new <launcher name>
The program 'gnome-desktop-item-edit' is currently not installed. You can install it by typing:
sudo apt-get install gnome-panel

So if gnome-panel will not be installed in Oneiric, I still don't know how to create a .desktop launcher file on the desktop.

It does not get much easier than right-clicking on the desktop to create a program launcher. I don't understand why you are removing this functionality. If it actually caused some sort of problem in user testing, please, educate those users, change the wording on the right-click menu if necessary, because removing it creates a different set of usability issues.

Sebastien Bacher (seb128) wrote :

Could people stop adding comments there? It has been stated before that the binary can't be used because it's in gnome-panel which is not installed, so it needs to be added back in some other way, if you are interested to help and work on that please feel free to work on it, otherwise complains that people who are overworked don't add back a feature you use might make sense to you but they will not help getting it back

Sebastien Bacher (seb128) wrote :

Ok, John just mentioned to me that https://launchpad.net/unity-launcher-editor should fit that need and work on packaging it is on going on so it should be avalaible in Ubuntu next cycle for those who want it

Johannes (johannes-schindelin) wrote :

@Sebastian: I guess the reason people are still commenting even getting discouraged all the time is that people are missing the functionality that has been removed without an adequate replacement. Count me into that group of people. It does not help that my previous solution stopped working, too: select "classic desktop".

John Lea (johnlea) wrote :

@johannes-schindelin; are there any specific features or functionality you would need to see added to unity-launcher-editor in order for it to be able to fulfil your use cases?

Someone (temp4746) wrote :

This change is really bad... I have seen so many complaints about it on the Internet.
What's wrong with having a way to create a custom .desktop launchers easily?

There just needs to be something to replace this feature.
I have seen there is a project to edit the Launcher but there also needs to be a way to edit the Dash and then I guess you can use the drag and drop functionality recently added to add the launcher to the desktop.

Sebastien Bacher (seb128) wrote :

Nothing wrong, see https://launchpad.net/unity-launcher-editor, the feature is not dropped it's just a move from an old unmaintained GNOME component to a new software

Pacho Ramos (pacho) wrote :

Will be any alternative for Gnome (upstream) fallback mode? Thanks for the info :)

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed

So there's no currently obvious way to edit launchers and this doesn't seem odd to the devs and release managers? Jumping to Unity before this kind of basic functionality is in place has pointlessly added to the change shock frustration, and makes me even less well disposed to having the change imposed :(

Launcher icon menus should provide the facility to edit the launcher.

Right-clicking on the launcher itself should provide a config menu.

I don't quite get it:

The panel is definitely a /consumer/ of launchers (because you need them to do anything usefrul with it). But, with removing the last /producer/ there is no longer a convenient way to create them - You all seem to be expecting every single program will provide application launchers. Leaving it as it is, would basically render the complete Unity panel useless.

I do agree that creating custom launchers on the desktop is probably a bad idea. I also agree that it did make sense to remove that function. But I very much disagree that there is no replacement needed - There's now now no convenient method to add custom programs to the panel.

How about an option on the panel itself to create a custom launcher in there?

Marc (ms-thebrookhavengroup) wrote :

I figured out how make launchers by simply writing *.desktop files. I now have about 6 custom launchers that I use everyday. It is convenient for some of them to be on the panel and some on the desktop and some in other directories based on their context. How could the developers know how I need or want my computer to be set up? The hardest and most frustrating thing about adopting the Unity Desktop was figuring out how to add my own launchers particularly when this was a solved problem in earlier versions of Ubuntu.

BTW, for those who don't know you can look for any *.desktop file on your disk and copy it to a directory in your account. Then you can edit with emacs or your favorite text editor. Or you can right click on it and select "Properties" to change parameters. They are simple text files. You can use the Nautilus file manager to double click on it to run it. You can also drag it to your Unity panel to install it.

Sebastien Bacher (seb128) wrote :

> The hardest and most frustrating thing about adopting the Unity Desktop was figuring out how to add my own launchers particularly when this was a solved problem in earlier versions of Ubuntu.

The issue has nothing to do with unity though, it's just a GNOME change, you would have it as well if you kept using GNOME

Marc (ms-thebrookhavengroup) wrote :

OK, you make a good point. The GNOME developers should consider adding useful functionality that once worked well and was taken away for no apparent good reason.

Nick Tait (jnick-tait) on 2012-04-20
tags: added: reviewedbydesignp
Changed in ayatana-design:
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-04-20
tags: removed: udo udp udt
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.