Window maximise/un-maximise does not return the window to the same position.

Bug #723859 reported by John Lea on 2011-02-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Tested using:
- Dell Inspiron mini with a screen resolution of 1024 x 600
- Empathy 'Messaging and VoIP Accounts' window

To reproduce:
1. Place the window just below the menu bar
2. Maximise the window using the window title bar maximise button
3. Un-maximise the window using the window title bar un-maximise button
4. The window will now be in a different position!

Desired resolution:
- Un-maximising a window using the un-maximise button should return the window to the same position it was before it was maximised.

John Lea (johnlea) on 2011-02-23
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → John Lea (johnlea)
tags: added: udt
Alex Launi (alexlauni) on 2011-03-03
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: Confirmed → Fix Committed
milestone: none → 3.8
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
John Lea (johnlea) on 2011-03-09
Changed in ayatana-design:
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-04-19
tags: added: reviewedbydesign
removed: udt
Victor Leung (victor-leung) wrote :

Actually, it seems that the released fix only works when the "un-maximise" button is used to restore the window.

When I tried to restore the window by double-clicking on the title bar, the original issue persists, and the window is restored to a different position.

To reproduce:
1. Place the window just below the menu bar
2. Maximise the window by double-clicking the title bar
3. Un-maximise the window by double-clicking the title bar
4. The window will now be in a different position!

Desired resolution:
- Un-maximising a window using double-clicking the title bar should return the window to the same position it was before it was maximised.

John Lea (johnlea) wrote :

Victor Leung; well spotted, I am opening this as a new bug because this is marked as fixed released. thx!

John Lea (johnlea) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers