reducing banshee in the sound menu show it closed in unity launcher

Reported by PEIGNOT Kévin on 2011-02-17
2
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

If you close banshee when playing a music, it will minimze and go to the sound menu. But in the laucher, it will be shown as closed, not as minimized. (the little light between the icon for active or minimized windows isn't there): whereas it's the first place a user will go to find a music player that is acutally running, he will see it as closed ! More of that, clicking on the icon launch a new window of Banshee, instead of reopening the minimized one.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.4.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
Date: Thu Feb 17 12:42:22 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 LC_MESSAGES=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: unity

PEIGNOT Kévin (kpeignot) wrote :
Conor Curran (cjcurran) wrote :

Not relevant for the sound menu but would like to keep this on my radar.

Changed in indicator-sound:
status: New → Opinion
assignee: nobody → Conor Curran (cjcurran)
status: Opinion → Invalid
Alex Launi (alexlauni) wrote :

Banshee is supposed to have single instance detection, what do you mean it's a new window? Does it show the currently playing track in the new window and just resets to the default library view?

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
PEIGNOT Kévin (kpeignot) wrote :

No, the currently playing song continue to be played in background, but the new window is "virgin" : the currently playing track isn't shown in it. it play in background, but the new window doesn't show any song playing.

Paul Graydon (twirrim) wrote :

Seeing this as well. Banshee, to my perception, just vanished. It wasn't on the dock, and no indication it could be found anywhere. However jumping through the 'start' menu buttons to reload banshee did restore the instance I'd been using before. Tried a few different combinations of ways of starting Banshee but been unable to duplicate Kevin's multiple instances.

For what it's worth I don't consider burying banshee under the volume icon on the status bar particularly intuitive. That's where you go to adjust the volume, not control a media player, same on most operating systems/environments. I don't mind the actual change as such, but if you intend media player controls to come under there it ought to have at least some kind of indicator that that is where it can be found. Not sure how exactly, maybe have the volume control icon transition to music notes symbol and back again with a delay.

PEIGNOT Kévin (kpeignot) wrote :

Does not happen for me any more. I ask Garp to change bug status to invalid if he do not have this problem any more.

Omer Akram (om26er) wrote :

Lets see what design say about this.

affects: indicator-sound → ayatana-design
Changed in ayatana-design:
assignee: Conor Curran (cjcurran) → nobody
status: Invalid → New
Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Matthew Paul Thomas (mpt) wrote :

The second part of this bug report is fixed for me as it is for Kévin: when I reopen Banshee, it resumes displaying playback progress of the current track. But that leaves the first part: music is being played by an application that isn't displayed as running in the launcher.

The sound menu, which predates Unity, is based on the idea that whether music is playing should be independent of whether a music player has any windows open. You can play music without opening the player, and conversely, you can close the player without stopping the music. This is implemented in both Banshee and Rhythmbox.

Then Unity arrived, and Unity's Launcher shows how many windows a program has open, up to a maximum of three. Usability tests show that most people don't even notice this. But some people, like Kévin, interpret it as a representation of whether the program is running at all. This is true most of the time, but it isn't true for screencast software (for example), and it isn't true for Banshee or Rhythmbox.

I can think of several possible ways to solve this problem, none of them particularly compelling.

1. Remove the music player integration from the sound menu, so that you must have a player window open to play music. Not only would this add clutter and reduce convenience, it wouldn't solve the problem for screencast software.

2. Show unpinned applications in the Launcher when they are running but have no windows open. This would be fiddly and maybe even impossible to implement reliably.

3. Give up on the pips in the Launcher altogether.

In conversation, John Lea just pointed out the extreme case where your music player isn't pinned to the Launcher, and you open an audio file in Nautilus or the Dash. The music player appears in the launcher and the song starts playing. If you then close the window, it's not at all obvious how to stop the music; you can't just reopen the player from the Launcher, because it isn't there. John suggests a solution specific to this case: when opening an audio file like that, don't open the window in the first place. This would force people to learn about the sound menu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers