Maximized windows in spread have no window decorations

Reported by Jono Bacon on 2011-01-17
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

Binary package hint: unity

When hitting Super-A to initiate the windows spread, everything works fine apart from that any maximized windows don't have their window decorations displayed, and it looks unusual. This affects Unity as of today (I updated today and see this behavior).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.12-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAiZOoDhwAAAAoUAQOAFg14CoA2ml5dkSggT1QAAAABAQEBAQEBAQEBAQEBAQEBlBEAsEBYGSA1I0UA3n0AAAAZAAAA/gAAAAAAAAAAAAAAAAAAAAAA/ABIU0QxMDFQRlczCiAgAAAAEAAKICAgICAgICAgICAgAIg=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Mon Jan 17 13:57:17 2011
DistUpgraded: Yes, recently upgraded Log time: 2010-12-15 19:40:23.273474
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Subsystem: CLEVO/KAPOK Computer Device [1558:1100]
   Subsystem: CLEVO/KAPOK Computer Device [1558:1100]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
Lsusb:
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System76, Inc. Starling NetBook
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=f13ca209-41c3-4345-ba27-3dac7d72cd9e ro vt.handoff=7 quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-12.26-generic 2.6.37
SourcePackage: unity
UnitySupportTest:

dmi.bios.date: 08/06/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 6.00
dmi.board.name: Starling NetBook
dmi.board.vendor: System76, Inc.
dmi.board.version: star3
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: System76, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr6.00:bd08/06/2010:svnSystem76,Inc.:pnStarlingNetBook:pvrstar3:rvnSystem76,Inc.:rnStarlingNetBook:rvrstar3:cvnSystem76,Inc.:ct10:cvrN/A:
dmi.product.name: Starling NetBook
dmi.product.version: star3
dmi.sys.vendor: System76, Inc.
version.libdrm2: libdrm2 2.4.22-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 7.9+repack-1ubuntu3
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu7
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.13.901-2ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20100805+b96170a-0ubuntu1

Jono Bacon (jonobacon) wrote :

 status confirmed
 importance medium

We definitely want to decorate the windows. However, the decorations
should not just be the standard ones scaled down, they should be custom
for the spread view. This has been discussed but I've not yet seen an
acceptable mockup. I've cc'd John and Otto, they will probably create a
task on ayatana-design with tags for visual design input.

Mark

Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Alex Launi (alexlauni) on 2011-02-17
Changed in unity:
status: New → Confirmed
Chad A. Davis (chadadavis) wrote :

This still occurs in unity 3.6.6, but on PC (amd64) and MacBook Pro (amd64), both with proprietary drivers (nVidia) and without (Radeon).
The window decorator does not crash, nor do the windows permanently loose their decorations. Scale simply does not show decorations for any windows that had been maximized when scale was invoked. This happens to nautilus, firefox, gnome-terminal, apparently to every window.

eZFlow (breakdevize) wrote :

Chad is right, same here and it should be marked critical as it's really counter productive and happens several times a day since i use scale a lot.

Omer Akram (om26er) on 2012-01-27
Changed in unity:
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Triaged → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → Fix Released
Changed in ayatana-design:
status: New → Fix Committed
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers