Window Management - Implement maximize and semi-maximise transitions

Reported by John Lea on 2010-12-13
118
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Compiz
Wishlist
Brandon Schaefer
compiz (Ubuntu)
Wishlist
Brandon Schaefer

Bug Description

Implement maximize and semi-maximise transitions

Description:
The window maximize and semi-maximize functionality has already been built, however the 'gesture previews' and transitions need to be perfected. Attached are two animations that show the desired 'gesture preview'. Note the behavior when the user backs away from the gesture preview without releasing the window.

The following art assets are linked from this bug:

1. maximise_gesture_preview.mov
       https://chinstrap.canonical.com/~johnlea/1104unity_elements/maximise_gesture_preview.mov

2. semimaximise_gesture_preview.mov
       https://chinstrap.canonical.com/~johnlea/1104unity_elements/semimaximise_gesture_preview.mov

------------------------------
Note from 12.04 user testing

Participants found that the current 12.04 maximise and semi-maximise transitions are unpredictable and the preview (the orange highlight box) is confusing.

Related branches

lp:~brandontschaefer/compiz/window-max-semi-animation
Merged into lp:compiz/0.9.9 at revision 3568
Daniel van Vugt: Approve on 2013-01-18
PS Jenkins bot: Approve (continuous-integration) on 2013-01-18
Brandon Schaefer: Approve on 2013-01-18
Sam Spilsbury: Abstain on 2013-01-15
MC Return: Approve on 2013-01-14
John Lea (johnlea) on 2010-12-13
tags: added: udn-wm udt
Changed in ayatana-design:
status: New → Confirmed
status: Confirmed → Fix Committed
assignee: nobody → John Lea (johnlea)
John Lea (johnlea) on 2010-12-14
description: updated
John Lea (johnlea) on 2010-12-14
Changed in ayatana-design:
importance: Undecided → High
John Lea (johnlea) on 2010-12-14
Changed in ayatana-design:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2010-12-14
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Jason Smith (jassmith)

Both of these animations are simply not possible right now. Getting a
preview of a window at a different size requires resizing the window,
which if done today would be a giant hack that would likely result in
unpredictable bugs. Animations cannot rely on being able to render the
window at multiple sizes.

--
Jason Smith | Desktop Experience Team
GNOME Developer
Canonical USA Inc.
T. +1.248.756.6266 | <email address hidden>
Ubuntu - Linux for human beings | www.ubuntu.com

Sam Spilsbury (smspillaz) wrote :

On Wed, Dec 15, 2010 at 11:32 AM, Jason Smith <email address hidden> wrote:
> Both of these animations are simply not possible right now. Getting a
> preview of a window at a different size requires resizing the window,
> which if done today would be a giant hack that would likely result in
> unpredictable bugs. Animations cannot rely on being able to render the
> window at multiple sizes.

I wasn't able to look at the videos (missing plugins), but I don't
think that these are impossible per-se. If the videos are showing
windows resizing the content, then we need an XComposite patch create
temporary large pixmaps (or at least a pixmap of a new size) and
resize the window inside of that pixmap. This massively increases
binding speed on the nvidia driver and others.

Otherwise it is possible to do in-compiz by copying the old window
texture into temp memory, and stretching the old texture, fading it
out and fading through the new texture.

>
> --
> Jason Smith | Desktop Experience Team
> GNOME Developer
> Canonical USA Inc.
> T. +1.248.756.6266 | <email address hidden>
> Ubuntu - Linux for human beings | www.ubuntu.com
>
> --
> You received this bug notification because you are a member of Canonical
> Desktop Experience Team, which is subscribed to Unity.
> https://bugs.launchpad.net/bugs/689792
>
> Title:
>  Window Management - Implement maximize and semi-maximise transitions
>
> Status in Ayatana Design:
>  Fix Released
> Status in Unity:
>  Confirmed
>
> Bug description:
>  Implement maximize and semi-maximise transitions
>
> Description:
> The window maximize and semi-maximize functionality has already been built, however the 'gesture previews' and transitions need to be perfected.  Attached are two animations that show the desired 'gesture preview'.  Note the behavior when the user backs away from the gesture preview without releasing the window.
>
> The following art assets are linked from this bug:
>
> 1.    maximise_gesture_preview.mov
>        https://chinstrap.canonical.com/~johnlea/1104unity_elements/maximise_gesture_preview.mov
>
> 2.    semimaximise_gesture_preview.mov
>        https://chinstrap.canonical.com/~johnlea/1104unity_elements/semimaximise_gesture_preview.mov
>
>
>
>
>

--
Sam Spilsbury

Jason Smith (jassmith) wrote :

The video in short shows the window at two sizes at the same time.

On Wed, 2010-12-15 at 05:32 +0000, Sam "SmSpillaz" Spilsbury wrote:
> On Wed, Dec 15, 2010 at 11:32 AM, Jason Smith <email address hidden> wrote:
> > Both of these animations are simply not possible right now. Getting a
> > preview of a window at a different size requires resizing the window,
> > which if done today would be a giant hack that would likely result in
> > unpredictable bugs. Animations cannot rely on being able to render the
> > window at multiple sizes.
>
> I wasn't able to look at the videos (missing plugins), but I don't
> think that these are impossible per-se. If the videos are showing
> windows resizing the content, then we need an XComposite patch create
> temporary large pixmaps (or at least a pixmap of a new size) and
> resize the window inside of that pixmap. This massively increases
> binding speed on the nvidia driver and others.
>
> Otherwise it is possible to do in-compiz by copying the old window
> texture into temp memory, and stretching the old texture, fading it
> out and fading through the new texture.
>
> >
> > --
> > Jason Smith | Desktop Experience Team
> > GNOME Developer
> > Canonical USA Inc.
> > T. +1.248.756.6266 | <email address hidden>
> > Ubuntu - Linux for human beings | www.ubuntu.com
> >
> > --
> > You received this bug notification because you are a member of Canonical
> > Desktop Experience Team, which is subscribed to Unity.
> > https://bugs.launchpad.net/bugs/689792
> >
> > Title:
> > Window Management - Implement maximize and semi-maximise transitions
> >
> > Status in Ayatana Design:
> > Fix Released
> > Status in Unity:
> > Confirmed
> >
> > Bug description:
> > Implement maximize and semi-maximise transitions
> >
> > Description:
> > The window maximize and semi-maximize functionality has already been built, however the 'gesture previews' and transitions need to be perfected. Attached are two animations that show the desired 'gesture preview'. Note the behavior when the user backs away from the gesture preview without releasing the window.
> >
> > The following art assets are linked from this bug:
> >
> > 1. maximise_gesture_preview.mov
> > https://chinstrap.canonical.com/~johnlea/1104unity_elements/maximise_gesture_preview.mov
> >
> > 2. semimaximise_gesture_preview.mov
> > https://chinstrap.canonical.com/~johnlea/1104unity_elements/semimaximise_gesture_preview.mov
> >
> >
> >
> >
> >
>
>
> --
> Sam Spilsbury
>

--
Jason Smith | Desktop Experience Team
GNOME Developer
Canonical USA Inc.
T. +1.248.756.6266 | <email address hidden>
Ubuntu - Linux for human beings | www.ubuntu.com

I doubt we want full preview of the maximise and semi-maximise windows.
Outline seems more appropriate. I am offline but will check the videos
later.

Having seen the movie I think we should focus on a classy outline
approach first, then come back to a blurred preview (snapshot in time)
in a future iteration.

Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
David Barth (dbarth) on 2011-02-22
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) wrote :

Description from duplicate bug entered by Charline after conducting the Natty user testing:

--------------------------------

Usability testing has shown that participants misinterpret the semi-maximise and maximise gesture previous shadow as a warning to stop their action. They do not understand the correlation between this gesture preview and semi-maximising and maximising the window.

Desired solution:
- implement the maximise and semi-maximise transitions as illustrated in the animations provided by design.
- see https://chinstrap.canonical.com/~johnlea/transitions/1104unity_elements/maximise_gesture_preview.mov
- see https://chinstrap.canonical.com/~johnlea/transitions/1104unity_elements/maximise_gesture_preview.mov
- This gesture preview does not need to be live. A cached snapshot of the window can be stretched as a performance optimisation.

tags: added: udo
Changed in ayatana-design:
importance: High → Medium
John Lea (johnlea) on 2011-05-06
Changed in ayatana-design:
importance: Medium → High

It is not very encouraging to know that we need to be authenticated to watch a preview, especially as active community members.

Josh Leverette (coder543) wrote :

Why can't i view these movies even when i'm logged in? it tells me i'm unauthorized.. :(

John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :

The movies are now attached ;-)

@rolandixor @coder543: this is a know issue. See this thread: https://lists.launchpad.net/ayatana-dev/msg00167.html

Jorge O. Castro (jorge) on 2011-07-01
tags: added: backlog
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Undecided → Medium
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Joschi Poschi (joschiposchi) wrote :

When are the effects shown in the videos are coming to Ubuntu? In Oneiric with all the newest updates (proposed included) I still have the orange rectangle preview like in Natty.

At what point will the window be considered set to maximize/semi-maximize? For natty it had that incremental approach and it was confusing as to when/if it would be registered as a maximize gesture. For oneiric there is none, giving a simple "yes or no" answer. Will the mockup be implemented in the current Oneiric approach?

steveacab (antonio.chiurazzi) wrote :

news?
code, package, integration in Precise?

Nekhelesh Ramananthan (nik90) wrote :

Is this going to be available in Precise?

Omer Akram (om26er) wrote :

>> Is this going to be available in Precise?
no

Adolfo Jayme (fitoschido) wrote :

Tip for anxious people: when a bug is milestoned "backlog", it means that it is delayed until more urgent bugs get fixed. So don't hold your breath! :)

John Lea (johnlea) on 2012-06-21
description: updated
John Lea (johnlea) on 2012-08-06
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-10
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in ayatana-design:
importance: High → Critical
Stephen M. Webb (bregma) on 2012-12-18
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
affects: unity → compiz
Changed in compiz:
importance: High → Wishlist
milestone: none → 0.9.9.0
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
importance: High → Wishlist
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.01.21-0ubuntu1

---------------
compiz (1:0.9.9~daily13.01.21-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * Window Management - Implement maximize and semi-maximise transitions
    (LP: #689792)

  [ Sam Spilsbury ]
  * Several memory leaks in ccsIntegratedSettingListAppend() from
    ccsIntegratedSettingsStorageDefaultFindMatchingSettingsByPredicate()
    from
    ccsIntegratedSettingsStorageDefaultFindMatchingSettingsByPluginAndSe
    ttingName() (LP: #1100539)
  * Several leaks in g_settings_new() [g_object_new()] from
    ccsGSettingsNewNoPath() [ccs_gsettings_interface_wrapper.c:184] (LP:
    #1097649)
  * Compiz reports incorrect _NET_DESKTOP_GEOMETRY until first viewport
    switch (LP: #1096455)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3569
 -- Automatic PS uploader <email address hidden> Mon, 21 Jan 2013 04:01:41 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
Nyan Cat (nyancat) on 2013-06-17
information type: Public → Private
Stephen M. Webb (bregma) on 2013-06-17
information type: Private → Public
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers