Dash - Create single widget for Dashboard

Bug #683729 reported by John Lea on 2010-12-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
High
Neil J. Patel
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Create single widget for Dashboard (dash home screen)

Description:
In Natty, when the Dashboard is opened it will display a single widget. This single widget has only two states, open or closed. The icons inside the widget will either launch an application or take the user to one of the Dash Lenses.

- Browse the Web: launches Firefox
- Check Email: launches Evolution
- View Photos: launches Shotwell (or F-Spot)
- Listen to Music: launches Rhythmbox
- Find Media Apps: go to the Dash File Lens with the 'Media' search facet selected
- Find Internet Apps: go to the Dash File Lens with the 'Internet' search facet selected
- Find Files: go to the Dash File Lens
- Find More Apps: go to the Dash App Lens

The following art assets are linked from this bug:

1. desktop_dash_home.png
    https://chinstrap.canonical.com/~johnlea/1104dash/desktop_dash_home.png
    Dash home in the open state

2. desktop_dash_02.png
    https://chinstrap.canonical.com/~johnlea/1104dash/desktop_dash_02.png
    Dash home in the closed state

John Lea (johnlea) on 2010-12-01
tags: added: udn-dash udt
Changed in ayatana-design:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Otto Greenslade (otto-chaotic)
John Lea (johnlea) on 2010-12-13
description: updated
John Lea (johnlea) on 2010-12-13
description: updated
Changed in ayatana-design:
status: Triaged → Fix Committed
assignee: Otto Greenslade (otto-chaotic) → John Lea (johnlea)
David Barth (dbarth) wrote :

The 'Shortcuts' button next to the search box is a toggle to hide or show the "training wheels" shortcuts

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → 3.4
status: New → Confirmed
Changed in ayatana-design:
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
milestone: 3.4 → 3.2.14
status: Confirmed → Triaged
Neil J. Patel (njpatel) wrote :

(first cut)

Changed in unity:
status: Triaged → Fix Released
David Barth (dbarth) on 2011-02-21
tags: added: needsdesignreview
John Lea (johnlea) wrote :

Reverted to triaged because:
- expanding and contracting the widget (switching it between the two states) is broken
- the 4 x 2 grid of widgets reflows into a single line if the dash is expanded. The widgets should always remain in a 4 x 2 grid, and the space between the items should expand or contract to compensate for changes is resolution

Didier Roche (didrocks) on 2011-03-10
Changed in unity:
status: Fix Released → Triaged
milestone: 3.2.14 → 3.6.8
John Lea (johnlea) on 2011-03-10
tags: removed: needsdesignreview
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Triaged
Neil J. Patel (njpatel) on 2011-03-15
Changed in unity:
milestone: 3.6.8 → 3.6.6
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

Reverted to Triarged because the title 'Find Internet Apps' wraps on to the next line. Otherwise this change looks good.

Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
John Lea (johnlea) on 2011-03-30
tags: added: reviewedbydesign
removed: udt
Neil J. Patel (njpatel) wrote :

Changing back to fix committed as the string changed and it no longer does that.

Changed in unity:
milestone: 3.6.6 → none
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers