Touch window management gesture previews

Bug #683688 reported by John Lea on 2010-12-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
Medium
Sam Spilsbury
unity-2d
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Touch window management gesture previews

Description:

When a window is initiated by a three finger touch a set of gesture previews should appear around the window border. For more information see section 5 of the "Unity Touch 11.04 Specification" ( http://use-case-mapper.canonical.com/specifications/0AU5sFuLRpCpBZGZra2pqY2pfMTU3MmhwbXczcWQ1 )

The art assets for this bug have now been fully signed off for Natty:

1. touch_window_gesture_preview.png
   https://chinstrap.canonical.com/~sabdfl/11_04/desktop_and_netbook/touch/
   Design showing the window manipulation gesture previews.

John Lea (johnlea) on 2010-12-01
Changed in ayatana-design:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Otto Greenslade (otto-chaotic)
John Lea (johnlea) on 2010-12-01
tags: added: udn-wm udt
John Lea (johnlea) on 2010-12-14
description: updated
Changed in ayatana-design:
status: Triaged → Fix Committed
assignee: Otto Greenslade (otto-chaotic) → John Lea (johnlea)
David Barth (dbarth) on 2010-12-15
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.6
Changed in unity-2d:
importance: Undecided → Medium
milestone: none → 3.6
status: New → Confirmed
Changed in unity-2d:
milestone: 3.6 → 3.8
John Lea (johnlea) wrote :

Updated description to reflect that the visual design has now been signed off.

description: updated
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
David Barth (dbarth) on 2011-02-22
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
David Barth (dbarth) wrote :

This is a request for feature freeze exception: the feature is implemented in a new compiz plugin that was not approved (design and code audit) in time for the Thursday upload window. We're hereby requesting authorization to land it today, to integrate it into alpha-3 images.

The new module provides a useful feature. Yet, it can be deactivated with a configuration option in case it's stabilization becomes problematic. It's meant to enhance the experience with the MT integration in particular.

David Barth (dbarth) wrote :

http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/903 contains the new module.

The feature rendering has been validated by Design. The code has been reviewed by the DX team through standard practices. The code has been tested by developers.

Neil J. Patel (njpatel) on 2011-03-01
Changed in unity:
assignee: Neil J. Patel (njpatel) → Sam "SmSpillaz" Spilsbury (smspillaz)
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Approved, but only for post-alpha3. We are in freeze mode now.

Didier Roche (didrocks) on 2011-03-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.6.0-0ubuntu1

---------------
unity (3.6.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Menu bar becomes blank periodically (LP: #683065)
    - Unity does not update when screen resolution changes (LP: #684539)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Dash - build the Desktop Dash (LP: #683719)
    - Quicklists not working (LP: #719780)
    - Launcher auto hide animation has a life of it's own / Unity launcher
      constantly sliding in and out without user interaction (LP: #717364)
    - compiz crashed with SIGSEGV in PrivateWindow::getModalTransient()
      (LP: #726235)
    - Don't show launcher number overlays on tap of super (LP: #726630)
    - Optimize texture memory usage for unexposed view icons (LP: #609994)
    - Unity should handle video-out keycodes that correspond to Super + P +
      Enter (LP: #632632)
    - dash - wrong count of remaining items to see (LP: #662605)
    - dash - x search box button visibility (LP: #662614)
    - Touch window management gesture previews (LP: #683688)
    - unity not working on rotated displays (LP: #694596)
    - unity main top bar in displays in wrong area (multi-head issue)
      (LP: #707209)
    - unity place group visual improvements (LP: #714528)
    - Implement ref_state_set for toplevel ATK objects in the panel service
      (LP: #715299)
    - Alt + F1 doesn't show the launcher if hidden (LP: #717125)
    - Keyboard navigation: Choosing a window from launcher doesn't change
      input focus. (LP: #721811)
    - Quicklists not closing when losing focus (LP: #724739)
    - wrong animation in the launcher (LP: #724956)
    - Window management - windows go below launcher and panel (LP: #725463)
    - Media and PrintScreen keys don't work (LP: #621887)
    - super-shortcuts should be "serializable" (LP: #638936)
    - Chromium icon in Unity is distorted / some scaled distored in the unity
      place applications (LP: #670169)
    - launcher stays on screen when it shouldn't | false show/hide positives
      on the launcher (LP: #711176)
    - Keyboard navigation: no public API to know the current Laucher Icon
      selected when key nav is activated (LP: #722660)
    - Require to implement AtkSelection on the Launcher (LP: #723804)
    - LauncherIcon accessibility support requires to expose the selection
      state (LP: #723806)
    - Add keyboard shortcuts for launching separate instances of applications
      (LP: #724865)
  * debian/control:
    - dep on latest nux
 -- Didier Roche <email address hidden> Tue, 01 Mar 2011 14:27:16 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity-2d:
milestone: 3.8 → none
John Lea (johnlea) wrote :

Returned to triaged as they are not in today's build of Unity, gesture interactions seem not to have landed yet. Tested on a 3M multi-touch monitor.

John Lea (johnlea) on 2011-03-11
Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
John Lea (johnlea) on 2011-04-19
tags: added: reviewedbydesign
removed: udt
Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
tags: added: delta-with-3d
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers