No option to delete package files after installed/updated them

Reported by Corey B. on 2010-11-12
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
software-properties (Ubuntu)
Undecided
Matthew Paul Thomas

Bug Description

Since update-manager has updated it's default backend to aptdaemon (10.04 was using synaptic) the synaptic option to delete the packages after they have been installed/updated does not affect the packages downloaded/installed/updated by download manager, causing a regression, especially bad for computers with limited space.

So the problem is that there is no user-configurable option to automatically delete .deb files from /var/cache after they have been installed from software-center or update-manager, eating up disk space.

Corey B. (cbodendein) on 2010-11-12
description: updated
Jacob Nevins (0jacobnk-ulp) wrote :

I see this too on 10.10, but the same setting works on my 10.04 machine.

Jacob Nevins (0jacobnk-ulp) wrote :

Still happening on 12.04.
Will this ever be looked at? It's quite annoying to have to remember to do "apt-get clean" every so often on space-constrained system.

Corey B. (cbodendein) wrote :

Maybe, for me at least, this wasn't actually a bug. I think I expected choosing "Delete downloaded packages after installation" would also clean out the packages in /var/cache/apt/archives already, but simply clicking the "Delete cached package files" button does this, and the "Delete downloaded packages after installation" option does keep the debs out of this folder after I install new packages, for 12.04 at least, marking this as invalid.

Changed in synaptic (Ubuntu):
status: New → Invalid
Jacob Nevins (0jacobnk-ulp) wrote :

Ah. Your use of tenses confused me.

The symptom I'm running into is that after selecting "Delete downloaded packages after installation", when I download new packages/updates, they remain in /var/cache/apt/archives, taking up space. I didn't have any particular expectation on the fate of packages already in /var/cache/apt/archives at the time I changed the option -- I don't recall what that behaviour was.

In short: "Delete downloaded packages after installation" doesn't work for me, at all. (Corey, does it work for you?)

Hence, reopening.

Changed in synaptic (Ubuntu):
status: Invalid → New
Jacob Nevins (0jacobnk-ulp) wrote :

I wrote:
> (Corey, does it work for you?)
Yes, it does, you just said that, sorry. Coffee.

Jacob Nevins (0jacobnk-ulp) wrote :

So, there's some difference between Corey's and my 12.04 installation. What useful information can I supply to figure out what it is?

(Whatever my problem is, it has affected a 10.10 installation and, I think, an unrelated 11.10. But my current 10.04 installation is fine.)

Jacob Nevins (0jacobnk-ulp) wrote :

Did some more testing. Perhaps Corey's and my installations don't differ after all.

On 10.04, changing the "Temporary Files" option to "Delete downloaded packages after installation" in the Synaptic preferences affects *both* Synaptic itself and Update Manager. (Verified by changing it to "Leave all downloaded packages in the cache" and fetching some updates, then setting it back and fetching more updates.)

On 11.04 (at least), the Synaptic setting only affects packages installed through Synaptic; Update Manager always leaves the packages in the cache.

(For completeness, on neither version does the Synaptic setting affect the behaviour of "sudo apt-get install", which leaves stuff lying around in the cache regardless.)

Perhaps one might reasonably expect the Synaptic setting to only affect Synaptic. However, it's a regression in behaviour compared to 10.04, and it leaves no obvious way for users to stop /var/cache/apt/archives growing without bounds due to security and other updates (since Update Manager doesn't have its own preference for this).

Perhaps I can fix this by creating/editing /etc/apt.conf, but I think there should be an easier way. The 10.04 behaviour seems a fine way of configuring this to me.

(Leaving the packages lying around is a silly default anyway. http://brainstorm.ubuntu.com/idea/16215/ reflects this, but the idea of fixing it seems to have run out of steam.)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Robert Roth (evfool) wrote :

@Jacob found the reason for this bug: update-manager in 10.04 uses synaptic as it's default backend (to install/update packages) but has now moved to aptdaemon as a default backend (don't know for sure whether it was for 10.10 or 11.04, I think 10.10 it was).
Jacob is also right that update-manager doesn't have a setting for that in it's settings panel (software-properties), and based on this investigtation this bug is about software-properties (update manager settings) not having a setting to delete packages after install/update, I am reassigning this bug to software-properties and updating the title and description with this information, and also subscribing Ayatana Design and mpt (the designer who has made the design for the update manager settings panel) to comment on the issue, and if required, update the design with the new option, or suggest any better ideas where the cleanup option should appear (as Computer Janitor is not part of the default install anymore, and it was not automatic anyway)

Changed in software-properties (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) on 2012-11-15
affects: synaptic (Ubuntu) → software-properties (Ubuntu)
summary: - Packages aren't deleted after installation
+ No option to delete package files after installed/updated them
description: updated
Robert Roth (evfool) on 2012-11-15
tags: added: needs-design
Changed in software-properties (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers