"open with" missing in files lens

Reported by Pavol Klačanský on 2010-10-27
104
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Medium
Unassigned
unity-2d
Undecided
Unassigned
unity-lens-files
Medium
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

Hi, I have problems with opening files from the files lens in an application that is not the default.

Example:
EOG natively opens pictures, but I cannot open them in GIMP, I have to launch GIMP and then open them

Or I would like to "open containing folder" for a file

=====================

Related bugs:
#662658: "delete files in the dash"
#667545: "[wishlist] rename files in the dash"
#960677: "eog should be replaced by shotwell for displaying images by default"
[there are probably more lingering around still]

Related question:
http://askubuntu.com/questions/10606/will-the-unity-file-manager-feature-right-clicks

Didier Roche (didrocks) wrote :

Natty will make nautilus more obvious in that perspective, but as we discussed in the sessions, the file place should have some design love for the future.

summary: - open with missing
+ "open with" missing
affects: unity (Ubuntu) → unity-place-files (Ubuntu)
Changed in unity-place-files (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in unity-place-files:
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
status: Triaged → Incomplete
Changed in unity-place-files:
status: Triaged → Incomplete
Changed in unity-place-files (Ubuntu):
status: Triaged → Incomplete
Alex Launi (alexlauni) on 2011-02-11
Changed in unity:
status: Incomplete → Confirmed
Changed in unity-place-files:
status: Incomplete → Invalid
Changed in unity-place-files (Ubuntu):
status: Incomplete → Invalid
Changed in unity-place-files:
status: Invalid → Confirmed
Changed in unity-place-files (Ubuntu):
status: Invalid → Confirmed

I think the idea is that you drag the file out over the launcher icon you wish to open it with. There has been some reports on non-working DND however (but it appears to work for some).

I'll mark as Incomplete until someone from design can clear up what the solution is.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity-place-files:
status: Confirmed → Incomplete
Changed in unity-place-files (Ubuntu):
status: Confirmed → Incomplete
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Incomplete
Ingo Gerth (igerth) wrote :

See also related question on AskUbuntu: http://askubuntu.com/questions/10606/will-the-unity-file-manager-feature-right-clicks

+++++++++++++++++++++++++++

Coming from a duplicate, I would like to share my thoughts here. Copy paste from Bug #735997:

It is currently impossible to open a file in the files lens with your program of choice. It is automatically linked to the default program for that mime type.

This is very inconvenient and really limits the potential of the dash. Imagine for example that you opened an image earlier and now want to return to it to do some editing. You go to the files lens, are happy to see the file under recent files, but then you are stuck. Everything you can do is opening it with the standard image viewer. There is no way to right click it and open it with GIMP or a comparable program. There currently isn't even the possibility to open the file's location in Nautilus to open it from there.

I do not mean to say that the implementation for this must be right clicking the file. There are many different possible designs. The important thing is that this functionality has to be implemented, in which ever way.

Proposals:
* For opening files with different programs: Enable drag and drop into the launcher. Then all applications linked to the mime type could be displayed. Drag and drop onto them would open the file with the respective program (as discussed in other bugs plenty of times)
* Highlight Nautilus to open the file's location

summary: - "open with" missing
+ "open with" missing in files lens
Ingo Gerth (igerth) on 2011-03-16
description: updated
Alex Launi (alexlauni) on 2011-04-01
tags: added: needs-design
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Incomplete
Robert Carr (robertcarr) wrote :

Just want to note that dragging to nautilus to open the files location works now.

Ingo Gerth (igerth) wrote :

Didier mention in 2010 that this issue would be tackled for 11.04. Since then, however, there has not been any input.

In my humble opinion this should be target for 12.10. It has not become less of a usability issue since two years ago.
The way Unity can be used to find files now is really fantastic. It has come a long way and has sped up my workflow significantly.

The feature requested in this report would really close the loop though, and avoid the last few major flaws that I see in the current implementation.

Ingo Gerth (igerth) on 2012-04-09
description: updated
Pavol Klačanský (pavolzetor) wrote :

The problem is I really do not know how to implement this in design
I suggest to have only one app for 1 task in default (that means shotwell should open images instead of eog)

description: updated
Changed in unity-place-files (Ubuntu):
status: Incomplete → Confirmed
Jeroen Hoek (mail-jeroenhoek) wrote :

Another practical example:

Most of the time I expect that the default application to launch for SVG images is a light-weight image viewer such as EOG, but I also want the option to open them in Inkscape. Inkscape isn't on my launcher bar because I don't use it daily. Currently searching for recently accessed SVG iamges in Unity offers no way to actually access that file in the way I want. The same holds true for images as #3 notes.

#4:
Dragging a file from the Dash to the Nautilus launcher just opens Nautilus in my home folder. It does not open the folder where the file is. Dragging image files to the Firefox launcher does open them in a Firefox tab.

#6:
Perhaps combine right-mouse or alt-clicking for mouse access, and hold-for-option for touch devices? I.e., when you click/touch the file icon, but don't release it for a set time, present the user with an "open with …" option. This seems like the proper (and expected) metaphor for interfaces that combine mouse and touch.

A nice design might be to switch to a single-file centred view when the user holds down the mouse or touches long enough, and present the contents of the "open with …" menu there.

Changed in unity (Ubuntu):
importance: Undecided → Wishlist
John Lea (johnlea) wrote :

We have a solution for this bug planned, but not sure when it will land.

description: updated
Greg Merchan (gregory-merchan) wrote :

My report about there being no indication of how a file will open (e.g., if it's a script, will it open for reading or be run?) got duped to this. Looking through the comments, I don't see anything about that here, so I mention it now.

Developer (lunixhacker) wrote :

Will the solution land in 12.10?

Ingo Gerth (igerth) wrote :

John, with the new previous feature I now see what you were referring to and where you are probably heading. However, in the current implementation this problem is not completely solved yet. It is now possible to open the containing folder of a file, but it would be more efficient to offer more options.
For pictures, for example, there could be a button "Edit" or so. What is planned in this direction?

Maybe it is time to triage this bug again? I have the feeling that bugs filed against Ayatana Design rarely get evaluated, also in this case. Maybe somebody from design could set the proper status.

Omer Akram (om26er) on 2012-08-19
no longer affects: unity-place-files (Ubuntu)
Jack Ramsay (f-jack) wrote :

This is an opinion and something someone wants not a bug

Changed in ayatana-design:
status: New → Incomplete
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
Changed in unity-lens-files:
status: Incomplete → Invalid
Changed in unity:
status: Incomplete → Invalid
Changed in unity-2d:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers