Clicking on Internet opens Firefox

Reported by Samuel Mehrbrodt on 2010-10-09
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned

Bug Description

When I open the launcher and click "Internet", instead of showing me the list of applications in "Internet", it opens Firefox which is very confusing.
When I choose "Internet" from the List on Top (after opening another category) it shows me the applications in "Internet"

Didier Roche (didrocks) wrote :

I think this is by design, opening an ayatana task to confirm.

Changed in unity:
status: New → Incomplete

Yes, it's by design. We can re-evaluate but most folk don't think of the
internet as a set of applications, they think of the browser. Hence the
decision to make that icon a shortcut straight to the web. We could
consider amending the title accordingly.

Mark

Nick (soapduk) wrote :

I do not like the way this menu item is implemented. For a start it is inconsistent because the other options are all categories, so it is implied that 'Internet' also would be a category.

Solution idea:
How about having 'Internet' as the set of applications that (I believe) it should be, eg Browser, Skype, Pidgin/Empathy, Torrent software, etc. and add another slightly smaller icon called 'Web Browser' or similar, so that with the smaller size it's seen as a sub-menu option from the top level catgories?

Mark Shuttleworth (sabdfl) wrote :

This will be addressed in Natty by:

 - being more explicit ("Browse the Web")
 - using the Firefox icon :-)

Mark

Samuel Mehrbrodt (sam92) wrote :

Sounds good :)
It would be good if it used the icon of the default browser so that it shows the Chromium icon if Chromium is your default browser e.g.

Mark Shuttleworth (sabdfl) wrote :

Not a bad idea, if we can swing that, yes.

Omer Akram (om26er) wrote :

marking fixed as now in Natty it shows 'Browse the web' with a firefox icons as stated in comment#4

Changed in unity:
status: Incomplete → Fix Released
Samuel Mehrbrodt (sam92) on 2013-04-19
Changed in ayatana-design:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers