There is no indication, that launcher manages multiple windows

Reported by adamthecamper on 2010-06-24
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Ubuntu design
Unity
Low
Ubuntu design
unity (Ubuntu)
Undecided
Unassigned

Bug Description

There is currently no idication, that launcher icon manages multiple windows.

Neil J. Patel (njpatel) on 2010-06-25
Changed in unity:
assignee: nobody → David Siegel (djsiegel)
importance: Undecided → Low
milestone: none → 2010-07-15
status: New → Triaged

 status wontfix

For the moment, we don't want to modify the icon purely to indicate the
number of windows associated with the application.

Changed in unity:
status: Triaged → Won't Fix

Could we have "stacked" buttons (i.e. one button mounted on top of another, of which only the bottom border is shown)? Kind of what windows 7 does?

Didier Roche (didrocks) wrote :

@GaryM: there is no need to add an ubuntu task for a "won't fix" bug. Now, I'll sync the status to upstream one. We won't patch dx work in ubuntu :)

Changed in unity (Ubuntu):
status: New → Won't Fix
Mark Shuttleworth (sabdfl) wrote :

I think we will add the ability to know there are multiple windows
running for the application.

 status confirmed

Mark

Changed in unity (Ubuntu):
status: Won't Fix → Confirmed
Didier Roche (didrocks) wrote :

@Mark: seems we get a lot of requests on that. I'm happy to see we will investigate some design there :) Changing upstream task then and adding a ayatana design task.

Changed in unity:
status: Won't Fix → Incomplete
Mark Shuttleworth (sabdfl) wrote :

Thanks Didrocks, you do indeed rock :-)

Oren Horev (oreneeshy) on 2010-11-12
Changed in unity:
assignee: David Siegel (djsiegel) → Unity design (unity-design-team)
Changed in ayatana-design:
assignee: nobody → Unity design (unity-design-team)
Bryce Harrington (bryce) on 2010-12-12
Changed in unity (Ubuntu):
milestone: none → ubuntu-11.04
Mark Shuttleworth (sabdfl) wrote :

 status fixreleased

Mark

Changed in ayatana-design:
status: New → Fix Released

How do i fix it

J@SoN

On Dec 20, 2010, at 3:57 PM, Mark Shuttleworth <email address hidden> wrote:

> ** Changed in: ayatana-design
> Status: New => Fix Released
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> ubuntu-11.04.
> https://bugs.launchpad.net/bugs/598259
>
> Title:
> There is no indication, that launcher manages multiple windows
>
> Status in Ayatana Design:
> Fix Released
> Status in Unity:
> Incomplete
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> There is currently no idication, that launcher icon manages multiple windows.
>
>

I think right now, its difficul to know that there are multiple windows open for a simple app. I think the indications should be a bit more clear: Here is my proposition: putting the number of windows over the app icon like that http://img545.imageshack.us/img545/1723/unity.png

Also when you go into exposé mode in order to see all windows for an app you should be able to see at least the title of the windows you are hovering, because if you have many windows open for the same app (like 5 or 6 OO documents) you might need to click on each one to actually see if its the right one or not you are looking for. Here is another design proposition by putting on top of a window its title when hovering over it: http://img707.imageshack.us/img707/2199/unity3.png

Omer Akram (om26er) wrote :

Baptiste, how about this(see the image). chromium have three windows and
empathy have two. its in Ubuntu Natty (the development release)

On Thu, Dec 23, 2010 at 8:45 PM, Baptiste <email address hidden> wrote:

> I think right now, its difficul to know that there are multiple windows
> open for a simple app. I think the indications should be a bit more
> clear: Here is my proposition: putting the number of windows over the
> app icon like that http://img545.imageshack.us/img545/1723/unity.png
>
> Also when you go into exposé mode in order to see all windows for an app
> you should be able to see at least the title of the windows you are
> hovering, because if you have many windows open for the same app (like 5
> or 6 OO documents) you might need to click on each one to actually see
> if its the right one or not you are looking for. Here is another design
> proposition by putting on top of a window its title when hovering over
> it: http://img707.imageshack.us/img707/2199/unity3.png
>
> --
> You received this bug notification because you are subscribed to unity
> in ubuntu.
> https://bugs.launchpad.net/bugs/598259
>
> Title:
> There is no indication, that launcher manages multiple windows
>
> Status in Ayatana Design:
> Fix Released
> Status in Unity:
> Incomplete
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> There is currently no idication, that launcher icon manages multiple
> windows.
>
>
>

Omer,
I already saw the multiple dots in the latest build, howerver I'm not sure if its very obvious for people as the indication is really small. I show it to some friends and they didnt even see that there were 2 or 3 dots. Thats why I though about the number of windows.

adamthecamper (adamthecamper) wrote :

Well, dots are better than nothing, but I agree, that they are not
realy visible :-) My prefered implementation is to have icons stacked
one on top of the other (way dockbarX, or win7 panel does it). You
know, some way to give the user on a quick glance the information "Oh,
yes, there are more windows behind this icon." IMHO, I don't realy
need to know how many apps do I have open, it might be sufficient to
see that this icon manages more windows, than obvious. Then you'd just
have another set of launcher icons (now you have set for not running
apps, set for currently running apps and I'd add separate iconset for
multiple window app in launcher).

Does it make any sense? :P

Anyway, keep up the good work, I really like this launcher :-)

I wish a merry Christmas to all the devs (and early adopters alike ;)

Adam

 status opinion

On the basis that we have a design, and it's implemented, but some folks
clearly don't agree it's sufficient, I'm marking this opinion rather
than invalid or wontfix.

Mark

Changed in ayatana-design:
status: Fix Released → Opinion
Alex Launi (alexlauni) on 2011-02-11
Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers