xterm icon available by default

Reported by Ralf Nieuwenhuijsen on 2007-07-29
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
ubuntu-gnome-default-settings (Ubuntu)
Low
Unassigned
xterm (Debian)
New
Unknown
xterm (Ubuntu)
Low
Unassigned

Bug Description

The Ubuntu 11.10 desktop by default has three terminals in the Dash labeled respectively as: Terminal, XTerm, and UXTerm. This is rather confusing for users who are told to just run a terminal. XTerm and UXTerm share a rather old, outdated icon and very few users will prefer using them to using the standard, full-featured GNOME Terminal.

XTerm apparently is used by Ubuntu's failsafe mode and so must be present by default.

My Proposed fix:
1.Add NoDisplay=true to the end of these 2 files:
  sudoedit /usr/share/applications/debian-xterm.desktop
  sudoedit /usr/share/applications/debian-xterm.desktop
2. Run sudo update-desktop-database
3. Log out and log back in.
4. Type "term" into the Dash, xterm and uxterm should not show.
5. Close the dash and type Alt+F2, now type "xterm" and "uxterm". The app shows with its icon. When run, the icon will show in the launcher and the Alt-Tab switcher. This fixes the problem mentioned in comment #10.

When the app is running, it's also possible to right-click on the app to lock to launcher in Unity or add to favorites in GNOME Shell. If you're using GNOME Classic, you can easily use Alacarte to unhide xterm.

This should be a good compromise between most users who don't need the clutter of the extra terminals and the ones who actually do want to run xterm. Also xterm has been hidden by default for many releases now and I personally consider their presence now a UI regression, not an improvement.

--Jeremy Bicha

Marco Rodrigues (gothicx) wrote :

I can confirm it in my Gutsy!

Sebastien Bacher (seb128) wrote :

the menu items come from the application package

Alexander Jones (alex-weej) wrote :

Furthermore, why do we even have these installed? If your system is so hosed you can't even use GNOME Terminal, then you should probably just be using a TTY.

Micah Cowan (micahcowan) wrote :

Not all people prefer gnome-terminal to xterm.

Alexander Jones (alex-weej) wrote :

Not all people prefer Firefox to Epiphany, but I don't see that affecting default inclusion.

Yeah, even the gnome-terminal is only used by like 1% of the desktop users.
But I get why its installed by default. Three is just too much though. At least remove the .desktop files from the package.

Hi,

I removed the .desktop files from the xterm package in 229-1 so these
bugs should be closed when that version is synced from Debian.

Cheers,
Julien

Alexander Jones (alex-weej) wrote :

And UXTerm?

Sassur (sassur) wrote :

A fresh install off Tribe 5 with the alternative i386 CD has this menu entry still.

Changed in xterm:
status: Confirmed → Fix Committed
Changed in xterm:
status: Fix Committed → Fix Released
Mantas Zimnickas (sirex) wrote :

Pleas return back xterm.desktop file.

Now Unity, Gnome Shell, Gnome-do, all of them recognize programs by their associated .desktop file.

Because of missing xterm .desktop file it is not possible to add xterm to unity's or gnome-shell's dash, also it is not possible to launch xterm trough launchers mentioned above.

gnome-shell even does not group several xterm windows, because of missing .desktop file.

As I understand all applications must have associated .desktop file to work properly, xterm is not an command line program, so it must have associated .desktop file.

xterm can be removed from menus, etc., but it must have .desktop file, because new desktop environments heavily use them in various ways.

More information: https://bugzilla.gnome.org/show_bug.cgi?id=609363#c6

Is XTerm still installed by default? If yes, then the solution is to mark it as hidden - or to stop installing it by default.

Changed in xterm (Ubuntu):
status: Fix Released → Triaged
Jeremy Bicha (jbicha) wrote :

Yes, please continue to ship the .desktop but set NoDisplay=True

Timo Aaltonen (tjaalton) wrote :

Since the default session is unity, which doesn't have a menu as classic GNOME, I'm inclined to close this bug as 'opinion' rather than implement 'NoDisplay', as the package in oneiric does install .desktop files by default.

The rationale is that apart from Ubuntu/Xubuntu, the other variants don't seem to include xterm by default, so if people install it they most likely want to see the app in the desktop menu as well..

Changed in xterm (Ubuntu):
status: Triaged → Opinion
Jeremy Bicha (jbicha) wrote :

I object to this being marked as "Opinion." Who intentionally uses xterm? If it needs to be there as part of the fallback support, fine. But it is the ugliest 2 menu items in the default install.

Timo Aaltonen (tjaalton) wrote :

As I said, the default install doesn't have a menu, and in oneiric there is no classic gnome included in default either.

Jeremy Bicha (jbicha) wrote :

By menu items, I meant launcher items in the dash. NoDisplay would hide them from the dash.

Matthew Paul Thomas (mpt) wrote :

I know "Opinion" is confusing and all, but I hope we can agree that "in one of the comments somebody proposed a solution that is now obsolete" is nowhere near what it means.

That said, it's not clear what the bug is here. The description refers to Ubuntu 7.10, which is long past its use-by date. If the bug still exists in 11.10 beta, please update the description with steps to reproduce the problem, and reopen the report. Thanks.

Changed in xterm (Ubuntu):
status: Opinion → Incomplete

On Sun, 9 Oct 2011, Matthew Paul Thomas wrote:

> I know "Opinion" is confusing and all, but I hope we can agree that "in
> one of the comments somebody proposed a solution that is now obsolete"
> is nowhere near what it means.
>
> That said, it's not clear what the bug is here. The description refers

essentially, the bug is that someone decided to prevent xterm from
installing a desktop file and/or icon. They're been part of the upstream
source since mid-2007 (patch #226).

awai

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Jeremy Bicha (jbicha) on 2011-10-09
description: updated
description: updated
description: updated
Jeremy Bicha (jbicha) wrote :

mpt, I think the description should be a bit more clear now about what I want.

As part of a clean desktop, we shouldn't have ugly icons that people don't really use. Those icons were hidden until 11.10. If I remember right, the .desktops weren't shipped before then.

Changed in xterm (Ubuntu):
status: Incomplete → Confirmed
Jeremy Bicha (jbicha) wrote :

Xubuntu already hides these icons (in xubuntu-default-settings) and the Ubuntu GNOME Remix will likely do the same thing too.

Everaldo Canuto (ecanuto) wrote :

Yes, Xubuntu already hide these #836311

Everaldo Canuto (ecanuto) wrote :

Also, on package gnome-menus we have gnome-menus-blacklist utility that hide these icons listed on /etc/gnome/menus.blacklist. Unfortunatelly it is commented on post installation script.

Thomas Dickey (dickey-his) wrote :

Jeremy Bicha's comment #19 here (and elsewhere) are a personal attack.
Focusing on the technical issues would be more suitable.

Jeremy Bicha (jbicha) wrote :

Thomas, I don't understand why you think I'm making a personal attack.

I understand that "ugly" and "beautiful" can be subjective but the icon does look dated. It uses an olive green square background without rounded corners. CRT monitors are not popular these days. The icon is also pixelated which is interesting because the icons at http://invisible-island.net/xterm/ aren't.

Ubuntu since the beginning has had the goal of shipping with only one app for a purpose, i.e. Firefox or Chromium but not both. Ubuntu users who prefer xterm to gnome-terminal are fairly rare and should be able to figure out Alt-F2.

description: updated
Thomas Dickey (dickey-his) wrote :

Notwithstanding your comments, the information is easily available.
Your repeated "ugly" is as noted subjective, and given the timeline
(no, I don't believe in coincidence, particularly for repeated slurs by you)
your new comments are apparently in reply to my updates to xterm patch #282.

Jeremy Bicha (jbicha) wrote :

My source for the "icons are less pixelated on the website" comment was http://ubuntuforums.org/showpost.php?p=12210364&postcount=3 which preceded your version 282 by 3 weeks.

Thomas, I appreciate you maintaining xterm for the past 16 years, but I think you have a hard time understanding that xterm just isn't very popular today even among terminal users like I am.

I'm definitely not the only one that doesn't appreciate the xterm icons showing up in the default menus. See the attached Debian bug or http://blog.davekoelmeyer.co.nz/2012/06/30/xterm-on-ubuntu-12-04-manages-to-party-like-its-1989/ for instance.

The technical issue for this bug has nothing to do with how awesome xterm is, but how well integrated it is with the modern Ubuntu desktop (whether Unity, GNOME Shell, GNOME Classic, or XFCE).

Dylan McCall (dylanmccall) wrote :

This really has nothing to do with xterm, except that the fix needs to be in the xterm package. Ubuntu is meant to be easy to understand, and it's really important that new users can explore all of the applications they are getting out of the box without running into a brick wall or feeling lost. That is getting difficult with the signal to noise ratio in the applications menu: scattered alongside the applications we want people to discover and enjoy we have every settings panel, a bunch of different admin tools, xdiagnose, and three terminal applications: gnome-terminal, xterm and uxterm.

This isn't about xterm being bad: it's about xterm and ubuntu-desktop being an odd fit.

Thomas Dickey (dickey-his) wrote :

Well, then - delete Bicha's remarks, and you'll be achieving that goal.

Jeremy Bicha (jbicha) on 2012-10-04
Changed in ubuntu-gnome-default-settings (Ubuntu):
status: New → Triaged
importance: Undecided → Low
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-default-settings - 12.10.3

---------------
ubuntu-gnome-default-settings (12.10.3) quantal; urgency=low

  [ Tim Lunn ]
  * Add ubuntu logo to gdm greeter screen.

  [ Everaldo Canuto ]
  * Fix missing password prompt for encrypted partitions (LP: #1060123)
  * Hide xterm, uxterm, and imagemagick from applications overview
    (LP: #129041)
 -- Tim Lunn <email address hidden> Thu, 04 Oct 2012 07:44:18 +1000

Changed in ubuntu-gnome-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Changed in xterm (Debian):
status: Unknown → New
Thomas Hotz (thotz) wrote :

I think the current icons in xterm and xdiagnose don't fit into the system beacause the other apps have really cool icons.

Changed in ayatana-design:
status: New → Invalid
Thomas Dickey (dickey-his) wrote :

The bug is already marked as fixed, no need to add abusive comments.

Jeremy Bicha (jbicha) wrote :

Thomas Dickey, this bug is "fixed" for Ubuntu GNOME Remix & Xubuntu, not the flagship Ubuntu image.

Thomas Hotz, I *do* want the Design Team's opinion on this bug.

Changed in ayatana-design:
status: Invalid → New
Thomas Dickey (dickey-his) wrote :

The decision was already made. However, the current icons for xterm haven't been discussed.
The only comments have been made based on the pre-SVG icons (and Bicha's comments about
the website got half of the information incorrect - at a minimum he should have based his
comments on the source and timeline). See

    http://invisible-island.net/xterm/xterm.icon.html

If there's any constructive comments to be made, that also might be interesting.

Thomas Dickey (dickey-his) wrote :

For example, this is what I see with xterm on Ubuntu - the old icon and new.

Everaldo Canuto (ecanuto) wrote :

Three terminal icons is too much, Ubuntu ships with only one tool per task. Also, the new xterm icon still ugly, I know that it is subjective but asking about this icons to 9 people around me (3 developers) I got this:

 * 9 in 9 think that it is *very* ugly (both, new and old)
 * 8 in 9 ask why three icons for same task
 * 4 in 9 ask why have any terminal by default :-)
 * 9 in 9 prefer the look of "Terminal" (gnome-terminal) because it looks like "ubuntu" and not (win95|old)

Thomas Dickey (dickey-his) wrote :

There are 3 icons for Libreoffice on that screenshot.
Each application (xterm, xterm-dev) gets exactly one icon.
You won't be installed xterm-dev; the screenshot merely shows things side-by-side.
The last comment is odd, since the color scheme of the "Terminal" icon isn't like the other icons.
(I don't see any hint that you're associated with the "design team").

Thomas Dickey (dickey-his) wrote :

By the way - "asking about this", etc., only indicates that you can find people to agree with you.
That inevitably introduces a bias into the results, and makes it not useful for this discussion.

Everaldo Canuto (ecanuto) wrote :

So, 9 in 9 people agree with me plus some people here plus lots of people that I meet and also have same opnion before I ask anything but we still need to make this ugly icons available because your opnion is more important.

Thomas, don't take me as bad but looks like nothing will convince you. If the argument that icon is ugly is not enought for you please see that ubuntu shows just one application per task and gnome-terminal is the current option.

Thomas Dickey (dickey-his) wrote :

hi - I should not have to explain "constructive" to you, since you presumably have agreed to the Ubuntu guidelines.
However, I've found a poor correlation between the guidelines and practice.

"Constructive" means that you (a) focus on the actual issues, and (b) make suggestions for improvement.
It differs from "subjective comments". A knowledgeable designer won't make subjective comments,
but will point to specific features which can be modified.

The issue which opened this bug has been addressed.

Based on Bicha's comment above, he wants some (unspecified) review by the design team.
If they have constructive comments, I'll note those of course.
However, I'll also (of course) weight the less constructive comments according to the inconsistencies
which are easy to comment on but would be a distraction.

Thomas Hotz (thotz) wrote :

Thank you Jeremy let the design team look at the bug.

My comment wasn't ment to hurt somebody but the original reporter says (1) we only need one terminal and (2) the icons are quite old and it would be nice to have icons that fit better in the Unity shell.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.