Both right and left clicking on any item in the dash that is not an installed app should open a preview

Bug #1209237 reported by John Lea on 2013-08-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
High
Unassigned
7.1
Won't Fix
Medium
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Both right and left clicking on any item in the dash that is not an installed app should open a preview.

This means that for anything that is not an app, users will always have to view the preview before they open an item.

This behaviour should be default for 13.10, but should also be easy to switch off via a dconf key for the purposes of user testing.

Tags: udp Edit Tag help
John Lea (johnlea) on 2013-08-07
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity:
status: New → Fix Released
Changed in ayatana-design:
status: New → Fix Committed
Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: udp
Stephen M. Webb (bregma) on 2013-08-07
Changed in unity:
milestone: none → 7.1.2
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Stephen M. Webb (bregma) wrote :

Remaining part of this bug is to provide a dconf key to switch it off by default (ie. enable left-click to just perform the "default" action for the Dash item).

Changed in unity:
milestone: 7.1.2 → none
milestone: none → 7.1.2
John Lea (johnlea) wrote :

@bregma; yes, default action is that both left and right click for all items that are not installed apps always opens a preview. But if the dconf key is flipped left click should directly open all items, and right click should always opens a preview.

Stephen M. Webb (bregma) on 2013-10-10
Changed in unity:
milestone: 7.1.2 → 7.2.0
Tim Fisken (tim2) wrote :

"This means that for anything that is not an app, users will always have to view the preview before they open an item."

This is surely not desirable behavior. First, because opening the item itself, rather than viewing the preview is more frequently going to be what the user wants to do, and secondly because it makes the behavior vary in a non-obvious way between installed app icons and the other icons.

Stephen M. Webb (bregma) on 2014-04-15
Changed in unity:
milestone: 7.2.0 → 7.2.1
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Changed in unity:
milestone: 7.2.2 → 7.2.3
Changed in unity:
milestone: 7.2.3 → 7.3.1
Andrea Azzarone (azzar1) on 2014-12-05
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Triaged → Fix Released
no longer affects: unity/7.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers