New shutdown Dialogs, shutdown/restart should change order.

Reported by Dietmar Wolf on 2013-03-13
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Marco Trevisan (Treviño)
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

When I choose shutdown at then menu top-right (because I want to shutdown) my mouse pointer is initially at the right top corner of the screen.

When the new dialog opens, shutdown is at the left of the popup window.

So I have to move my mouse over "restart" to get to shutdown.

I would suggest to move shutdown (that what I wanted to do) to the right and restart (it is just an option) to the left.

Then it would be consistent with the Logout popup window, too.

See attached png. Thank you.

Related branches

lp:~3v1n0/unity/session-shutdown-buttons-reorder
Merged into lp:unity at revision 3233
PS Jenkins bot: Approve (continuous-integration) on 2013-03-19
Andrea Azzarone: Approve on 2013-03-19
John Lea (johnlea) wrote :

@Dietmar; thanks for your bug report, I can understand and appreciate your reasoning. However this change conflicts with the order of the options in the shutdown dialogue that is presented when a user presses the power button, and it would be weird for the Shutdown and Suspend options to be the opposite way around in each of these dialogues, they need to be consistent. For this reason we won't be making the change you have requested, but thanks for taking the time to report this bug ;-)

Changed in unity:
status: New → Won't Fix

@john; thank you. your answer doesnt convince me at all. First, after pressing the power button, at the original popup window which existed before, the shutdown button was at the right! You changed that for some reason which I dont understand.
Second, I (I suppose most user) do myself press the power button very rarely at the PC. Wouldnt it be logical to design the most used shutdown dialog first and after that design the power button dialog accordingly? kind regards, dietmar

Deitmar, I see your point... But it seems that moving the shutdown button to the right doesn't get the wanted design.
FYI, this is the result we get moving both to the right:

- Full mode: http://i.imgur.com/jgoo5nB.png
- Standard mode: http://i.imgur.com/10RERBC.png

John, what do you think?

John Lea (johnlea) wrote :

@Treviño; +1 for changing the master order to:

(from left to right)

1. lock
2. suspend
3. hibernate
4. restart
5. shutdown

This works because the order is going from the lightest to the heaviest action. If we follow this order then the small version of this dialogue will be in the order requested by Dietmar as well as the order being consistent in the different shutdown dialogues.

Changed in ayatana-design:
status: New → Fix Committed
Changed in unity:
status: Won't Fix → Triaged
tags: added: indicator-session-new-dialogs
Changed in unity:
status: Triaged → In Progress
importance: Undecided → Medium
Changed in ayatana-design:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.03.20-0ubuntu1

---------------
unity (6.12.0daily13.03.20-0ubuntu1) raring; urgency=low

  [ Stephen M. Webb ]
  * ‘No Image Available’ in previews isn’t translatable (LP: #1106849)

  [ Brandon Schaefer ]
  * Unity unit tests take too long to finish (LP: #1053163)
  * Unity FTBFS xgettext unicode TrashLauncherIcon.cpp:91 (LP: #1156931)
  * HUD's item which is being mouse-hovered is selected, making fast
    typing and clicking Enter unsafe (LP: #1066442)

  [ Marco Trevisan (Treviño) ]
  * Icons edges are not visible on the 13.04 unity launcher (LP:
    #1156698)
  * Clicking on a device (volume) icon doesn't always bring nautilus to
    focus (LP: #1154792)
  * [Regression] No "filter result" label in the dash. (LP: #1155550)
  * Launcher icon edges become invisible when loading an application
    (LP: #1157303)
  * [regression] Tooltip label is not centered (LP: #1155553)
  * Clicking on trash icon doesn't always bring nautilus to focus (LP:
    #1154862)
  * Shutdown dialogue should close the overlays when activated from
    power button (LP: #1155610)
  * New shutdown Dialogs, shutdown/restart should change order. (LP:
    #1154578)
  * Shut Down dialog spells "Shut Down" incorrectly (LP: #1156641)
  * New shutdown dialog had no default option selected (LP: #1155562)
  * alt-tab - the 'pips' the indicate a application has multiple windows
    open look pixelated (LP: #863331)
  * Log Out dialog spells "Log Out" incorrectly (LP: #1156638)
  * Launching an application from the "Appname" quicklist could not
    bring it to focus (LP: #1155225)

  [ Mathieu Trudel-Lapierre ]
  * gcalctool desktop file got renamed (LP: #1156810)

  [ Chris Townsend ]
  * Launcher - auto-scroll needs to be more progressive (LP: #765732)

  [ Andrea Azzarone ]
  * Tooltip timeout should not be resetted on each mouse movement. (LP:
    #1155659)
  * The sharp white line between dash and launcher is missing (LP:
    #1125346)
  * Reduce launcher tooltip timeout. (LP: #1155665)
  * Launcher tooltips need fade animation on show/hide. (LP: #1155672)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3239
 -- Ubuntu daily release <email address hidden> Wed, 20 Mar 2013 04:03:16 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers