[UIFe] Window list in right click context menu should indicate the focused window

Reported by Tigran Gabrielyan on 2013-03-08
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Tigran Gabrielyan
unity (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu 13.04

When we right click on a launcher's icon which has 2 or more windows open, we now have a list of open windows we may switch focus to.

If the current focused window is in this list, it should be highlighted already. Some apps have the same name in the title bar and it is sometimes hard to tell which item in the list is the other window you are trying to give focus to.

Example:

2 Chrome windows open, call it Window A and Window B.
Window B has focus.
Right click on chrome's launcher.

Current behavior:
    Window A
    Window B

What it should be:
    Window A
  * Window B

* = radio state checked

Ubuntu-doc list: https://lists.ubuntu.com/archives/ubuntu-doc/2013-March/017153.html

Related branches

lp:~tigrangab/unity/unity-fix-1152477
Merged into lp:unity at revision 3281
PS Jenkins bot: Approve (continuous-integration) on 2013-04-05
Marco Trevisan (Treviño): Approve on 2013-04-05
Andrea Azzarone: Approve on 2013-03-28
tags: added: raring
description: updated
summary: - Right click context menu on launcher icons window list should highlight
- the current focused window
+ Window list in right click context menu should show active/focused
+ window
description: updated
summary: - Window list in right click context menu should show active/focused
+ Window list in right click context menu should indicate the focused
window
Changed in unity (Ubuntu):
assignee: nobody → Tigran Gabrielyan (tigrangab)
status: New → In Progress

Patch added: http://bazaar.launchpad.net/~tigrangab/unity/unity-fix-1152477/revision/3203

See attachment
-------------------------
Firefox_launchpad_open.png: Firefox window with launchpad.net opened and is the focused window, so that item has the radio checked state
Firefox_google_open.png: Firefox window with google.com opened and is the focused window, so that itemhas the radio checked state
Firefox_nautilus_open.png: Nautilis is focused so no firefox window entry has radio checked state

Changed in unity:
status: New → Incomplete
tags: added: needs-design
Adolfo Jayme (fitoschido) wrote :

I agree with this request, I think it's sensible and makes sense. Also, thanks for creating a patch and screenshots, Tigran! Kudos!

John Lea (johnlea) on 2013-03-19
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in ayatana-design:
status: New → Fix Committed
Changed in unity:
status: Incomplete → Triaged
tags: added: udp
removed: needs-design
John Lea (johnlea) wrote :

@tigrangab; thanks for both the good suggestion, clear description, screenshots and a patch that implements the change ;-) Submitting all these together makes it really easy to review and approve the change, thanks again!

+1 from design

(I wish more bug reports were like this one, this is a textbook example of how to submit a change request ;-)

Tigran Gabrielyan (tigrangab) wrote :

@johnlea No problem :)

I just wanted to confirm that you gave the approval for radio button option.

John Lea (johnlea) wrote :

@tigrangab; yes, radio option approved ;-)

For clarity, screenshots attached to comment #1 are good, approved by design.

summary: - Window list in right click context menu should indicate the focused
- window
+ [FFe] Window list in right click context menu should indicate the
+ focused window
Changed in unity:
status: Triaged → In Progress
assignee: nobody → Tigran Gabrielyan (tigrangab)
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: In Progress → New
assignee: Tigran Gabrielyan (tigrangab) → nobody
summary: - [FFe] Window list in right click context menu should indicate the
+ [UIFe] Window list in right click context menu should indicate the
focused window
Tigran Gabrielyan (tigrangab) wrote :

I'm waiting for mod approval so I can post the links here.

Benjamin Kerensa (bkerensa) wrote :

I think the impact on documentation will be minimal if any.

+1 from Doc Team

description: updated
description: updated
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Steve Langasek (vorlon) wrote :

This is very low-impact for the docs team since it only affects a context menu, which is almost never included in screenshots; approved the UIFe.

Changed in unity (Ubuntu):
status: New → Triaged
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.04.08-0ubuntu1

---------------
unity (7.0.0daily13.04.08-0ubuntu1) raring; urgency=low

  [ Tigran Gabrielyan ]
  * [UIFe] Window list in right click context menu should indicate the
    focused window (LP: #1152477)

  [ Andrea Azzarone ]
  * Launcher - When a app is automatically placed in the Launcher after
    being installed from the Software Center, it should be in the 'non-
    running' state (LP: #987727)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3283
 -- Ubuntu daily release <email address hidden> Mon, 08 Apr 2013 04:02:51 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix released in Unity 7.1.0.

Changed in unity:
milestone: 7.0.1 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers