Dash home application icon is different from app-lens icon

Bug #1149495 reported by AliNâ on 2013-03-06
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity Asset Pool
Low
Unassigned
Trusty
Low
Unassigned
unity-asset-pool (Ubuntu)
Low
Andrea Azzarone
Nominated for Trusty by Stephen M. Webb

Bug Description

In Ubuntu 13.04 daily builds, application icon in "dash home" which shows recently used applications is the old app icon while app-lens icon is updated to a new one, an A with a progressbar (see the screenshot attached).
The home application icon should be the same.

-------------------------
Desired resolution:

- The icon should be the "A" version in both places

Related branches

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in unity.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

tags: added: raring
affects: ubuntu → unity (Ubuntu)
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in ayatana-design:
status: New → Confirmed
status: Confirmed → New
Adolfo Jayme (fitojb) wrote :

Oh, indeed, never noticed that! Seems that the home lens just needs to update that leftover icon. Thanks for reporting this!

lenooh (lenooh) wrote :

Other icons should also be checked (files, music, ...), maybe they need updating as well.

lenooh (lenooh) wrote :

The bug is still present in 14.04 (daily build 2014-02-24).

Adolfo Jayme (fitojb) on 2014-02-25
tags: added: bitesize trusty
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
affects: ayatana-design → unity
AliNâ (alinajafi) wrote :

Yes. But the workaround is very simple. You just need to replace the “group-apps” SVG with the “lens-nav-app”. For example, on 13.04 Raring you can enter the command:

sudo cp /usr/share/unity/6/lens-nav-app.svg /usr/share/icons/unity-icon-theme/places/svg/group-apps.svg

After a re-login it will be corrected.

For other releases you need to find the correct path to the files to make sure.

Andrea Azzarone (azzar1) on 2014-12-16
Changed in unity:
status: New → Opinion
Changed in unity (Ubuntu):
status: Triaged → Opinion
lenooh (lenooh) wrote :

The bug is still present in 14.10.
Why was this marked as "opinion"? When the dash icons were updated in 13.04, this one was obviously overseen.
As Ali Najafi wrote, the fix seems to be simple.

Andrea Azzarone (azzar1) wrote :

Ok. We need design feedback.

Changed in unity:
status: Opinion → Incomplete
Changed in unity (Ubuntu):
status: Opinion → Incomplete
tags: added: needs-design
John Lea (johnlea) on 2014-12-17
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Andrea Azzarone (azzar1) on 2014-12-17
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
importance: Undecided → Medium
importance: Medium → Low
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 7.3.1
John Lea (johnlea) wrote :

Description updated

Andrea Azzarone (azzar1) on 2014-12-17
Changed in unity-asset-pool:
status: New → In Progress
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity-asset-pool:
importance: Undecided → Low
Changed in unity-asset-pool (Ubuntu):
status: New → In Progress
Changed in unity-asset-pool:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity-asset-pool (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2014-12-17
tags: removed: needs-design
Changed in unity:
milestone: 7.3.1 → none
no longer affects: unity
Changed in unity (Ubuntu):
status: In Progress → Invalid
Stephen M. Webb (bregma) on 2014-12-17
Changed in unity-asset-pool:
milestone: none → 0.8.25
Changed in unity-asset-pool (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-asset-pool - 0.8.24+15.04.20141217-0ubuntu1

---------------
unity-asset-pool (0.8.24+15.04.20141217-0ubuntu1) vivid; urgency=low

  [ Andrea Azzarone ]
  * Update group-apps.svg (LP: #1149495)
 -- Ubuntu daily release <email address hidden> Wed, 17 Dec 2014 23:33:57 +0000

Changed in unity-asset-pool (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2014-12-18
Changed in unity-asset-pool:
status: In Progress → Fix Committed
Adolfo Jayme (fitojb) on 2014-12-18
no longer affects: unity (Ubuntu)
Andrea Azzarone (azzar1) on 2017-10-13
Changed in unity-asset-pool:
assignee: Andrea Azzarone (azzar1) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers