[regression] Clicking on the indicators when the Dash is open no longer closes the Dash.

Reported by Brandon Schaefer on 2013-01-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Brandon Schaefer
unity (Ubuntu)
Undecided
Brandon Schaefer

Bug Description

To Reproduce:
1) Open the Dash
2) Click on any indicator

Result:
  Nothing (The dash stays open).

Expected:
  The dash should close.
  The indicator which was clicked on should open.

Tags: udp Edit Tag help

Related branches

lp:~brandontschaefer/unity/lp.1109150-fix-dash-indicators
Merged into lp:unity at revision 3090
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-01-30
Andrea Azzarone: Approve on 2013-01-30
MC Return (community): Approve on 2013-01-30
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: New → In Progress
importance: Undecided → Medium
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: New → In Progress
assignee: nobody → Brandon Schaefer (brandontschaefer)
John Lea (johnlea) on 2013-01-30
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
description: updated
Changed in ayatana-design:
importance: Undecided → Medium
status: New → Fix Committed
tags: added: udp
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.02.04.1-0ubuntu1

---------------
unity (6.12.0daily13.02.04.1-0ubuntu1) raring; urgency=low

  * debian/control:
    - recommends indicator-sync so it gets installed by default
      (lp: #1053482)
    - recommends indicator-bluetooth as well (lp: #1111314)

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - bump compiz build-dep due to the last ABI break

  [ Brandon Schaefer ]
  * [regression] Clicking on the indicators when the Dash is open no
    longer closes the Dash. (LP: #1109150)
  * [staging][raring] Dash Maximise/Restore button depends on the
    launcher icon size. (LP: #1101310)

  [ Romain Perier ]
  * The Dash closes when trying to switch to the Command lens (Alt+F2)
    (LP: #1019457)

  [ Marco Trevisan (Treviño) ]
  * Launcher can have smaller size on monitor resolution change (LP:
    #1105382)
  * Dragging down a window from the panel on an external monitor,
    restores it at wrong offset (LP: #1104043)
  * [regression] Alt+Tab/Alt+grave brings other window to the front but
    loses focus entirely. (LP: #1111620)
  * Quicklist items need a way to be ellipsized (LP: #1111471)

  [ Charles Kerr <email address hidden>, Andrea Azzarone ]
  * the GObject subclasses in tests/ don't dispose() properly (LP:
    #986875)

  [ Nicolas d'Offay ]
  * Speed up dash blur (LP: #1102410)

  [ Manuel de la Pena ]
  * API changes to FindKeyFocusArea in the Preview class stops more
    complicated previous fom setting the correct focus (LP: #1102387)

  [ MC Return ]
  * Wrong description in Dconf key
    com.canonical.unity.launcher.favorites (LP: #1112560)
  * Keyboard shortcut overlay says Ctrl+Super+Down "minimises" the
    current window, but it doesn't (LP: #966099)

  [ Andrea Azzarone ]
  * unmounting any gvfs-mounted device from unity menu crashes compiz
    (LP: #1111389)
  * compiz crashed with SIGSEGV in async_wrapper_callback() from
    g_simple_async_result_complete() from
    _g_simple_async_result_complete_with_cancellable() from
    unmount_reply() (LP: #1102926)

  [ Łukasz 'sil2100' Zemczak ]
  * SwitcherControllerImpl autopilot test failures in unity -
    6.12.0daily13.01.29.2-0ubuntu1 (LP: #1109192)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3117
 -- Automatic PS uploader <email address hidden> Mon, 04 Feb 2013 09:59:13 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers