Panel should be right-clickable when window is maximised with global menu enabled

Reported by Stéphane Guillou on 2013-01-11
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Compiz
Undecided
Unassigned
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

Currently, it is possible to right click on the name bar of a window to get the drop-down menu allowing the following actions:
- Minimise
- Maximise
- Move
- Resize
- Always on top
- Always on visible workspace
- Only on this workspace
- Move to workspace x
- Move to workspace y
- Move to another workspace > ...
- Close

However, when a window is maximised and the top bar is merged with the panel, allowing the global menu, there is no way to access this menu, except going back to windowed mode, thus adding an extra step to execute an action like moving the window to another workspace.

This is not expected as the panel is already dragable and double-clickable.

WHAT SHOULD HAPPEN:

The top panel's empty space should be right-clickable in order to be able to access those options as easily as in windowed mode.

Another option, not as good as the first one, would be to add another drop-down menu in the global menu, that would appear only when the window is maximised. The advantage would be the ability to use those actions with the HUD; however, adding a "Window" drop-down menu would interfere with apps that already have one, like LibreOffice Writer, and would probably end up being more confusing.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-panel (not installed)
ProcVersionSignature: Ubuntu 3.5.0-22.34-generic 3.5.7.2
Uname: Linux 3.5.0-22-generic i686
ApportVersion: 2.6.1-0ubuntu9
Architecture: i386
Date: Fri Jan 11 14:22:24 2013
InstallationDate: Installed on 2012-10-21 (81 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~3v1n0/unity/decorations-menu
Merged into lp:unity at revision 3659
PS Jenkins bot: Approve (continuous-integration) on 2014-02-14
Christopher Townsend: Approve on 2014-02-14
Sami Jaktholm (sjakthol) on 2013-01-11
affects: gnome-panel (Ubuntu) → unity (Ubuntu)
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
description: updated

@John Lea
I do not agree with the decision of marking this bug as a duplicate of #656519
This bug is targetting the exact opposite of the objective of bug #656519.
I will be commenting in that one too.
Cheers

Changed in compiz:
status: New → Won't Fix
Changed in unity:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
milestone: none → 7.2.0
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :
Download full text (18.5 KiB)

This bug was fixed in the package unity - 7.1.2+14.04.20140214.1-0ubuntu1

---------------
unity (7.1.2+14.04.20140214.1-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * use unity-control-center by default.
  * lists keybinding in unity-control-center. (LP: #1271710)

  [ Brandon Schaefer ]
  * Bump to new libnux from this branch:
    https://code.launchpad.net/~brandontschaefer/nux/xim-preedit-
    support.
  * Adds Super+L to lock the screen, while keeping the older shortcut
    around in g-s-d (Ctrl+Alt+L). (LP: #830709)
  * Do not open the dash/hud on a monitor with a top most window that is
    fullscreen. (LP: #1267210)
  * Implement an EMConveter. This way with default settings such that
    DPI = 96.0f, and font_size = system font size. We can get the
    correct EM value for any pixel size. Once we have the correct EM
    value for any pixel size, the DPI value can be adjusted to the
    current logical one. From here, you can now get the correct pixel
    size based from of the EM value for the logical DPI of the screen.
  * Refactor EMConverter API. Now all thats needed is int
    ConvertPixels(int pixel); This will calculate the correct pixel size
    based on the DPI and font size.
  * Testing that the ibus anthy tests could possibly be causing strange
    issues on the nvidia machine. So skipping them to test if tihs is
    the source of the error.
  * Add Pt to Px function to em converter.
  * Move EMConverter over to unity settings.
  * Add multi monitor support for EMConverter in unity settings. Now you
    can grab a specific converter per monitor.
  * Simple RawPixel class. It adds 2 define literals, ex: 10_em,
    10.0_em. From there it turns them into raw pixels. RawPixels have CP
    (CovertPixel) function which takes in an EMConverter that allows you
    to use a converter specific to a monitor to convert the raw pixel to
    the correct value.

  [ Marco Trevisan (Treviño) ]
  * Don't re-present all of our windows on every frame. Only do that if
    damage intersects it. Use the new APIs exposed by compiz and nux to
    intelligently determine which windows need to be presented per-frame
    and only register damage for those windows. This fixes two things:
    1. BaseWindows being redrawn from scratch every time damage was
    registered over them. That was incorrect and should only be done in
    the case of background blurs. 2. BaseWindows being drawn to the
    screen on every frame, regardless of whether or not they needed to
    be. Now they will only be drawn if some damage intersects beneath
    them. Note that unity will expand the damage region to accomadate
    the base window since nux does not support geometry clipping. So if
    there is a partial intersection of the launcher for example, the
    area of the screen which contains the launcher will be re-painted
    (but the launcher itself won't be redrawn, just its texture) (LP:
    #1080947). (LP: #1080947)
  * Convert compiz regions / rects to nux::Geometry's and back easily.
  * UnityScreen: remove the useless and expensive gl{Push,Pop}Attrib
    calls For some reasons this code was copied by the opengl plugin as
    a workaround to fix the s...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.2.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers