Update the default wallpaper in 13.04

Reported by John Lea on 2012-11-21
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
ubuntu-wallpapers (Ubuntu)
Undecided
Didier Roche

Bug Description

We have got the 13.04 wallpaper ready ahead of schedule, so we might as well get it in the distro now ;-)

See attached file "ubuntu_default_13_04.jpg"

------------------------------------

This change is part of a larger set of icon changes, the other bugs that are part of this same change request are:

bug #1081704 (Dash - update the 'App Lens' icon asset in the Dash bottom lens nav bar)
bug #1081702 (Update the default wallpaper in 13.04)
bug #838854 (Workspaces, Launcher - The workspace Launcher icon should change depending on which workspace is currently being utilised)
bug #1081697 (Launcher - Update BFB icon to use a new special asset)
bug #1081687 (Launcher - Update Launcher tile assets)
bug #1081691 (Launcher - Update the icons used for the Software Centre, Nautilus, and Software Updater)

Related branches

lp:~didrocks/ubuntu-wallpapers/raring-wallpaper
Merged into lp:ubuntu-wallpapers at revision 93
PS Jenkins bot: Pending (continuous-integration) requested 2012-12-12
Ubuntu Artwork Packagers: Pending requested 2012-12-12
John Lea (johnlea) on 2012-11-21
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
tags: added: launcherassets udp
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) on 2012-11-21
description: updated
Changed in unity:
status: Triaged → Won't Fix
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in ubuntu-wallpapers (Ubuntu):
status: New → Confirmed
Lain_13 (lain-halfbit) wrote :

Guys, I terribly sorry but I have a question here:

How did you manage to make JPEG compression artifacts and color banding so clearly visible?
It is just downright ugly.

MaTachi (matachi) wrote :

@Lain_13 (lain-halfbit): I'm pretty sure that's intended and not due to compression. The wallpaper in 12.10 has the same grainy filter/effect.

Lain_13 (lain-halfbit) wrote :

First of all it actually is 12.10 wallpaper rotate on 180 degree. Seriously.
It is wrong in 12.10 as well and it is not due to grainy effect. Grainy effect actually supposed to hide color banding and it is not supposed to break image into small squares. That's actually happens when you over-compress image with grainy effect which is clearly bad idea. Grainy images doesn't compress well at all — grainy effect will be heavily damaged... like here.
Is there source image without compression?

It actually very pointless to compress it at all. Image will be unpacked in the memory anyway. Why not to use loseless PNG instead of JPEG?

Daniel van Vugt (vanvugt) wrote :

The issue with all Ubuntu wallpapers being low quality is not new. I logged it as bug 1016824. It would be nice if we could say that bug was fixed with this one but it sounds like we probably can't.

CSRedRat (csredrat) wrote :

More different standart wallpapers ;)

Hans Heintze (hansheintze1) wrote :

The current compression is really noticable and ugly.
Since ubuntu is moving away from the 700Mb iso size restriction i think a lossless PNG would be perfectly acceptable.

It also seems like most of the public currently hates it... perhaps more could be done to make it at least feel *somewhat* original.

no longer affects: unity
John Lea (johnlea) wrote :

Lossless .jpg version of the 13.04 wallpaper is attached. It also contains additional tweaks to remove the banding. Let's use this file if possible to improve the quality.

Didier Roche (didrocks) on 2012-12-12
Changed in ubuntu-wallpapers (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Daniel van Vugt (vanvugt) wrote :

John,

Lossless is a good improvement. But I think even the original uncompressed image is too grainy (which looks like "noise" but technically isn't). That's a problem which has to be addressed by the artist and not in the compression/conversion :(

Keep bug 1016824 in mind...

Daniel van Vugt (vanvugt) wrote :

Here's a nice quick fix:

Gimp > Filters > Blur > Gaussian Blur... >
    Radius = 16
    OK

Done :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-wallpapers - 13.04daily12.12.13.1-0ubuntu1

---------------
ubuntu-wallpapers (13.04daily12.12.13.1-0ubuntu1) raring; urgency=low

  [ Didier Roche ]
  * debian/control, debian/compat, debian/rules:
    - Update Vcs-Bzr, Vcs-Browser and add a notice to uploaders.
    - Sanitize the build-deps order and remove all unsupported transitions
    - transition from cdbs to dh9
  * Move it to split mode
  * Change the versionning
  * Automatic snapshot from revision 90 (bootstrap)
  * Update the default wallpaper in 13.04 (LP: #1081702)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 94
 -- Automatic PS uploader <email address hidden> Thu, 13 Dec 2012 07:23:25 +0000

Changed in ubuntu-wallpapers (Ubuntu):
status: Confirmed → Fix Released
John Lea (johnlea) wrote :

@vanvugt; Hi Daniel, the problem with your solution is that it re-introduces the problem of banding on cheep monitors. The reason the image has noise is because on cheep TN monitors you get terrible banding with gradients like this. We have been through a lot of iterations of different solutions for fixing this problem, and the current image with the noise is the best solution we have found so far. It's an annoying problem, my laptop screen displays a version of the background image without any noise perfectly, but the cheep TN screen that we user for testing shows very unpleasant banding with the same image.

Daniel van Vugt (vanvugt) wrote :

John,

I know what you mean with monitors that only have 6-bits per channel. I'm not sure we should punish people who have good monitors for the sake of making things look better on bad ones though.

Daniel van Vugt (vanvugt) wrote :

Maybe provide two images?... One for real 24-bit displays, and one with built-in dithering for 18-bit displays.

John Lea (johnlea) wrote :

Is there any way of auto-detecting this? Or could we have a white list of the EDIDs of known good high quality monitors, and if the users monitor is not on this list we fall back to version that works on all displays?

no longer affects: unity (Ubuntu)
Aleve Sicofante (sicofante) wrote :

My background is computer graphics. I've been on that industry for about 20 years.

There's no way wallpapers with so much gradients on a limited color range that cover a big screen area at the same time will look good on most screens today. Not only laptops use mainly 6-bit panels. There are also many cheap desktop monitors that do the same. Some dither properly, others don't. But I even question that big screens using 8bit per channel will properly show these gradients too. As a matter of fact, this wallpaper might be used to test an 8bit monitor's quality... ;-)

Until we all have a 10bit per channel workflow (and that won't happen in a long long time) the real solution is letting the artists know the limitations of gradients -especially those on short color ranges using big screen areas- and ask them for a different style of wallpapers. Non-busy wallpapers doesn't mean "very simple gradients with tons of blur". Of course, management at Canonical should be informed about this too, just in case orders to use this wallpaper style come from above.

Daniel van Vugt (vanvugt) wrote :

I don't know if you can get the physical colour depth from the EDID but doubt it.

When I first encountered such a problem it was a Macbook Air 11" with Nvidia graphics. I was shocked, but the good news is that the Nvidia driver does temporal dithering, so it looks nice (once you turn that feature on). Such temporal dithering done in the driver looks much nicer than doing it statically in an image. And of course, this is only the wallpaper. We can't easily fix it for the graphics you see in your application windows.

Changing wallpaper is a trivial workaround, but it does disappoint me that we're degrading the quality feel of the out-of-box experience. Anyway, it's up to design...

P.S. I use this awesome image to test if a display is any good:
http://www.nasa.gov/multimedia/imagegallery/image_feature_347.html
Looking at that gradient it becomes pretty obvious if you have a crumby 6-bit panel.

John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers