Minimize window requires numeric keypad (Ctrl+Alt+KP0)

Reported by Սահակ on 2012-11-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

The default minimize window shortcut in 12.10 is Ctrl+Alt+KP0. We should have eliminated all keypad combos I thought?

See also: bug 966099 (which is _different_ to this one)

ORIGINAL DESCRIPTION:
according to default keyboard shortcuts (see attachment), the default keyboard shortcut for minimizing a window is Ctrl+Alt+0

However that shortcut does not minimize windows.

This is a 64 bit stock installation of Ubuntu 12.10

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: compiz 1:0.9.8.4-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Sat Nov 3 23:28:22 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c0cd]
MachineType: SAMSUNG ELECTRONICS CO., LTD. 900X3B/900X4B
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=90BCD2D0BCD2AFC8 loop=/hostname/disks/root.disk ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/16/2012
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: P08AAH
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 900X3B/900X4B
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: FAB1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrP08AAH:bd09/16/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn900X3B/900X4B:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rn900X3B/900X4B:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
dmi.product.name: 900X3B/900X4B
dmi.product.version: 0.1
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
version.compiz: compiz 1:0.9.8.4-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Սահակ (petrosyan) wrote :
RaduStoica (radumstoica) wrote :

Hello,

  Thank you for taking the time to report this. The actual problem is that you have to use the keys from the numeric keypad instead of the normal number keys. You can change this manually, to use the key on the character pad, but it again stops working after a restart. If I remember correctly, this is a bug with all default shortcuts.

Սահակ (petrosyan) wrote :

Interesting. I don't have a numeric keypad on my laptop. Does this mean I can't use the default shortcut to minimize windows?

Daniel van Vugt (vanvugt) wrote :

Yes, according to the CCSM settings it's actually Ctrl+Alt+KP0 so you need a keypad. And it does work.

This is a bug in itself because design /thought/ they had eliminated all shortcuts that use the keypad, but obviously not. See bug 966099.

Changed in compiz (Ubuntu):
status: New → Invalid
Daniel van Vugt (vanvugt) wrote :

Invalid for upstream Compiz. We use Alt+F9 there.

This bug only applies to Ubuntu Compiz.

summary: - default keyboard shortcut for minimizing windows (Ctrl+Alt+0) does not
- work
+ Minimize window requires numeric keypad (Ctrl+Alt+KP0)
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
description: updated
affects: gnome-control-center → compiz
Changed in compiz:
status: New → Invalid
Սահակ (petrosyan) wrote :

this bug is still present in Ubuntu 13.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers