Alt-Tab - alt+grave (key above tab) takes you back to where you started, not to the next window

Reported by Alan Bell on 2012-10-03
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
High
Brandon Schaefer
6.0
High
Brandon Schaefer
unity (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

= Impact =

Clearly visible for alt+grave users, see original description.

= Test case =

See original description, press alt+grave two times and you should _not_ be back to the original window when you have 3 or more windows open.

= Regression potential =

Low, test that the functionality otherwise continues to work.

----

open up 3 or more terminal windows or any other application, focus on one of them and press alt+grave (key above tab).

The first time you press the 'grave' key the previous window that was focused of the same application will become focused. This is correct.

Press the 'grave' key a second time and the focus will switch back to the first window. This is incorrect.

The correct behaver is for the 3rd window of the same application in recency of use order to become focused, basically exactly the same as ALT-TAB, but switching windows rather than applicaitons.

To fix this bug we want the following:

-----------------
Window order, where 1 is the current focused window:
1,2,3,4,5,6

Pressing Alt+` (e.g. tapping ` once)
This action ends with the windows in the following order:
2,1,3,4,5,6

-----------------

Window order, where 1 is the current focused window:
1,2,3,4,5,6

Pressing Alt+`+` (e.g. tapping ` twice)
The action ends with the windows in the following order:

3,1,2,4,5,6

-----------------

Related branches

lp:~brandontschaefer/unity/alt-grave-ordering-fix
Merged into lp:unity at revision 2827
Marco Trevisan (Treviño): Approve on 2012-10-10
Thomi Richards: Approve (quality) on 2012-10-09
jenkins: Pending (continuous-integration) requested 2012-10-11
Alan Bell (alanbell) wrote :
Omer Akram (om26er) on 2012-10-04
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Omer Akram (om26er) wrote :

needs design discussion

Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → nobody
importance: Low → Undecided
Changed in unity (Ubuntu):
importance: Low → Undecided
Changed in unity:
status: Triaged → New
status: New → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete
John Lea (johnlea) on 2012-10-09
summary: - alt backtick backtick takes you back to where you started
+ Alt-Tab - alt+backtick (grave) takes you back to where you started, not
+ to the next window
John Lea (johnlea) on 2012-10-09
description: updated
summary: - Alt-Tab - alt+backtick (grave) takes you back to where you started, not
- to the next window
+ Alt-Tab - alt+grave (key above tab) takes you back to where you started,
+ not to the next window
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udp
Changed in ayatana-design:
importance: Undecided → Critical
Changed in unity:
importance: Undecided → Critical
Changed in ayatana-design:
status: New → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Critical
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Triaged → In Progress
Changed in unity:
milestone: none → 7.0.0

So with this change:

Window order, where 1 is the current focused window:
1,2,3,4,5,6

Pressing Alt+`

Current result order:
2,1,3,4,5,6

Desired result order:
2,3,4,5,6,1

John Lea (johnlea) wrote :

@brandontschaefer;

Not exactly. To fix this bug we want the following:

-----------------
Window order, where 1 is the current focused window:
1,2,3,4,5,6

Pressing Alt+` (e.g. tapping ` once)
This action ends with the windows in the following order:
2,1,3,4,5,6

-----------------

Window order, where 1 is the current focused window:
1,2,3,4,5,6

Pressing Alt+`+` (e.g. tapping ` twice)
The action ends with the windows in the following order:

3,1,2,4,5,6

-----------------

Basically exactly the same as ALT-TAB, but switching windows rather than applicaitons.

description: updated

I think we are talking about different ordering :). I was talking about the order of the windows in the detail mode, if you press and hold alt+`. It seems you are talking about the window stack order which I am not touching, it still behaves as it should.

I was just mentioning that when you opened up the switcher in detail mode the currently active window will be at the end, because I don't see how it can be the second choice yet have the third window activate when you hit it twice.

So if you press and hold Alt+` once, the order of the windows in detail mode has to be:
2,3,4,5,6,1

If it was:
2,1,3,4,5,6

Pressing Alt+` grave twice would give you window 1 which is what this bug is all about....

With my changes you would get window 3, which would still preserve the window stack, ie it just raises the selected window to the top and focuses it. Leaving the currently selected window as the last active window.

I think I mis worded my previous statement, my branch does what you want :)

John Lea (johnlea) wrote :

@brandontschaefer; yes I did think you were talking about window stack ordering ;-) Your proposal now sounds good.

Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-10-11
Changed in unity:
importance: Critical → High
Changed in unity (Ubuntu):
importance: Critical → High
Changed in unity (Ubuntu):
status: Triaged → In Progress
description: updated
Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
Sebastián Mancilla (smancill) wrote :

@brandontschaefer:

You wrote: "I was just mentioning that when you opened up the switcher in detail mode the currently active window will be at the end, because I don't see how it can be the second choice yet have the third window activate when you hit it twice."

You should put the current focused window in the first position, just like the Alt+Tab dialog does with the current focused application. The focus should be in the second window, just like the Alt+Tab dialog.

So if you press and hold Alt+` once, the order of the presented windows in "detail mode" has to be:
1,2,3,4,5,6

and 2 should have the focus (this is what Alt+Tab does with applications)

Pressing the grave key a second time (while holding Alt) should move the focus to 3 (without changing the order in the detailed view).

Then I do some work in window 3, and I decide to switch windows again. Pressing and holding Alt+` should present this order:

3,1,2,4,5,6

with the focus in 1.

@Sebastian

I really like that idea, it also is a lot more efficient :).

I filed a bug here, as it needs design review:
https://bugs.launchpad.net/ayatana-design/+bug/1067879

Sebastián Mancilla (smancill) wrote :

Are you going to port the solution of this bug to 12.04?

Hello Alan, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Alan Bell (alanbell) on 2012-10-26
tags: added: verification-done
removed: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Alan, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Still fixed in ubuntu2.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu2

---------------
unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 18:00:00 +0100

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu3

---------------
unity (6.10.0-0ubuntu3) raring; urgency=low

  * Upload to raring

unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Didier Roche <email address hidden> Fri, 09 Nov 2012 08:06:47 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Sebastián Mancilla (smancill) wrote :

Hi, guys,

I am sorry for comment in this closed bug, but:

* Why are you not solving this for 12.04.2? Do I need to open another bug for it? How can this bug being marked as high but it is not even considered for Precise, which will be around for more than 4 years. And yes, this bug is totally present in Unity 5.18.0-ubuntu2.

* Why nobody is taking care of https://bugs.launchpad.net/ayatana-design/+bug/1067879, which is an improvement over the currently accepted solution.

Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers