Dash - When the Dash preview opens, the category headers should be expanded and the filters should hide

Reported by John Lea on 2012-10-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Nick Dedekind
unity (Ubuntu)
High
Nick Dedekind

Bug Description

When the preview opens, the ghost images should reflow so that if the category header is collapsed it becomes expanded, and if the ‘filter results’ is closed it is opened.

Also see bug #1060941

Related branches

lp:~nick-dedekind/unity/dash.animations-view.redirection
Merged into lp:unity at revision 2983
Brandon Schaefer: Approve on 2012-12-13
PS Jenkins bot: Pending (continuous-integration) requested 2012-12-13
lp:~nick-dedekind/unity/dash.animations-overlay.renderer
Merged into lp:unity at revision 2986
Brandon Schaefer: Approve on 2012-12-14
Marco Trevisan (Treviño): Approve on 2012-12-14
PS Jenkins bot: Pending (continuous-integration) requested 2012-12-14
lp:~nick-dedekind/unity/dash.animations-animations
Merged into lp:unity at revision 2996
Brandon Schaefer: Approve on 2012-12-17
PS Jenkins bot: Pending (continuous-integration) requested 2012-12-17
John Lea (johnlea) on 2012-10-03
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Triaged
tags: added: dashm udp
Changed in unity (Ubuntu):
status: New → Triaged
Changed in ayatana-design:
status: New → Fix Committed
John Lea (johnlea) on 2012-10-03
description: updated
Stephen M. Webb (bregma) on 2012-11-26
Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity:
status: Triaged → In Progress
Stephen M. Webb (bregma) on 2012-12-05
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
milestone: none → 7.0.0
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package unity - 6.12.0daily13.01.11.2-0ubuntu1

---------------
unity (6.12.0daily13.01.11.2-0ubuntu1) raring; urgency=low

  [ Didier Roche ]
  * debian/control:
    - bump some missed build-deps
    - bump compiz and nux build-deps for the API and ABI breakages
      (LP: #1095981)
  * debian/rules:
    - disable pch for now as it's not working with -g -02 (LP: #1095978)

  [ Brandon Schaefer ]
  * Ported Compiz to 0.9.9
  * debian/control:
    - bump the build-deps
  * Dash and HUD do not have X event focus, causing XIM to not work.
    (LP: #1086988)
  * Windows losing focus after the start/restart of Unity (LP: #1097368)

  [ Łukasz 'sil2100' Zemczak ]
  * Dash - Update Dash nav bar icons (LP: #1089373)
  * Autopilot tests failing in the test_hud suite due to locale
    dependency (LP: #1076531)
  * Super key not registered if held too long (LP: #1097189)
  * Unity HUD uses wrong icon when switching from the Dash to HUD (LP:
    #1089482)

  [ Marco Trevisan (Treviño) ]
  * Using bleeding edge Mesa drivers causes GL_INVALID_OPERATION error
    in glDrawBuffer / glReadBuffer (LP: #1092550)
  * [Regression] Window buttons / Title doesn't redraw correctly on
    windows with no menus (LP: #1090439)

  [ Nick Dedekind ]
  * Dash - When the Dash preview is open, the ghost images should run
    all the way to the top of the screen as shown in the design (LP:
    #1060948)
  * Dash - When the Dash preview opens, the category headers should be
    expanded and the filters should hide (LP: #1060937)
  * Dash - In the Dash preview, when a user moves to the next or
    previous preview the highlighted ghost image should change (LP:
    #1060941)
  * Dash - As soon as a user starts dragging a .png file from the Dash,
    the file icon changes size (LP: #863412)

  [ Gord Allott <email address hidden>, Łukasz 'sil2100' Zemczak <email address hidden>, Didier Roche ]
  * "unitydashlegalseen" Causing back-up error (LP: #1066646)
  * unity dash should show legal disclaimer (LP: #1065652)

  [ Manuel de la Pena ]
  * StaticCairoText makes NUX get into an infinte loop (LP: #1071327)

  [ Daniel van Vugt ]
  * Minimized windows don't restore, or restore as blank (LP: #1089779)

  [ Andrea Azzarone ]
  * TestOverlayScrollBar.TestScrollDownSignal segfaults (LP: #1089888)
  * Dash - Update Dash Launcher icon tooltip to say "Search your
    computer and online sources" (LP: #1090325)
  * TestLauncherController.GetLastIconPriorityUnStickyWithNoIconsAndUri
    segfaults (LP: #1089894)
  * TestDashController.TestShowAndHideDash fails (LP: #1089904)
  * [Regression] Tapping super key shows shortcuts overlay. (LP:
    #1090388)
  * [Regression] Unity fails to restore initially minimized windows.
    (LP: #1097686)
  * launcher does not show minimized update manager while clicked (LP:
    #1003950)
  * Dash - Update Dash Home search box hint message to say "Search your
    computer and online sources" (LP: #1090327)
  * can't quit a minimized application (LP: #1086366)
  * Unity daily-build (07.01.13) empty space between launcher and dash
    in non default launcher size (LP: #1097184)

  [ Sam Spilsbury ]
  * Fonts get chang...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints