Web app prompt appears on every single page load

Reported by Matthew Paul Thomas on 2012-10-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Christian Giordano
WebApps: Websites integration Firefox plug-in
Undecided
Unassigned
WebApps: unity-chromium-extensions
Undecided
Unassigned
WebApps: unity-firefox-extension
Undecided
Unassigned
unity-chromium-extension (Ubuntu)
Undecided
Unassigned
unity-firefox-extension (Ubuntu)
Undecided
Unassigned
webapps-greasemonkey (Ubuntu)
Undecided
Robert Carr

Bug Description

1. In Firefox, go to a Web site that integrates with Unity's web apps feature.
2. Try to scroll the page with a trackpad or mousewheel.
3. Click a link to another page on the same site.
4. Click the link again.
5. Repeat steps 2~4 a few more times.

What happens:
1. A web app prompt appears.
2. The prompt blocks scrolling with trackpad/mousewheel.
3. The prompt also blocks your first attempt to click something on the page.
5. The prompt reappears on every single page.

This is terrible design. Sometimes Web sites do something like this on the first or second page you visit in a session: putting up an advertisement or an invitation for a survey, that you can click outside to return to the page. But if any site did that on *every* page you visit, nobody would visit that site any more. So this is appropriate behavior only if you don't want any non-Ubuntu Web site to ever adopt the web apps feature.

What should happen: either
* the prompt appears only once per site per Firefox session, or
* the prompt appears only once per site per day.

Tags: udp Edit Tag help
Matthew Paul Thomas (mpt) wrote :
description: updated
description: updated
Christian Giordano (nuthinking) wrote :

Added Chromium since this case wasn't really covered by the design.

Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → High
Christian Giordano (nuthinking) wrote :

I think the prompt should appear only once per site per day (option 2).

John Lea (johnlea) on 2012-10-03
Changed in ayatana-design:
assignee: nobody → Christian Giordano (nuthinking)
tags: added: udp

Once per day seems a bit arbitrary to me, a user might wonder how to make it come back for example, or the user might be surprised that it actually comes back some time after ... On chromium for example, despite the logo, it might be mistaken for one of chromium's usual infobar (e.g. translation, etc.) and overlooked the first time,

Robert Carr (robertcarr) wrote :

Once per day seems potentially frustrating to me as well, in that it's not an easy behaviour for the user to come to understand. I am imagining the following scenario (this kind of thing happens to me frequently):

1. User opens page
2. User sees navigation prompt, but clicks on the page anyway out of habit dismissing the prompt
3. User tries to trigger the prompt appearing again but can't
4. Next day user sees the prompt again and can't understand why.

This would make me uncomfortable as a user.

Will Cooke (willcooke) wrote :

If I had a vote I'd vote for #1 or something similar. Once per browsing session seems a lot more predictable and logical.

Robert Carr (robertcarr) wrote :

Option 1 is implemented here:
https://code.launchpad.net/~robertcarr/webapps-greasemonkey/fix-1060888 can merge with review + design approval.

Option 2 can be implemented fairly easily as well.

Changed in webapps-greasemonkey:
status: New → In Progress
Changed in unity-firefox-extension:
status: New → Invalid
Changed in unity-firefox-extension (Ubuntu):
status: New → Invalid
Christian Giordano (nuthinking) wrote :

Ok, no strong opinions. I was just thinking that sometimes a browser session could last longer. So I would probably go for browser session unless is older than 1 day.

Robert Carr (robertcarr) on 2012-10-05
Changed in webapps-greasemonkey (Ubuntu):
status: New → Fix Committed
assignee: nobody → Robert Carr (robertcarr)
Víctor R. Ruiz (vrruiz) wrote :

omgubuntu.co.uk, which hosts its own user script, is not covered with the greasemonkey patch, so the dialog reappears in every new navigated page.

Ken VanDine (ken-vandine) wrote :

If this needs to be fixed in greasemonkey, I think we have a design flaw. The user experience of sites with native integration should be first class, if we ever want to convince sites to integrate. IMO greasemonkey should be just a bridge to get us over the hump and eventually die.

This feels very much like a design flaw. No site should ask on every page
load, IMO.

On Wed, Oct 10, 2012 at 12:59 AM, Ken VanDine <email address hidden>wrote:

> If this needs to be fixed in greasemonkey, I think we have a design
> flaw. The user experience of sites with native integration should be
> first class, if we ever want to convince sites to integrate. IMO
> greasemonkey should be just a bridge to get us over the hump and
> eventually die.
>
> --
> You received this bug notification because you are a member of WebApps
> Team, which is subscribed to WebApps: unity-chromium-extensions.
> https://bugs.launchpad.net/bugs/1060888
>
> Title:
> Web app prompt appears on every single page load
>
> Status in Ayatana Design:
> Fix Committed
> Status in Chromium extension: Unity Integration:
> New
> Status in Firefox extension: Unity Integration:
> Invalid
> Status in WebApps: Websites integration Firefox plug-in:
> In Progress
> Status in “unity-chromium-extension” package in Ubuntu:
> New
> Status in “unity-firefox-extension” package in Ubuntu:
> Invalid
> Status in “webapps-greasemonkey” package in Ubuntu:
> Fix Committed
>
> Bug description:
> 1. In Firefox, go to a Web site that integrates with Unity's web apps
> feature.
> 2. Try to scroll the page with a trackpad or mousewheel.
> 3. Click a link to another page on the same site.
> 4. Click the link again.
> 5. Repeat steps 2~4 a few more times.
>
> What happens:
> 1. A web app prompt appears.
> 2. The prompt blocks scrolling with trackpad/mousewheel.
> 3. The prompt also blocks your first attempt to click something on the
> page.
> 5. The prompt reappears on every single page.
>
> This is terrible design. Sometimes Web sites do something like this on
> the first or second page you visit in a session: putting up an
> advertisement or an invitation for a survey, that you can click
> outside to return to the page. But if any site did that on *every*
> page you visit, nobody would visit that site any more. So this is
> appropriate behavior only if you don't want any non-Ubuntu Web site to
> ever adopt the web apps feature.
>
> What should happen: either
> * the prompt appears only once per site per Firefox session, or
> * the prompt appears only once per site per day.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/1060888/+subscriptions
>

Changed in webapps-greasemonkey (Ubuntu):
status: Fix Committed → Confirmed
Changed in webapps-greasemonkey:
status: In Progress → Fix Released
Changed in webapps-greasemonkey (Ubuntu):
milestone: none → quantal-updates
Will Cooke (willcooke) wrote :

How to test:

1. Open Firefox.
2. Go to non-accepted site with integration (e.g. launchpad.net).
3. When the integration dialog appears, click on close (X).
4. Reload the page.

Expected result: The browser must not prompt again the integration dialog (if it does, then is not fixed).

Will Cooke (willcooke) wrote :

Regression potential: Very low. Sets a flag

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-chromium-extension (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webapps-greasemonkey - 2.3.5-0ubuntu1

---------------
webapps-greasemonkey (2.3.5-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Webapp prompt appears on every page load (LP: #1060888)
    - Keeps asking to install packages even when responded with
      don't ask (LP: #1061633)
  * -debian/patches/no-shadow-repo.patch, fixed upstream
 -- Ken VanDine <email address hidden> Thu, 11 Oct 2012 11:00:04 -0400

Changed in webapps-greasemonkey (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-chromium-extension:
status: New → Fix Committed
Changed in unity-chromium-extension (Ubuntu):
milestone: none → quantal-updates
Changed in unity-chromium-extension:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-chromium-extension - 2.4.2-0ubuntu1

---------------
unity-chromium-extension (2.4.2-0ubuntu1) quantal-proposed; urgency=low

  * New upstream snapshot.
    - switch to manifest version 2 (version 1 will be deprecated soonish)
    - Web app prompt appears on every single page load (LP: #1060888)
    - Error after package installation (LP: #1065308)
 -- Ken VanDine <email address hidden> Fri, 12 Oct 2012 12:06:04 -0400

Changed in unity-chromium-extension (Ubuntu):
status: Confirmed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers