Improve spread windows's (<super>w) focused window indicator

Reported by Dario Ruellan on 2012-09-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
One Hundred Papercuts
Low
Papercuts Ninjas

Bug Description

Description:
When you spread windows using the <super>w key, the only extra indicator you have to know which window is selected is a faint shadow, and sometimes this is not enough and makes the spread windows option useless as a selector.

Test case:
Open two unmaximized Nautilus windows.
Spread windows using <super>w
The selected window has a faint shadow, but also title bar and buttons look brighter as an indicator that the window has focus, thats good.

Now maximize the two windows and <super>w again.
You now don't have the title bar, but still there is a slight difference between focused and unfocused windows.

Now open two Firefox maximized windows.
You must rely only on the faint shadow to tell which window is focused.

What can be done:
There are currently two stablished indicators to show focused windows. First is the orange glow of the alt+tab or alt+~ selectors. The other is compiz's window fadeout effect. Any of them can help a lot on the situation above.

Gareth (gmccumskey) on 2012-10-24
Changed in hundredpapercuts:
status: New → Confirmed
Chris Wilson (notgary) on 2012-10-24
Changed in hundredpapercuts:
milestone: none → raring-round-3
assignee: nobody → Papercuts Ninja (papercuts-ninja)
importance: Undecided → Low
Dario Ruellan (druellan) wrote :

This seem fixed on 12.10. At least there is a title bar that you can use as indicator for the active window.
I think its safe to mark it as invalid, unless the design team want to revisit the issue.

Dario Ruellan (druellan) wrote :

Update:
The title bar indicator works fine, but still not solves the problem regarding opening two maximized Firefox windows.

Chris Wilson (notgary) on 2012-11-28
Changed in hundredpapercuts:
milestone: none → raring-compiz
Dario Ruellan (druellan) wrote :

The problem regarding two maximized Firefox windows seems solved now. Since I can't find any app having a problem with the proposed solution, I will mark it as solved.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in ayatana-design:
status: New → Invalid
Dario Ruellan (druellan) on 2013-03-10
no longer affects: compiz-core-ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers