[UIFE] Dash - The icon animation that is triggered when the user installs an application from the Dash App Preview is incorrect

Reported by John Lea on 2012-09-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Nick Dedekind
unity (Ubuntu)
High
Nick Dedekind
unity-lens-applications (Ubuntu)
Undecided
Unassigned

Bug Description

Currently when the user installs an app from a Dash App Previews, an animation is triggered whereby the icon travels downwards from the BFB (Dash launcher icon) to it's new location in the Launcher. This is incorrect.

The animation should start at the app icon *inside the preview* (the icon to the top right side of the preview image), and show the icon travelling from this location to it's new position in the launcher (the end position in the current animation is correct).

So when the user clicks 'install', two things should happen simultaneously:
1) The Dash closes
2) The app icon travels from the location it was a moment ago inside the app preview across the screen to it's new location in the Launcher

Related branches

lp:~nick-dedekind/unity/lp1052582.usc-icon-animation
Merged into lp:unity at revision 2825
Brandon Schaefer: Approve on 2012-10-10
jenkins: Pending (continuous-integration) requested 2012-10-10
lp:~nick-dedekind/unity/lp1052582.remove-source-manager
Merged into lp:unity at revision 2845
Marco Trevisan (Treviño): Approve on 2012-10-16
PS Jenkins bot: Pending (continuous-integration) requested 2012-10-16
John Lea (johnlea) on 2012-09-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in ayatana-design:
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in ayatana-design:
status: Triaged → Fix Committed
tags: added: dashm
Changed in unity-lens-applications:
assignee: nobody → Pawel Stolowski (stolowski)
Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
status: Triaged → In Progress
Michal Hruby (mhr3) on 2012-09-24
summary: - Dash - The icon animation that is triggered when the use installs an
+ Dash - The icon animation that is triggered when the user installs an
application from the Dash App Preview is incorrect

@John: this won't look good... The problem is there may be a password popup between 1 & 2, unless you're already authorized.

Omer Akram (om26er) on 2012-09-24
Changed in unity-lens-applications:
status: New → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity-lens-applications (Ubuntu):
status: New → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity-lens-applications (Ubuntu):
assignee: nobody → Pawel Stolowski (stolowski)
Nick Dedekind (nick-dedekind) wrote :

Confirmed. doesn't look great. Icon now just flys from middle of no-where.

Seeing as installation is a async function I don't really think the animation from the preview is valid, otherwise we will need to wait until the signal that the installation is in progress comes in before closing the dash.

Pawel Stolowski (stolowski) wrote :

@Nick: re: "(...) otherwise we will need to wait until the signal that the installation is in progress comes in before closing the dash".

I'm afraid it's not really doable with current framework; there is a su password popup after clicking 'Free download' and Dash needs to hide for it to show; on a side note, password popup is a system-wide solution triggered by apt and we've no control over it.

summary: - Dash - The icon animation that is triggered when the user installs an
- application from the Dash App Preview is incorrect
+ [UIFE] Dash - The icon animation that is triggered when the user
+ installs an application from the Dash App Preview is incorrect
Nick Dedekind (nick-dedekind) wrote :

I've added another branch which removes USC icon animation from invalid screen co-ords (<= 0).
It also pops up tool-tip for 1.5 seconds after installation completes. (requested by design team).

lp:~nick-dedekind/unity/lp1052582.usc-icon-animation

no longer affects: unity-lens-applications
Changed in unity-lens-applications (Ubuntu):
assignee: Pawel Stolowski (stolowski) → nobody
status: In Progress → Invalid
John Lea (johnlea) on 2012-10-03
tags: added: dashs
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-12-11
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers