[regression] Launcher tooltip should not appear when keyboard overlay is shown

Reported by Barneedhar on 2012-08-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Unity
Low
Andrea Azzarone
unity (Ubuntu)
Low
Andrea Azzarone

Bug Description

Steps to reproduce:
----------------
1. Mouseover any item in the launcher so that a tooltip appears
2. Press and hold super key so that the shortcut hint overlay appears
3. Move the mouse away from the launcher

What happens:
The tooltip keeps showing over the launcher icon even though the cursor is far away.

What should happen:
As soon as the mouse leave the launcher icon the tooltip should hide.

<<The same happens if you press and hold super key and mouse over any launcher item>>

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-9.9-generic 3.5.0
Uname: Linux 3.5.0-9-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Sun Aug 12 20:14:59 2012
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
SourcePackage: unity
UpgradeStatus: Upgraded to quantal on 2012-07-10 (33 days ago)

Related branches

lp:~andyrock/unity/fix-1035860
Merged into lp:unity at revision 2874
PS Jenkins bot: Needs Fixing (continuous-integration) on 2012-10-31
Thomi Richards: Approve (quality) on 2012-10-31
Marco Trevisan (Treviño): Approve on 2012-10-31
Barneedhar (barneedhar) wrote :
Barneedhar (barneedhar) wrote :
Omer Akram (om26er) on 2012-08-12
description: updated
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → 7.0.0
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
John Lea (johnlea) on 2012-10-11
summary: - Launcher tooltip should not appear when keyboard overlay is shown
+ [regression] Launcher tooltip should not appear when keyboard overlay is
+ shown
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
tags: added: udp
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily12.12.05-0ubuntu1

---------------
unity (6.12.0daily12.12.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/control:
    - Update Vcs-Bzr
  * Automatic snapshot from revision 2905 (bootstrap)
    - Hide launcher tooltip once shortcut overlay appears (LP: #1035860)
    - Update shortcut overlay design (LP: #1049601)
    - Don't cut off shadow on launcher icon drag window (LP: #765715)
    - Provide more immediate feedback when clickong on launcher (LP: #893140)
    - Decorate spread windows in switcher (LP: #838222)
    - Make sure to initialize a variable before it can be used (LP: #1073516)
    - Fix FTBFS due to BAMF API change (LP: #1077937)
    - Run gtest during build (LP: #133637)
    - Make shopping lens test more robust (LP: #1077131)
    - Fix some random autopilot test failures (LP: #1078448)
    - Fix autopilot tests for details mode (LP: #1073892)
    - Fix autopilot tests for indicator-session (LP: #1075350)
    - Fix autopilot tests for non-English locales (LP: #1075898)

  [ Didier Roche ]
  * debian/control:
    - adding libgtest-dev and google-mock build-dep now that there are in main
      (LP: #1076763)
    - add libunity-core -> unity-common dep (LP: #1079132)
    - do not have unity-common dep on compiz-gnome: the migration code is only
      ran if compiz-gnome is installed, but compiz-gnome is pulled by compiz
      directly. We don't care if the migration code isn't executed.

  [ bschaefer ]
  * Ported to nux 4.0

  [ Ricardo Salveti de Araujo ]
  * Doesn't need to depend on gcc 4.6 anymore (LP: #1044836)

  [ Nick Dedekind ]
  * Previews loading more than 454 lines of description text crash Unity
    (LP: #1066788)

  [ Brandon Schaefer ]
  * unity::TimeUtil::TimeDelta returns an int value which overflows
    after 24 days of uptime (LP: #806248)
  * Top panel "tooltip" is gone (regression) (LP: #1085045)
  * Dash - Implement *overlay scrollbars* in Dash. Existing scrollbars
    are too thin to grab on to. (LP: #608124)

  [ Andrea Azzarone ]
  * Dash - Regression: Clicking between filter label and 'All' button no
    longer toggles filter label (LP: #1080534)

  [ Didier Roche ]
  * libunity-core fails without the schemas from unity-common (LP:
    #1079132)

  [ Manuel de la Pena ]
  * There is no common ui element that behaves like a url link (LP:
    #1067705)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 2956
 -- Automatic PS uploader <email address hidden> Wed, 05 Dec 2012 09:27:29 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers